Bug 54896 - Red Hat init scripts are in wrong order
Red Hat init scripts are in wrong order
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 15:59 EDT by Need Real Name
Modified: 2014-03-16 22:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-22 15:59:02 EDT
Description of Problem:

Red Hat init scripts are all started in the wrong order.  I've entered bugs
about this before.  My specific problem is that when autofs is started, it
doesn't look at NIS maps, because NIS hasn't been started yet!  So no NIS
automaps are looked at.  I'm not a casual user of red hat, I use it in the
enterprise and have been doing so for years.  This has always been a problem...

You guys have GOT to do a better job of looking at dependencies when
determining the order of your init scripts.

Another example of this, which I came across while looking for this bug to
be reported.  In bug #53981 for example, the user's NIS automaps are not
being used, because the PCMCIA cards haven't been initialized yet.

Let me give you a clue: you have to initialize services which other
services will depend upon before you initialize the dependent services! 
Otherwise they will not work!

Here's an even better clue:

1. Start kernel (no, that's not an init script)
2. Initialize all hotplug hardware (like PCMCIA and USB devices)
3. Initialize network Interfaces (including PCMCIA interfaces)
4. Start network services that other services will need to work properly,
like NIS, DNS, etc.
5. Start all other (dependent) services

If you don't do this, things will not work.  It's really that simple.  You
are currently using the order  1->3->5->2->4 or something like that. 
That's just screwy.  You can't initialize your network before all your
interface drivers are loaded!  C'mon people, it's just common sense!

Version-Release number of selected component (if applicable):

ALL

How Reproducible:

ALWAYS

Steps to Reproduce:
1. Run Red Hat Linux
2. Use all components
3. Watch stuff break

Actual Results:

Services will not start, or not start properly

Expected Results:

Stuff should work properly!


Additional Information:
Comment 1 Need Real Name 2001-10-22 16:08:22 EDT
P.S. when I say in the first paragraph that "this has always been a problem,"
I'm referring to the poor ordering of your init scripts, not specifically NIS
being started out of order.  You did actually get that one right, in the past.
Comment 2 Bill Nottingham 2005-09-29 15:17:38 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

Realistically, this will be fixed by moving to a dependency based-system; it
probably won't be changed in the current chkconfig system.

Note You need to log in before you can comment on or make changes to this bug.