Bug 548997 - SELinux is preventing /usr/libexec/gdm-session-worker "getattr" access on /root/.dmrc.
Summary: SELinux is preventing /usr/libexec/gdm-session-worker "getattr" access on /ro...
Keywords:
Status: CLOSED DUPLICATE of bug 543970
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:38ff7dfefb3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-19 21:37 UTC by Gene Snider
Modified: 2009-12-21 15:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-21 15:31:16 UTC


Attachments (Terms of Use)

Description Gene Snider 2009-12-19 21:37:15 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-session-worker "getattr" access on
/root/.dmrc.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gdm-session-wor. It is not expected that this
access is required by gdm-session-wor and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root/.dmrc [ file ]
Source                        gdm-session-wor
Source Path                   /usr/libexec/gdm-session-worker
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.28.1-25.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-55.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.6-166.fc12.x86_64 #1 SMP
                              Wed Dec 9 10:46:22 EST 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Mon 14 Dec 2009 04:25:22 PM PST
Last Seen                     Mon 14 Dec 2009 04:25:22 PM PST
Local ID                      3c57a17e-661f-4c7d-909d-feb55126a050
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1260836722.556:21293): avc:  denied  { getattr } for  pid=1546 comm="gdm-session-wor" path="/root/.dmrc" dev=dm-1 ino=76691 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1260836722.556:21293): arch=c000003e syscall=4 success=yes exit=0 a0=12addd0 a1=7fff295a6320 a2=7fff295a6320 a3=1 items=0 ppid=1433 pid=1546 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="gdm-session-wor" exe="/usr/libexec/gdm-session-worker" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-55.fc12,catchall,gdm-session-wor,xdm_t,admin_home_t,file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file getattr;

Comment 1 Daniel Walsh 2009-12-21 15:31:16 UTC

*** This bug has been marked as a duplicate of bug 543970 ***


Note You need to log in before you can comment on or make changes to this bug.