Bug 549065 - Elantech touchpad detected as Logitech Mouse
Elantech touchpad detected as Logitech Mouse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-20 04:06 EST by Cosmin Deaconu
Modified: 2011-11-12 12:28 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-07 00:14:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 123775 None None None Never

  None (edit)
Description Cosmin Deaconu 2009-12-20 04:06:01 EST
Description of problem:
The Elantech touchpad in my Dell Mini 10 is detected as a logitech mouse, making touchpad configuration impossible (it is super sensitive to tapping and does not turn off while typing which results in me being very angry while typing).  

Version-Release number of selected component (if applicable):
kernel version: 2.6.30.9-102.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Boot 
2. lshal | grep Logitech
  
Actual results:
  info.product = 'ImPS/2 Logitech Wheel Mouse'  (string)
  input.product = 'ImPS/2 Logitech Wheel Mouse'  (string)
  info.vendor = 'Logitech, Inc.'  (string)
  usb_device.vendor = 'Logitech, Inc.'  (string)
  usb.vendor = 'Logitech, Inc.'  (string)
  info.product = 'Logitech USB Optical Mouse'  (string)
  input.product = 'Logitech USB Optical Mouse'  (string)

Expected results:
Nothing, it should be an elantech touchpad. 

Additional info:

In drivers/input/mouse/elantech.c, there are some comments indicating that Logitech mice respond to similar detection knocks as elantech touchpads...that's probably the root of the problem...
Comment 1 Andrew Overholt 2009-12-21 14:05:14 EST
The same thing happens on my ASUS UL30A-A2 laptop.  Is there a way to trick the kernel into seeing it?
Comment 2 Andrew Overholt 2009-12-21 14:18:20 EST
Cosmin, is this still present on F-12?  It is for me, so please move the version to 12 if it is for you as well.  Thanks.
Comment 3 Cosmin Deaconu 2009-12-21 15:39:41 EST
I haven't tried F12 on my netbook because it has a GMA 500 and I'm unsure if the poulsbo driver will work on F12...   

As for tricking the kernel, the place to do that would probably be in drivers/input/mouse/elantech.c:elantech_detect ...
Comment 4 Tapani Mattila 2010-01-01 19:03:43 EST
Confirmed with Asus X66IC-JX011V & F12 (X86_64). From what I can see in various forums, this concerns all or most new Asus laptops.
Comment 5 Tapani Mattila 2010-01-11 14:33:31 EST
Cosmin, could you try this with a F12 live CD/DVD?

If not, we should copy this to a new report and assign it to F12, but that sounds a bit unnecessary spamming of the bug database.
Comment 6 Cosmin Deaconu 2010-01-13 21:06:38 EST
Problem confirmed in F12 w/ liveusb.
Comment 7 Dag 2010-01-28 07:16:08 EST
confirmed on Asus N71VN with F12 x86_64:
Kernel: 2.6.31.12-174.2.3.fc12.x86_64

lshal:
udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input'
  info.capabilities = {'input', 'input.mouse'} (string list)
  info.category = 'input'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port'  (string)
  info.product = 'ImPS/2 Logitech Wheel Mouse'  (string)
  info.subsystem = 'input'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port_logicaldev_input'  (string)
  input.device = '/dev/input/event5'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX3_port'  (string)
  input.product = 'ImPS/2 Logitech Wheel Mouse'  (string)
  input.x11_driver = 'evdev'  (string)
  linux.device_file = '/dev/input/event5'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  linux.sysfs_path = '/sys/devices/platform/i8042/serio4/input/input5/event5'  (string)


Xorg.0.log:
(II) config/hal: Adding input device ImPS/2 Logitech Wheel Mouse
(**) ImPS/2 Logitech Wheel Mouse: always reports core events
(**) ImPS/2 Logitech Wheel Mouse: Device: "/dev/input/event5"
(II) ImPS/2 Logitech Wheel Mouse: Found 3 mouse buttons
(II) ImPS/2 Logitech Wheel Mouse: Found scroll wheel(s)
(II) ImPS/2 Logitech Wheel Mouse: Found relative axes
(II) ImPS/2 Logitech Wheel Mouse: Found x and y relative axes
(II) ImPS/2 Logitech Wheel Mouse: Configuring as mouse
(**) ImPS/2 Logitech Wheel Mouse: YAxisMapping: buttons 4 and 5
(**) ImPS/2 Logitech Wheel Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "ImPS/2 Logitech Wheel Mouse" (type: MOUSE)
(**) ImPS/2 Logitech Wheel Mouse: (accel) keeping acceleration scheme 1
(**) ImPS/2 Logitech Wheel Mouse: (accel) acceleration profile 0
(II) ImPS/2 Logitech Wheel Mouse: initialized for relative axes.

really annoying, as we can't have any control over the touchpad.

Bye for now
Comment 8 Tapani Mattila 2010-06-20 03:17:34 EDT
I still suffer from this in F13.
Comment 9 Cosmin Deaconu 2010-07-23 02:54:00 EDT
It looks like there is a possible fix for this? https://bugs.launchpad.net/ubuntu/+source/linux/+bug/418282
Comment 10 Chuck Ebbert 2010-07-23 12:08:49 EDT
(In reply to comment #9)
> It looks like there is a possible fix for this?
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/418282    

Those fixes are all in 2.6.34; you can get a 2.6.34.1 kernel for F-13 from koji. We'll probably not fix this in F-12 at this point.
Comment 11 Cosmin Deaconu 2010-07-27 01:11:39 EDT
Hi, I upgraded to F13 and installed the newest 2.6.43.1 kernel off koji and I still have this issue... is there something I need to do in addition to installing the updated kernel?
Comment 12 Jonathan 2010-08-11 08:28:09 EDT
Same here. I'm running F13 with 2.6.34.3-37.fc13.x86_64 from updates-testing.
The Elantech trackpad is still recognized as a Logitech ps/2 mouse.
Comment 13 Cheng 2010-08-11 21:49:31 EDT
Still can't fix this with my ASUS K50AD laptop in F12. you mean I should compile my own kernel-2.6.34 or kenrel-2.6.35?
Comment 14 Jonathan 2010-08-12 07:14:07 EDT
No, you just update your system with yum. Kernel 2.6.34 is not stable yet so you need to enable repository "updates-testing". I would advise waiting with using this kernel until it is in the normal updates repository. I tried it yesterday and while it made the touchpad work, it crashed several times. I'm now running 2.6.33 again until 2.6.34 has matured some more.

If you still want to test it, here's the command:
#sudo yum update --enablerepo=updates-testing kernel

2.6.34 still didn't detect my Elantech touchpad automatically (laptop Asus UL50VT) but it has the option to force identify it by passing kernel option "psmouse.force_elantech=1" in the grub menu.

This bug might be a duplicate:
https://bugzilla.redhat.com/show_bug.cgi?id=556229
Comment 15 Jonathan 2010-08-12 07:17:02 EDT
Sorry, I just noted you wrote F12. I'm not sure 2.6.34 will be available for F12, only F13. Compiling kernels is a bit above my head.

why not upgrade to F13? 
#preupgrade
Comment 16 Cheng 2010-08-12 11:19:54 EDT
(In reply to comment #15)
> Sorry, I just noted you wrote F12. I'm not sure 2.6.34 will be available for
> F12, only F13. Compiling kernels is a bit above my head.
> 
> why not upgrade to F13? 
> #preupgrade    

Yep, it works with the kernel option "psmouse.force_elantech=1". Thx.
Comment 17 Cosmin Deaconu 2010-08-17 14:28:21 EDT
psmouse.force_elantech=1 works for me too =)
Comment 18 Dag 2010-09-04 13:59:13 EDT
This bug is still not fixed (touchpad detected as Logitech PS/2 mouse) with the new 2.6.34 kernel :
# uname -r
2.6.34.6-47.fc13.x86_64

It is still detected as a Logitech PS/2 mouse.



It works with the fix:
psmouse.force_elantech=1

Bye for now
Comment 19 sok 2010-10-09 10:38:17 EDT
I have the same issue on an asus K52F-SX139X

kernel : 2.6.34.7-56.fc13.i686
Comment 20 sok 2010-10-09 11:03:16 EDT
Idownloaded fedora 14 and tested it succefully.

maybe a backport can fix it?
Comment 21 Dag 2011-04-13 04:54:38 EDT
I confirm that an upgrade to Fedora 14 has fixed this issue : no need for any "fix" on the grub's kernel line.
(kernel 2.6.35.11-83.fc14.x86_64)

Dag
Comment 22 terrance wickman 2011-11-12 12:28:33 EST
This still occurs on Fedora 16. Happens to newest model Elan smartpads.

dmesg | grep input

Resulted in:

[    2.297035] input: PS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input4

Note You need to log in before you can comment on or make changes to this bug.