Bug 54908 - Sound server fatal error
Sound server fatal error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 21:12 EDT by Mike Chambers
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 08:51:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backtrace or Traceback file (2.62 KB, text/plain)
2001-10-22 21:16 EDT, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2001-10-22 21:12:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
KDE set to auto login with normal user account.  Get error message once 
KDE loads, I believe when the sound server is trying to start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reboot
2.Login to KDE as normal user
3.
	

Actual Results:  Get error message stating..
"Sound server fatal error: cpu overload, aborting"

Expected Results:  KDE sound server, aRts should start up without error.

Additional info:

Sound system is on an eMachine, I810 chipset.
Comment 1 Mike Chambers 2001-10-22 21:16:52 EDT
Created attachment 34661 [details]
Backtrace or Traceback file
Comment 2 Bernhard Rosenkraenzer 2001-10-23 07:57:48 EDT
By any chance, are you on a relatively slow CPU and running lots of other 
things in the background? artsd will fail with that message if your CPU can't 
handle its load at the moment (I'm seeing this message when starting KDE when 
the system load is already at 10).
Comment 3 Mike Chambers 2001-10-23 17:24:04 EDT
It's a Celeron 766 w/512M RAM on an eMachine.  There aren't really any other 
programs running besides KDE starting up except xinetd, sendmail, httpd, atd, 
anacron, crond, gpm, identd,keytable, kudzu, sshd, ntpd, network, portsentry, 
rhnsd, sgi_fam, smb, syslog, and xfs.

What exactly are you doing to get a 10 at system load?  As in what command to 
see that?
Comment 4 Maciej Kycler 2001-11-07 05:27:55 EST
I confirm. My machine is Intel Celeron 128 MB RAM.
This started to happen after upgrading to kernel 2.4.9-7 (still exist with
2.4.9-13 kernel) via RedHat Network.
System works fine with genuine 2.4.7-10 kernel that comes with RH 7.2 CDs.
Comment 5 Need Real Name 2001-11-13 01:36:22 EST
I can confirm the same issue on a Compaq AP250, Genuine Intel P3-866 with 256MB
ECC RAMBUS memory.  Compaq product specs for the PC at
"http://www.compaq.com/products/quickspecs/10438_na/10438_na.HTML".

The system ran fine under original Red Hat 7.1 installation and after upgrading
to the Red Hat Linux v7.2 (enigma) distribution.  After running up2date and
downloading/installing all updates logging into KDE produces the same "Sound
server fatal error, CPU overload, aborting" error message.  This then causes
knotify to fail and produce a SIGNAL 6.  Trying to play a sound with the KDE
media player produces the same error.

Logging into GNOME and enabling the sound seems to work OK.  Switching to run
level 3 I can play sounds with the play command line utility but launching
startx from run level 3 results in the same sound error on KDE startup as
logging in under run level 5.  If I switch from the newer 2.4.9-13 kernel back
to the original 2.4.7-10 kernal then everything works OK.
Comment 6 Need Real Name 2002-01-03 01:15:04 EST
Yes, also confirmed.  eMachines 1090 with 256M of RAM, Celeron 900.  Not much 
going on when KDE starts, only thing I have started is httpd/mysqld.  Worked 
fine with 2.4.7-10, stopped working when 2.4.9-13 kernel installed via up2date.
Comment 7 carl 2002-01-30 11:51:03 EST
We are also experiencing this problem on an AMD Athlon 1.4GHz with 512 MB RAM and a Creative SoundBlaster 128 PCI (ES1371) sound card. We don't know if it worked with kernel 2.4.7 since when we installed Redhat 7.2 we immediately upgraded to the latest kernel using up2date before we got the sound system working.  We are using KDE desktop.
Comment 8 Need Real Name 2002-03-10 00:45:55 EST
Problem reported on Compaq AP250 with Intel i810 chipset resolved by latest run of up2date which included 2.4.9-31 kernel and 2.2.2-2 KDE 
packages.  Sound server is now functioning normally for KDE desktop.
Comment 9 Mike Chambers 2002-03-25 08:56:32 EST
I haven't seen this error/bug in Skipjack public beta 1 as of yet, although I 
don't use it as a workstation except right after install to configure it as a 
server then I go to init-3.

Anyone else getting any errors on this one in the beta?
Comment 10 Barry Wright 2002-07-11 21:38:31 EDT
We have experienced the problem on machines that use the I810 chipset, kernel
2.4.9-13, kde 2.2.2-2. artsd increases it's use of cpu resources in the first 20
- 30 sec until the error appears and artsd dies with a 6 (SIGABRT), other cpu
intensive processes can slow down the rate of artsd resource useage. Moving down
to 2.4.7-10 or up to 2.4.9-31 cures the problem. Same spec machines with
soundblaster or via82 cards and 2.4.9-13 do not have the same problem.
Comment 11 Ngo Than 2004-09-29 08:51:12 EDT
i cannot reproduce it with a newer version of Red Hat Enterprise Linux
or Fedora Core. it's fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.