Bug 549088 - ipv6 breaks yum
ipv6 breaks yum
Status: CLOSED DUPLICATE of bug 548269
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2009-12-20 06:29 EST by Lennart Poettering
Modified: 2014-01-21 18:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-20 19:47:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-12-20 06:29:43 EST
yum is complete broken for me on rawhide.

$ sudo yum upgrade
[sudo] password for lennart: 
Loaded plugins: refresh-packagekit, refresh-updatesd
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rawhide. Please verify its path and try again

With wireshark I found out that apparently a AAAA DNS lookup is done for the yum repo server, which is successful, but that's it. I presume that yum tries to connect to that AAAA server which fails since I lack IPv6 connectivity. And then yum does not try IPv4 as fallback.

Is there any quick workaround available that allows me to tell yum not to try ipv6 connections at all?

I even disabled ipv6 in the kernel to no success, yum still only tries the ipv6 connection which of course fails completely, too.
Comment 1 seth vidal 2009-12-20 12:26:57 EST
Roll back curl to the earlier version from f12-GA and it'll work.

reassigning to curl since this is b/c of that update
Comment 2 Kamil Dudka 2009-12-20 15:22:58 EST
(In reply to comment #0)
> Is there any quick workaround available that allows me to tell yum not to try
> ipv6 connections at all?

Seth, is there such a workaround? It would be still good to have one for the next iteration ;-) It's hard to do an update of curl once yum is already broken...

(In reply to comment #1)
> Roll back curl to the earlier version from f12-GA and it'll work.

Why? I am not aware of any bug reports by curl-7.19.7-4.fc13.

I've just restored the behavior of the last working release to unblock yum.

Let's recall who was asking for c-ares 5 months ago - bug 514771.

> reassigning to curl since this is b/c of that update

It makes no sense to have two open bugs against curl addressing the same issue. Just close it as duplicate of bug 548269 if yum developers are not going to change anything within yum.
Comment 3 seth vidal 2009-12-20 19:06:26 EST
(In reply to comment #2)
> 
> Seth, is there such a workaround? It would be still good to have one for the
> next iteration ;-) It's hard to do an update of curl once yum is already
> broken...

If you disable ipv6 on the host then it will work.

 
> (In reply to comment #1)
> > Roll back curl to the earlier version from f12-GA and it'll work.
> 
> Why? I am not aware of any bug reports by curl-7.19.7-4.fc13.

Fine - the last version I KNEW was safe was f12-ga. That's why I reassignedit.

 
> I've just restored the behavior of the last working release to unblock yum.
> 
> Let's recall who was asking for c-ares 5 months ago - bug 514771.

Absolutely. I still want c-ares resolution support. I just want it to work with ipv6, too.

 
> > reassigning to curl since this is b/c of that update
> 
> It makes no sense to have two open bugs against curl addressing the same issue.
> Just close it as duplicate of bug 548269 if yum developers are not going to
> change anything within yum.  


I didn't know the bug number, I reassigned it to curl so you can handle it however you normally do. This is the normal process we follow with bugs filed against anaconda that are yum bugs or vice-versa.

finally, I'm not sure what yum should do here. Ipv6 support SHOULD work once the bugs are fixed. Disabling it at the yum layer seems like the wrong place to fix it.

thanks
Comment 4 Kamil Dudka 2009-12-20 19:29:37 EST
(In reply to comment #3)
> If you disable ipv6 on the host then it will work.

Have you tried it yourself? comment #0 says otherwise.

> Absolutely. I still want c-ares resolution support. I just want it to work with
> ipv6, too.

Working IPv6 name resolving actually triggers the bug. What we need, is a fallback to IPv4 in case of broken IPv6 network. Patches are welcome ;-)

> I didn't know the bug number, I reassigned it to curl so you can handle it

Now you know the bug number, feel free to close it if there is nothing to be done from the yum's part.
Comment 5 seth vidal 2009-12-20 19:47:59 EST

*** This bug has been marked as a duplicate of bug 548269 ***

Note You need to log in before you can comment on or make changes to this bug.