Bug 54911 - X server fails in vmware guest
X server fails in vmware guest
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://www.contrib.andrew.cmu.edu/~cg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 23:50 EDT by Chaskiel Grundman
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-22 23:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chaskiel Grundman 2001-10-22 23:50:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9 i686; Nav)

Description of problem:



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install rh7.2 inside a vmware guest
2. run startx

Actual Results:  X and gnome should start up

Expected Results:  the server aborts. Relevant error text is:
Symbol mfbQueryBestSize from module
/usr/X11R6/lib/modules/drivers/vmware_drv.o
 is unresolved!

...
        This should not happen!
        An unresolved function was called!

Fatal server error

Additional info:

Adding 
Load "mfb"
to the Modules section allows the X server to start.
(It crashes soon after that, but that may be because I'm using a beta
of vmware 3. The problem in _this_ report shouldn't be dependent on that)
Comment 1 Chaskiel Grundman 2001-10-23 00:36:23 EDT
It looks like this is actually an upstream issue in 4.1.0.
Silly me.

Note You need to log in before you can comment on or make changes to this bug.