Bug 54912 - FTP option not working with RPM
Summary: FTP option not working with RPM
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-23 04:11 UTC by Thomas Chung
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 18:01:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Chung 2001-10-23 04:11:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
Just installed a Red Hat 7.2 final version.
When I tried to install a rpm package using rpm command with FTP option 
over network, it fails to do so.  It doesn't give any error message and it 
simply ignores my command. Is this a bug?  
Please try rpm -Uvh ftp://<any-ftp-server>/<any-rpm-package>.rpm 

ps. "rpm -q rpm" shows version rpm-4.0.3-1.03

Version-Release number of selected component (if applicable):
rpm-4.0.3-1.03

How reproducible:
Always

Steps to Reproduce:
1. Fresh install Red Hat 7.2
2. Try any rpm pakcage install over network using ftp option
ex) rpm -Uvh ftp://<any-ftp-server>/<any-rpm-package>.rpm 
3. It fails to install rpm package over network. It simply ignores.
	

Actual Results:  It doens't install rpm package over network.

Expected Results:  It supposed to install rpm packaage over network as if 
it's been installing locally.

Additional info:

- Installing RPM package over network used work just fine on RH 7.0 and RH 
7.1
- I have installed Red Hat 7.2 on two different machines and got the same 
result.

Comment 1 Michael Schwendt 2001-10-23 16:45:37 UTC
Works for me. 

Can you provide the output of "rpm -Uvvh
ftp://<any-ftp-server>/<any-rpm-package>.rpm"? (note the double "v")

Comment 2 Jeff Johnson 2001-10-23 16:51:34 UTC
Remote globbing (i.e. '*') is/was broken in rpm-4.0.3-1.03, fixed in
rpm-4.0.3-1.04, will be in rpm-4.0.3 final.

Comment 3 Thomas Chung 2001-10-23 18:01:15 UTC
It says following when I used "vv" option

# rpm -Uvvh ftp://<ftp-server>/<package-name>*
D: logging into <ftp-server> as ftp, pw (username)
D: found 0 source and 0 binary packages
# 

Howe ever, it DID work for me if I specify a complete package name ends with 
".rpm"  

It seems "rpm-4.0.3-1.03" doesn't support wild card option (*) when you try ftp 
rpm installation.

Comment 4 Jeff Johnson 2001-10-23 18:23:05 UTC
As I said:
	This problem is already fixed in rpm-4.0.3-1.04.

Comment 5 Thomas Chung 2001-10-23 18:27:47 UTC
Thank you Jeff! When and where will new version of rpm be available?

Comment 6 Michael Schwendt 2001-10-23 22:00:28 UTC
Until there'll be an errata update for rpm (if there'll be any), you can try the
fixed albeit experimental package from Raw Hide at your own risc.

ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/
(or your favourite mirror)

Be sure to check out this:
ftp://rawhide.redhat.com/pub/redhat/linux/rawhide/README



Note You need to log in before you can comment on or make changes to this bug.