Bug 549122 - Regression: wrong name used when adding new file
Regression: wrong name used when adding new file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: patch (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 517509 550319
  Show dependency treegraph
 
Reported: 2009-12-20 09:37 EST by Robert Scheck
Modified: 2010-01-12 18:50 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 550319 (view as bug list)
Environment:
Last Closed: 2010-01-12 18:33:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2009-12-20 09:37:23 EST
Description of problem:
Regression: Suffix inside of new files of patch files are added to new files.
Take http://cvs.fedoraproject.org/viewvc/devel/popt/popt-1.13-multilib.patch
for example for reproducing:

With patch-2.6-1, "%patch0 -p1 -b .multilib" causes:
-rw-r--r-- 1 tux tux 256 Dec 20 15:26 footer_no_timestamp.html.multilib
-rw-r--r-- 1 tux tux   0 Dec 20 15:26 footer_no_timestamp.html.multilib.multilib

-rw-r--r-- 1 tux tux 51543 Dec 20 15:26 Doxyfile.in
-rw-r--r-- 1 tux tux 51519 May 25  2007 Doxyfile.in.multilib

With patch-2.5.4-36, "%patch0 -p1 -b .multilib" causes:
-rw-r--r-- 1 tux tux 256 Dec 20 15:32 footer_no_timestamp.html
---------- 1 tux tux   0 Dec 20 15:32 footer_no_timestamp.html.multilib

-rw-r--r-- 1 tux tux 51543 Dec 20 15:32 Doxyfile.in
-rw-r--r-- 1 tux tux 51519 May 25  2007 Doxyfile.in.multilib

You see what I mean? If the file is created by the patch file, the suffix
inside of the patch is appended to the new created file. That behaviour has
been introduced with the new version and it looks like a regression to me.

Version-Release number of selected component (if applicable):
patch-2.6-1
patch-2.5.4-36

How reproducible:
Everytime, see above.

Actual results:
Regression: Suffixes inside of patches at new files are added to new files

Expected results:
Good old behaviour like at patch-2.5.4-36.
Comment 1 Tim Waugh 2009-12-21 05:17:27 EST
Verified.

Affects F-12 and F-11 as well.
Comment 2 Tim Waugh 2009-12-21 11:44:02 EST
Reported upstream:
  https://savannah.gnu.org/bugs/index.php?28367
Comment 3 Fedora Update System 2009-12-24 09:11:56 EST
patch-2.6-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/patch-2.6-2.fc11
Comment 4 Fedora Update System 2009-12-24 09:12:36 EST
patch-2.6-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/patch-2.6-2.fc12
Comment 5 Robert Scheck 2009-12-24 11:30:33 EST
Tim, thank you for solving the issue. The patch fixes it.
Comment 6 Fedora Update System 2009-12-25 03:23:02 EST
patch-2.6-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update patch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13699
Comment 7 Fedora Update System 2009-12-25 03:25:19 EST
patch-2.6-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update patch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13713
Comment 8 Fedora Update System 2010-01-05 17:46:36 EST
patch-2.6.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update patch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13699
Comment 9 Fedora Update System 2010-01-05 17:46:41 EST
patch-2.6.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update patch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13713
Comment 10 Fedora Update System 2010-01-12 18:33:17 EST
patch-2.6.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2010-01-12 18:50:31 EST
patch-2.6.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.