Bug 54931 - Total System freeze
Total System freeze
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-10-23 07:20 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-06-07 14:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-23 07:20:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
My sytem freezes after certan time of use, could be 3 Minutes after login,
or maybe 2 hours. You are not beeing able to switch to any of the consoles.
The only possibility is a reset of the machine.
Partitions are / in ext3 /boot in ext3 swap and a /vfat in vfat on a 9 Gig
SCSI U2W HD on a Symbios SCSI controller. 
/var/log/messages does not report anyting :-( can not trace it back.... but
happens all the time.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Run machine

Additional info:
Comment 1 Havoc Pennington 2001-10-23 11:30:30 EDT
System freezes pretty much have to be kernel or X problems.
Comment 2 Arjan van de Ven 2001-10-23 11:33:21 EDT
1) which kernel (version, smp/up etc)
2) can you attach lspci output so I can get an idea what hardware is present
Comment 3 sahag 2001-10-23 18:24:58 EDT
I also have the same problem with RH 7.2
I suspected that it was GNOME who was freezing my system so I switched to KDE
now it does not freeze anymore
when I was using GNOME it used to freeze every  few hours.
I use IBM ThinkPad T20 2637

Comment 4 sahag 2001-10-25 15:04:21 EDT
I have some more information about this bug.
It is definitely related to GNOME somehow.
When I start GNOME and then leave my computer for a few hours it _always_ 
freezes in a matter of hours. I can't even ping the computer.
mouse and keyboard are dead. only rebooting the computer helps.
on the other hand i used KDE for a few days and nights without shutting down the 
computer and I _never_ had any problems with it.
I will attach my lspci


Comment 5 sahag 2001-10-25 15:08:05 EDT
it is an IBM Thinkpad T20 2647 RR3 laptop.

00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 09)
00:03.1 Serial controller: Xircom: Unknown device 000c
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear 
SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/MX-/IX (rev 11)

Comment 6 sahag 2001-10-25 15:31:23 EDT
I am using kernel-2.4.9-7.i686 .rpm

Comment 7 borgia 2001-10-31 02:37:53 EST
Same here on a Compaq Deskpro with same kernel.
X is running, but just the login screen is present, all activity was on text consoles.
Freeze appens from a few minutes to a few hours after startup and with almost no disk activity.
Comment 8 Jeremy Linden 2001-11-11 18:50:41 EST
I have had this problem too.  I use GNOME.  When it freezes I cannot do anything
at all and the system stops responding to both local events and network
requests, including ping.  The only remedy is to do a hard reboot by pressing
the reset switch or (if sysrq is on) pressing Alt-Sysrq-B.  I am running a PII
450 with 128 MB of RAM and a RIVA TNT 16MB video card.  I was running kernel
2.4.9-7, and am now running 2.4.9-13.  The problem happens with both kernel
versions.  I have been running all previous versions of RedHat since 6.2 and
have not seen this problem since I have upgraded to 7.2.
Comment 9 sahag 2001-11-13 00:56:00 EST
I think there are different bugs listed here, but I found the solution to the
system freeze which happens under GNOME.
After I disabled xscreensaver my system stopped to freeze.
So the system freeze is somehow connected to xscreensaver package.

I think the status of this bug has to be changed.
Comment 10 Jeremy Linden 2001-11-13 16:10:07 EST
I don't think that xscreensaver is the issue.  It freezes even without it
running.  It tends to freeze for me when I am in Mozilla (although this may be
coincidental because I use Mozilla a lot.  It never happens when I am not using
the computer, always when I am active.
Comment 11 Need Real Name 2001-11-14 13:14:51 EST
I have just installed Red Hat 7.2 on my Compaq Presario laptop. I got the 
freezing problem too, but mine appears to be more fundamental than an X 
problem. Shortly after booting into text mode (before going in to X) I'll get a 
Kernel panic with a message something like:

Unable to handle kernel NULL pointer deference at virtual address 00000028

then some kind of a dump followed by a freeze

This appears to happen at some arbitary time after booting, and some of the 
message scrolls off. I think it may have something to do with virtual memory

Comment 12 Frank Worsley 2001-11-15 21:36:16 EST
I am having the very same problem on an Athlon system. It was suggested that I
try adding the 'noathlon' kernel option. Everyone who has an Athlon should try
that too, maybe it will fix the problem.
To add the option edit your /etc/grub.conf file and add the word 'noathlon'
without the quotes at the end of the 'kernel' line.
Comment 13 Frank Worsley 2001-11-15 22:03:44 EST
Crap, it didn't work. System crashes again after 20 minutes, even with the
noathlon option. :(
Comment 14 Need Real Name 2001-11-16 15:59:58 EST
Check out this thread - it looks like for me at least it could be a problem 
with linux trying to find the cache size, etc for my processor (AMD Duron). 
Exactly the same problem


Comment 15 Need Real Name 2001-11-19 11:21:20 EST
I have this problem (or something very like it) If I run Gnome I get a system 
freeze if I open a shell window.

If I run KDE I get a system freeze if I resize a shell window. The system also 
freezes randomly with no apparent cause that I can determine. The two actions 
above will freeze it everytime however.
Comment 16 Need Real Name 2001-11-20 09:38:11 EST
Ah! I think I've solved it for my machine anyway. Some browsing on the web 
indicated the problem could be with the AMD Duron chip in my machine, and the 
solution worked for me. Here is what to do:

1. In GRUB, type e to edit the script and add:

x86_serial_nr=1 noathlon=1

to the end of the kernel line.

2. Boot up

3. Make the same change in /etc/grub.conf

Hope it works for you too! Now just got to get my modem and soundcard working...

Comment 17 Need Real Name 2001-11-23 06:20:29 EST
Try to hashmark the DRI section in /etc/X11/XF86Config-4
Should help.

Comment 18 David F 2001-12-03 04:11:11 EST
Well, I am using an Intel PIII 600/750 Speed Step.  Red Hat 7.2 On a Dell 
Inspirion 7500.  Only lockup I have noticed is when I try to record a CD with 
Firwire drive.  I am using the IEEE ohci and SBP2 modules. THats for my 
Firewire hard drive and Firewire Lacie 24 speed burner.  Anyhow when I go to 
record with X-CD-Toast My system freezes right at the point when it 
sais "OCP".  I guess when it si optically algining the lazer or whatever.  Once 
that starts then my system freezes.

Adaptec Card bus firewire card
SIIG Card Bus Firewire card
Adaptec 1460 16 bit PCMCIA card
Adaptec 1480 Card bus card

For the last two cards I tried a SCSI burner and really did not experience a 
freeze but I cannot burn a CD without a coaster.

From my experience with Red Hat 7.1 and Ximian' gnome and  Nautilus I had 
expereinced many problems but not a total lockdown.  I sitll see problems with 
MICE to.  I have to killl Xserve to stop the mouse form goin nuts.  MS mouse 
PS2 3 button and MS Mouse Intellimouse LED.

Hope that helps a little
Comment 19 Need Real Name 2001-12-03 10:22:43 EST
noathlon and latest errata kernel do not resolve the problem! Still freezes no
messages in /var/log/messages ide=nodma is not beeing an option as this system
using an Symbios Sym 21002 SCSI U2W controller. System completely updated!

Any suggestions?

Steffen Mann
Comment 20 Need Real Name 2001-12-06 19:12:56 EST
After upgrading to 7.2 my system also freezes after an unspecified amount of
time, could be 2 mins. or 1 day.  I didn't have any problems using the same
motherboard (but with a few different components) under 7.0.  Some details: it
happens more frequently under GNOME than under KDE, but it still can happen
under KDE.  It has happened with the 2.4.9-13 kernel and the stock 7.2 kernel. 
It has happened with 2 different network cards (a 3com 509B and a 3com 595) and
2 different sound cards (ensoniq CT5880 and an onboard VIA card).  All hardware
is RH-7.2 certified to the best of my knowledge.  I thought it might somehow be
related to both ACPI and APM being enabled in the BIOS (the default for my
motherboard) but I had the crash again after disabling ACPI.  I have reinstalled
7.2 with ACPI disabled when I installed (it was enabled previously), and we'll
see if that fixes the problem.  

Here is my lspci:

00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev 44)
00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev
00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 10)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev
00:0b.0 Multimedia audio controller: Ensoniq CT5880 [AudioPCI] (rev 02)
00:0f.0 Ethernet controller: 3Com Corporation 3c595 100BaseTX [Vortex]
01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)
Comment 21 Need Real Name 2001-12-07 06:50:15 EST
I've now tried 7.2 under VMWARE. To run linux under VMWARE, you have to replace 
the RH X Server with a version from VMWARE. The systems freeze bug does not 
occur with the 7.2/VMWARE combination. This points strongly to the X server 
being at fault.
Comment 22 Jeremy Linden 2001-12-26 19:14:39 EST
I have realized that the only time that this bug occurs is when I am running,
exiting, or minimizing Mozilla.  Once I switched to Pine as an e-mail client,
the freezes were greatly minimized in occurance.  It can't be just Mozilla's
fault; since everything freezes, even the network.  Maybe it's something to do
with Mozilla and X or the kernel?
Comment 23 Need Real Name 2002-01-26 13:16:03 EST
This is most likely related to the recently discovered AMD/Kernel2.4/AGP bug documented on 
Slashdot and Newsforge earlier in the week.  I've been struggling w/ seemingly random hard 
lockups ever since I upgraded to RH7.2 w/ the 2.4.x kernel.  I've not submitted any bug reports 
because I couldn't recreate the problem reliably.

The problem is NOT Mozilla-specific.  I've 
had crashes with and without Mozilla running, and it's been triggered by actions in Opera, red-
carpet, XMAME, MATLAB, Abiword, and a number of other applications on multiple machines.  (I 
have a total of 4 identically configured RH7.2/Athlon 1.4 GHz/Asus A7A systems.)

I hope that 
a 2.4 kernel patch will be made available promptly by Redhat.
Comment 24 Christian Rose 2002-01-26 13:44:33 EST
It's probably not related to any AMD processor bug since it happens on Intel
processor systems too, which I can testify myself and others have reported in
the report already.

Not a chipset problem either, I have replaced the previous Intel BX chipset
motherboard with an Intel i815 chipset-based one and the lockups still occur.
The only thing that I have tried that solves the problem is removing the
SoundBlaster Live! card (with or without replacing it with another different
sound card). Pretty much everything else in the computer is also new and replaced.
Comment 25 Jeremy Linden 2002-02-01 17:54:17 EST
Switching to KDE completely fixes it for me.  It must be something related to GNOME.  
Comment 26 Jim Shanks 2002-04-11 17:50:37 EDT
I've noticed the same problem.  My system was rock-solid under RH 7.1;  It
literally ran for months.  After upgrading to 7.2 it started locking
intermittently.  I completely wiped the drives and did a fresh install . . .
same problem.  I changed my motherboard from an unapproved "Boardrunner" to an
Epox (same VIA chipset). . . same problem.  Since my new motherboard had sound,
I removed the (much superior) Soundblaster Live! card and enabled the onboard
sound.  Problem solved.  Now I have a rock-solid system with
less-than-desireable sound.  Has to be the Soundblaster Live! and RH 7.2
combination.  By the way, I have only has success on one old system with the
"noathlon" boot option, and when I upgraded the BIOS on that system, the
"noathlon" option was no longer required.
Comment 27 Jeremy Linden 2002-04-12 15:02:35 EDT
Interesting, I have a SB Live! too, so maybe for me it's a combination of that
and RH 7.2 and GNOME.  Removing any one of the last two seems to fix the
problem, and of the three, the one that I am most willing to part with is GNOME.
Comment 28 captnmaster 2002-04-23 23:05:02 EDT
I was having the same problem with my computer. I found out there was a bug with
the default kernel driver for SoundBlaster Live! cards (bug 57564). The latest
kernel packages (2.4.9-21 and later) come with an experimental driver for these
cards. Switching to the experimental driver from the default driver has fixed
this problem for me. I know this would affect systems with audio cards that are
members of the SoundBlaster Live! family as well as the SoundBlaster PCI 512,
sind they use the same chip. I do not know if it affects any other cards. Please
refer to the bug for more details. I hope this helps.
Comment 29 Matt McParland 2002-04-24 22:49:07 EDT
I'm using a Duron on an SiS mainboard.  Whenever I compile a kernel (2.4.18 in 
this case) while running the stock RedHat-7.2 kernel (2.4.7-10), the system 
hangs and requires a hard reboot.  I'm using gcc-2.95.98 and grabbed the 
kernel source from kernel.org.

So, I tried building 2.4.18 on a different RH 7.2 machine with Intel 
processors and it worked fine.  I'm running that on the Duron box now and no 
more hangs, but I do get a segfault whenever I compile the 2.4.18 kernel.

The output of lspci for the Duron box is below:

00:00.0 Host bridge: Silicon Integrated Systems [SiS]: Unknown device 0735 
(rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] 5591/5592 AGP
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] 85C503/5513
00:02.2 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS]: Unknown 
device 7012 (rev a0)
00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 10/100 
Ethernet (rev 90)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS]: Unknown 
device 0300 (rev 90)
Comment 30 Mike A. Harris 2002-09-11 17:41:02 EDT

/me is amazed with the amount of people who have added themselves
to this report with a me-too and totally different hardware, when
it is probably an S3 Savage driver bug.  ;o)
Comment 31 Mike A. Harris 2002-09-11 17:45:35 EDT
So, does this problem still occur in RHL 7.2 with all of the latest
erratum applied, including the kernel?

What about with RHL 7.3 (if you've tested it by chance)?
Comment 32 Alan Cox 2003-06-07 14:53:32 EDT
No reply on RH 7.3 query - closing

Note You need to log in before you can comment on or make changes to this bug.