Bug 54937 - Chowning /dev/audio etc. to the 500.root is not a good thing
Chowning /dev/audio etc. to the 500.root is not a good thing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
7.2
All Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 10:25 EDT by carll
Modified: 2007-03-26 23:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 11:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carll 2001-10-23 10:25:58 EDT
Description of Problem:
I was very shocked when I installed Red Hat today;
/dev/audio, dsp, mixer etc. were all 500.root, while
I, and most other distributions would use something
like root.audio, etc.

I think slackware uses a less fine-grained system,
with only one group, 'sys', for audio, modem etc.

I guess the installation you have checkboxes like
[v] Allow to play audio
[v] Allow to use modem/serial line
[v] Allow to mount CDROM
etc., most checked by default.

Steps to Reproduce:
install rh, ls -al /dev/

Actual Results:
500.root on /dev/audio etc

Expected Results:
root.audio
Comment 1 Brent Fox 2001-10-23 14:17:44 EDT
I don't think that anaconda creates this file. Changing component to the dev
package since that's what 'rpm -qf /dev/audio' says creates this file.
Comment 2 Andreas-Johann Ulvestad 2001-10-23 14:34:48 EDT
This is indeed an annoying part. I "fix" this myself after install, but it would
however be nicer if the installer would do it automatically.

Comment 3 Bill Nottingham 2003-02-19 11:07:16 EST
We use pam_console for this. We don't use groups.

Note You need to log in before you can comment on or make changes to this bug.