Bug 549445 - [abrt] crash in calibre-0.6.26-1.fc12
Summary: [abrt] crash in calibre-0.6.26-1.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9dc80874
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-21 17:57 UTC by Boricua
Modified: 2010-06-21 13:12 UTC (History)
1 user (show)

Fixed In Version: calibre-0.6.55-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-21 13:12:14 UTC


Attachments (Terms of Use)
File: backtrace (1.89 KB, text/plain)
2009-12-21 17:57 UTC, Boricua
no flags Details

Description Boricua 2009-12-21 17:57:18 UTC
abrt 1.0.1 detected a crash.

How to reproduce
-----
1.Open calibre.
2.Request the program to fetch elpais.com newspaper.
3.After a while trying to download elpais.com, calibre crashes.

Comment: A download from cnn.com does work.

backtrace
-----
Summary: TB9dc80874 stylizer.py:287:_normalize_font:AttributeError: 'module' object has no attribute 'validate'

Traceback (most recent call last):
  File "/usr/bin/calibre-parallel", line 18, in <module>
    sys.exit(main())
  File "/usr/lib64/calibre/calibre/utils/ipc/worker.py", line 89, in main
    result = func(*args, **kwargs)
  File "/usr/lib64/calibre/calibre/gui2/convert/gui_conversion.py", line 21, in gui_convert
    plumber.run()
  File "/usr/lib64/calibre/calibre/ebooks/conversion/plumber.py", line 811, in run
    flattener(self.oeb, self.opts)
  File "/usr/lib64/calibre/calibre/ebooks/oeb/transforms/flatcss.py", line 122, in __call__
    self.stylize_spine()
  File "/usr/lib64/calibre/calibre/ebooks/oeb/transforms/flatcss.py", line 146, in stylize_spine
    extra_css=css)
  File "/usr/lib64/calibre/calibre/ebooks/oeb/stylizer.py", line 165, in __init__
    rules.extend(self.flatten_rule(rule, href, index))
  File "/usr/lib64/calibre/calibre/ebooks/oeb/stylizer.py", line 219, in flatten_rule
    style = self.flatten_style(rule.style)
  File "/usr/lib64/calibre/calibre/ebooks/oeb/stylizer.py", line 239, in flatten_style
    style.update(self._normalize_font(prop.cssValue))
  File "/usr/lib64/calibre/calibre/ebooks/oeb/stylizer.py", line 287, in _normalize_font
    if cssprofiles.validate(key, value):
AttributeError: 'module' object has no attribute 'validate'

Local variables in innermost frame:
style: {}
self: <calibre.ebooks.oeb.stylizer.Stylizer object at 0x540fd50>
cssvalue: <cssutils.css.CSSValueList object cssValueType='CSS_VALUE_LIST' cssText=u'sans-serif large' propname=u'font' valid=False at 0x5472b50>
value: sans-serif
key: font-style
v: <cssutils.css.CSSPrimitiveValue object primitiveType=CSS_IDENT cssText=u'large' _propertyName=None valid=False at 0x5472c50>
primitives: [u'large']
composition: ('font-style', 'font-variant', 'font-weight', 'font-size', 'line-height', 'font-family')

cmdline: python /usr/bin/calibre-parallel 
component: calibre
executable: /usr/bin/calibre-parallel
kernel: 2.6.31.6-166.fc12.x86_64
package: calibre-0.6.26-1.fc12
uuid: 9dc80874

Comment 1 Boricua 2009-12-21 17:57:21 UTC
Created attachment 379662 [details]
File: backtrace

Comment 2 Ionuț Arțăriși 2009-12-27 15:52:57 UTC
Hi! Thanks for the bug report.

This seems to be related to the old python-cssutils package in fedora. Calibre seems to require some things from python-cssutils 0.9.6. I'll see if I can get the fedora maintainer to push a new package in fedora.

Comment 3 Fedora Admin XMLRPC Client 2010-05-13 04:25:40 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Kevin Fenzi 2010-05-23 20:54:14 UTC
Greetings.

I have created a test build of the latest calibre version for Fedora 12.

Can you please update from:             
http://koji.fedoraproject.org/koji/taskinfo?taskID=2204259

And see if you can reproduce this bug?

Comment 5 Fedora Update System 2010-05-29 22:15:06 UTC
calibre-0.6.55-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/calibre-0.6.55-1.fc12

Comment 6 Fedora Update System 2010-05-31 18:14:05 UTC
calibre-0.6.55-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update calibre'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/calibre-0.6.55-1.fc12

Comment 7 Fedora Update System 2010-06-21 13:10:38 UTC
calibre-0.6.55-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.