This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54945 - "Kernel panic: No init found" after upgrading to 2.4.9
"Kernel panic: No init found" after upgrading to 2.4.9
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 11:56 EDT by Sasha
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 16:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sasha 2001-10-23 11:56:43 EDT
I used up2date yesterday (Oct. 22) to update, among other packages,
kernel (to 2.4.9-6), mkinitrd (to 3.2.6), and glibc (to 2.2.4-19). The
update completed sucessfully, lilo updated, etc. Now when I try to reboot
the machine I get this:

....
Mounting root filesystem
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed:2
Freeing unused kernel memory: 224k freed
Kernel panic: No init found. Try passing init= option to kernel

Fortunately, LILO gives me option of loading one of previous kernel images
- and they load without any problem at all. Still, needless to say, I am
very much upset. 

I have package SysVinit-2.78-17 installed, and rpm --verify shows no
problems with it.
Comment 1 Arjan van de Ven 2001-10-23 11:59:16 EDT
Did you also get the filesystem package (you should have gotten, if not let me
know); also do you have a /initrd directory in your root filesystem (you can
make one by hand if not, but the filesystem package update should have done that
for you)
Comment 2 Sasha 2001-10-23 12:08:23 EDT
No, I do not have /initrd
I do  have /boot, which, among other files, contains
initrd-2.4.2-2.img  
initrd-2.4.3-12.img  
initrd-2.4.9-6.img



And yes, I did get and install package filesystem-2.1.0-2.1. Here is part of
up2date install log:

-------------------
[Mon Oct 22 15:46:36 2001] up2date installing packages: ['kernel-2.4.9-6',
'kernel-headers-2.4.9-6', 'filesystem-2.1.0-2.1', 'glibc-2.2.4-19',
'glibc-common-2.2.4-19', 'glibc-devel-2.2.4-19', 'openssh-2.9p2-8.7',
'openssh-askpass-2.9p2-8.7', 'openssh-askpass-gnome-2.9p2-8.7',
'openssh-clients-2.9p2-8.7', 'openssh-server-2.9p2-8.7',
'telnet-server-0.17-18', 'mkinitrd-3.2.6-1', 'modutils-2.4.6-4',
'e2fsprogs-1.23-1.7.1', 'e2fsprogs-devel-1.23-1.7.1'] 
[Mon Oct 22 15:46:36 2001] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Mon Oct 22 15:46:36 2001] up2date Opening rpmdb in /var/lib/rpm/ with option 1
[Mon Oct 22 15:46:36 2001] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Mon Oct 22 15:46:36 2001] up2date Removing packages from package profile:
['e2fsprogs-1.19-4', 'e2fsprogs-devel-1.19-4', 'glibc-2.2.2-10',
'glibc-common-2.2.2-10', 'glibc-devel-2.2.2-10', 'kernel-headers-2.4.3-12',
'mkinitrd-3.0.10-1', 'modutils-2.4.2-5', 'openssh-2.5.2p2-5',
'openssh-askpass-2.5.2p2-5', 'openssh-askpass-gnome-2.5.2p2-5',
'openssh-clients-2.5.2p2-5', 'openssh-server-2.5.2p2-5', 'telnet-server-0.17-10']
[Mon Oct 22 15:46:36 2001] up2date Adding packages to package profile:
['e2fsprogs-1.23-1.7.1', 'e2fsprogs-devel-1.23-1.7.1', 'glibc-2.2.4-19',
'glibc-common-2.2.4-19', 'glibc-devel-2.2.4-19', 'kernel-2.4.9-6',
'kernel-headers-2.4.9-6', 'mkinitrd-3.2.6-1', 'modutils-2.4.6-4',
'openssh-2.9p2-8.7', 'openssh-askpass-2.9p2-8.7',
'openssh-askpass-gnome-2.9p2-8.7', 'openssh-clients-2.9p2-8.7',
'openssh-server-2.9p2-8.7', 'telnet-server-0.17-18']
[Mon Oct 22 15:46:36 2001] up2date Modifying lilo.conf to include the new kernel
info
[Mon Oct 22 15:46:36 2001] up2date Adding 2.4.9-6 to lilo.conf
[Mon Oct 22 15:46:36 2001] up2date Running lilo with the new configuration
[Mon Oct 22 15:46:36 2001] up2date Running "/sbin/mkinitrd --ifneeded
/boot/initrd-2.4.9-6.img 2.4.9-6" 
[Mon Oct 22 15:46:36 2001] up2date /boot/initrd-2.4.9-6.img was created


Comment 3 Arjan van de Ven 2001-10-23 12:11:53 EDT
Does it work if you mkdir /initrd yourself (as root)?
Comment 4 Sasha 2001-10-23 12:27:33 EDT
Yes!
After mkdir /initrd
and rebooting, it worked. Funny - never expected that adding an empty directory
can change things. Still, of course, it should've been done automatically.
Comment 5 Arjan van de Ven 2001-10-23 12:29:41 EDT
It should absolutely have been done automatically, it's the reason we shipped an
updated filesystem rpm in the first place!

I'll go re-check the rpm, but it's just weird... (you're the first one to report
this)
Comment 6 Brett Schwarz 2001-10-26 11:10:48 EDT
I see this as well. Unfortunately, I am installing via kickstart, and so I only
have the 2.4.9 kernel, and can not make the initrd directory. Besides, I need
this to work off the bat, since this needs to be automatic (hence using
kickstart). I guess I could maybe do this in the post install section, but I
would rather not. Any status on this problem?

thanks,

--bret
Comment 7 Arjan van de Ven 2001-10-26 11:16:34 EDT
The new filesystem package just provides this directory... so why it's not
there..............
Comment 8 Arjan van de Ven 2001-10-26 11:46:41 EDT
Are you guys VERY sure you are using the 7.1 filesystem package and not the 7.2
one or one from Rawhide ?
Comment 9 Brett Schwarz 2001-10-26 12:16:07 EDT
Ok, I am an idiot. I had thought I had upgrading all of the new packages, but
after just reviewing them, it looks like filesystem was not updated. I need to
check my script that pulls the updates. Anyways, it is working now for
me....sorry for the noise.

--brett
Comment 10 Sasha 2001-10-26 14:00:57 EDT
You are right: package "filesystem" was *not* upgraded: 
 

rpm -qi filesystem
Name        : filesystem                   Relocations: (not relocateable)
Version     : 2.0.7                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Fri 21 Jul 2000 11:26:37
AM EDT
Install date: Wed 02 May 2001 12:27:28 PM EDT    

But I did select it in up2date, and up2date wrote in the log that it has updated
it (see my previous comment)! And I believed  it...


So, this is not a kernel or filesystem bug but up2date bug.
Comment 11 Aleksey Nogin 2001-10-27 18:31:55 EDT
One of our LUG members just reported seing this problem after *a clean install
of RH 7.2*, so it is not clear whether this is an up2date problem. I will try to
get more information from him.
Comment 12 Adrian Likins 2002-03-26 18:41:21 EST
Is this still an issue with the 2.7.11 versions of up2date?
Comment 13 Sasha 2002-03-27 16:48:00 EST
I didn't have this problem with recent updtaes - but then, I didn't try removing
/initrd directory or downgrading to an old version of filesystem to check
whether it would work now.

Note You need to log in before you can comment on or make changes to this bug.