Bug 549549 - [abrt] crash in firefox-3.5.6-1.fc12
[abrt] crash in firefox-3.5.6-1.fc12
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
abrt_hash:5fec5954981f2ea175dfbc68f53...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-21 17:47 EST by Matěj Cepl
Modified: 2010-03-22 10:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 10:29:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (106.50 KB, text/plain)
2009-12-21 17:47 EST, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2009-12-21 17:47:19 EST
abrt 1.0.2 detected a crash.

How to reproduce
-----
1.download Firebug 1.5beta
2.run Firefox
3.

Comment: I have tried Firebug 1.5beta
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5.6/firefox
component: firefox
executable: /usr/lib64/firefox-3.5.6/firefox
kernel: 2.6.31.6-166.bz528312.fc12.x86_64
package: firefox-3.5.6-1.fc12
rating: 4
reason: Process was terminated by signal 11 (Segmentation fault)
Comment 1 Matěj Cepl 2009-12-21 17:47:31 EST
Created attachment 379728 [details]
File: backtrace
Comment 2 Matěj Cepl 2009-12-21 18:22:46 EST
#2  <signal handler called>
No symbol table info available.
#3  js_GetOpcode (pc=<value optimized out>, script=<value optimized out>, 
    cx=<value optimized out>) at jsscript.h:325
        op = <value optimized out>
#4  js_PCToLineNumber (pc=<value optimized out>, 
    script=<value optimized out>, cx=<value optimized out>)
    at jsscript.cpp:1808
        type = <value optimized out>
        op = <value optimized out>
        lineno = <value optimized out>
        offset = <value optimized out>
        target = <value optimized out>
        sn = <value optimized out>
#5  0x0000003980bd4c8c in jsd_GetClosestLine (jsdc=0x7f9ea67f0780, jsdscript=
    0x7f9ea6551460, pc=<value optimized out>) at jsd_scpt.c:523
        first = 650
        last = 650
        line = <value optimized out>
#6  0x0000003980bdb075 in jsds_FilterHook (jsdc=0x7f9ea67f0780, 
    state=<value optimized out>) at jsd_xpc.cpp:400
        glob = 0x7f9eb2065540
        frame = <value optimized out>
        url = 0x7f9ea5318c70 "chrome://firebug/content/firebug.js"
        currentLine = 2938811498
        len = <value optimized out>
        currentFilter = <value optimized out>
        cx = <value optimized out>
        script = 0x7f9ea6551460
#7  0x0000003980bdc359 in jsds_ExecutionHookProc (jsdc=0x7f9ea67f0780, 
    jsdthreadstate=0x7f9ea6203cc0, type=4, callerdata=<value optimized out>, 
    rval=0x7fff9bf94d48) at jsd_xpc.cpp:680
        frame = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f9eaf1d8740}, <No data fields>}
        hook = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f9ea63c1d40}, <No data fields>}
        hook_rv = 5
        js_rv = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f9ea6203d00}, <No data fields>}
        native_frame = <value optimized out>
#8  0x0000003980bd3dc1 in jsd_CallExecutionHook (jsdc=0x7f9ea67f0780, 
    cx=<value optimized out>, type=<value optimized out>, hook=
    0x3980bdc230 <jsds_ExecutionHookProc(JSDContext*, JSDThreadState*, uintN, void*, jsval*)>, hookData=0x0, rval=<value optimized out>) at jsd_hook.c:177
        hookanswer = 5
        jsdthreadstate = 0x7f9ea6203cc0
#9  0x000000397fc4481b in js_Interpret (cx=0x7f9eb2008400)
Comment 3 Chris Campbell 2009-12-25 15:55:58 EST
Heh heh heh. Reporter, if this is a reproducible bug, could we please get the following information as attachments? :)



Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Marcus Better 2009-12-28 11:19:38 EST
This looks like an upstream bug (already fixed) affecting 64-bit builds:

https://bugzilla.mozilla.org/show_bug.cgi?id=510040
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=542768
Comment 5 David Rees 2010-01-20 15:49:39 EST
Any idea when the upstream fix will make it to Fedora?  This crash is also affecting me from updating to Firebug 1.5.0.
Comment 6 David Rees 2010-01-20 15:50:40 EST
BTW, this appears to be a duplicate of bug #534033.
Comment 7 Stefan Neufeind 2010-01-24 17:04:23 EST
This bug was officially fixed with firefox 3.5.8. However fc12 still remains at 3.5.6 at the moment, even in testing. Could we maybe push a 3.5.8 (or 3.6) to fc12-testing?

Ubuntu has a detailed view on the bug fixed with FireBug 1.5 and Firefox <3.5.8:
https://bugs.launchpad.net/ubuntu/+source/firefox-3.5/+bug/449744

Firebug also mentions it on their blog:
http://blog.getfirebug.com/2010/01/19/64-bit-firefox-on-linux-crashes-with-firebug-1-5-0/
Comment 8 Robert Laverick 2010-02-02 03:55:18 EST
(In reply to comment #7)
> This bug was officially fixed with firefox 3.5.8. However fc12 still
> remains at 3.5.6 at the moment, even in testing. Could we maybe push
>  a 3.5.8 (or 3.6) to fc12-testing? 

I doubt that 3.6 is going to be back ported to f12, but in order to get firebug back I did the following, tho you should be aware that this is probably bad, and could cause all kinds of problems, so if this doesn't work, or breaks things then you're best going back to 3.5.6. (*Insert standard warning about broken systems and stolen girlfriends here*)

0) download firefox, xulrunner and sqlite F13 builds, I got mine from koji linked below

http://koji.fedoraproject.org/koji/buildinfo?buildID=152508
http://koji.fedoraproject.org/koji/buildinfo?buildID=152495
http://koji.fedoraproject.org/koji/buildinfo?buildID=151728

1) Remove the current version of xulrunner. For some reason I had to remove this as rpm didn't want to do a straight update.  This will remove some other things, make a note of what it removes so you can re-install after updating xulrunner.  In my case it removed FF yelp and the open java plugin

yum remove xulrunner

2) install the rpms you downloaded.

yum localinstall firefox-3.6.1-1.fc13.x86_64.rpm xulrunner-1.9.2.1-1.fc13.x86_64.rpm sqlite-3.6.22-1.fc13.x86_64.rpm --nogpgcheck

3) re-install anything that got removed as dependant on xulrunner

yum install yelp

Open Firefox and things should "just work"

As I said before there are many reasons this is a bad idea, but if you don't mind getting your hands dirty, things going wrong and you just can't wait that's how I did it.
Comment 9 Stefan Neufeind 2010-02-16 06:15:16 EST
As already mentioned, a firefox >= 3.5.8 should resolve this and similar issues. It's needed for firebug 1.5.x, which is a quite commonly used extension. Any chance to to at least get 3.5.8 for FC12 (if not porting over the 3.6.1 from FC13)?
Comment 10 David Rees 2010-02-16 13:06:09 EST
Looks like firefox 3.5.8 builds have hit koji for F11/F12:

http://koji.fedoraproject.org/koji/packageinfo?packageID=37
Comment 11 Stefan Neufeind 2010-02-20 06:42:54 EST
firefox 3.5.8-1 arrived for f12 through regular updates. Works fine with firebug 1.5.0 now on x86_64. So that update fixed this bug here.
Comment 12 Stefan Becker 2010-02-20 13:33:17 EST
Confirmed. Firebug Javascript console no longer crashes with x86_64 firefox-3.5.8.
Comment 13 Martin Stransky 2010-03-22 10:29:57 EDT
firefox-3.5.8 is here, closing.

Note You need to log in before you can comment on or make changes to this bug.