Bug 54955 - Kickstart file created by installer contains a syntax error; and fails.
Kickstart file created by installer contains a syntax error; and fails.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 13:44 EDT by ramon
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 20:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ramon 2001-10-23 13:44:50 EDT
Description of problem:
The kickstart file created by an installation (for reproducing this
installation in other machines) contains a syntax error in the 
following line:

xconfig --card "S3 Savage4" --videoram 8192 --hsync 30 - 69 --vsync 50 -
120 --resolution 1024x768 --depth 32

As you see, the hsync and vsync parameters are wrong. There should be no
space between the lowest and the highest horizontal (vertical) frequency.

How reproducible:
Always

Steps to Reproduce:
1. Install a Redhat Linux system.
2. Copy the kickstart file created by the installation in a boot floppy of
the installation program, with the name ks.cfg.

mcopy anaconda-ks.cfg a:

3. Run the installation from that floppy, passing the option ks=floppy at
the boot prompt.
	

Actual Results:  The installation fails with a Python exception. The
installer complains about - not being a valid argument.

Additional info:


The installation program should display better error messages when there
is a syntax error in the kickstart file.

It should simply display:

syntax error in line <>: .....

and skip that line and continue a normal installation, instead of a python
stacktrace.
Comment 1 Brent Fox 2001-10-23 16:06:43 EDT
Did you enter the numbers by hand?
Comment 2 ramon 2001-10-23 16:18:14 EDT
No, the monitor (and the video card) was automatically detected.
Comment 3 Brent Fox 2001-10-23 16:57:32 EDT
What model of monitor did it detect?
Comment 4 ramon 2001-10-23 17:31:00 EDT
Sorry, I did not take note of that. I think in the tree of monitor list
under the folder DDC.

However, tomorrow I can run any program that displays the same information
that anaconda gets about the monitor.
Comment 5 Brent Fox 2001-10-23 17:43:03 EDT
After the system is installed, try running the program '/usr/sbin/ddcprobe'. 
You will have to install the anaconda RPM in order to do this.  It sounds as if
the monitor probe returns values with the spaces in it.  We can detect this in
the installer and strip the spaces out.
Comment 6 ramon 2001-10-23 18:07:05 EDT
I will do that tomorrow.

However, running ddcprobe from the CD in a different machine returns timings
with spaces:

[...]
Monitor details 3:
	Timing ranges: horizontal = 30 - 85, vertical = 50 - 120

This is /usr/sbin/ddcprobe from the filesystem image /RedHat/base/stage2.img of
the first CD.

I think the problem is quite reproducible.
first CD.
Comment 7 Brent Fox 2001-10-23 20:56:17 EDT
Ah, ok.  That's the problem.  We will have to check for this in the future and
strip the whitespace out if any exists.  We need it to be in the form of "30-85"
and "50-120" instead of "30 - 85" and "50 - 120".  A workaround for you, though,
is to remove the spaces in your kickstart file before you use it for another
kickstart install.  That should avoid the problem for now.
Comment 8 Brent Fox 2001-10-23 21:48:20 EDT
I've committed a fix for this in cvs on both the anaconda-7-2-branch and on
head.  Closing as Rawhide.  Thanks for your report.
Comment 9 ramon 2001-10-23 22:05:13 EDT
Isn't it a little irresponsible to delay it for the next release?
Any automated installation that uses the automatically generated
anaconda-ks.cfg will fail. And most users will be unable to know
the reason: they will be simply frustrated.
Comment 10 Brent Fox 2001-10-24 00:15:50 EDT
No, that's not so.  This situation can only happen in two ways.  One is that the
monitor in question isn't in the MonitorsDB file, so the installer has to probe
for the sync rates.  In this case, the spaces will be present in the
anaconda-ks.cfg file.  It can also occur if the user types in values that
contain whitespaces in the HSync and VSync text boxes in the monitor screen. 
The majority of monitors are in the monitors database and this will cause the
file to be written correctly.  The entries in the database don't contain the
whitespaces, but the return values for ddcprobe do.  So if the monitor is in the
database, the problem doesn't occur.

Do you really think this issue is big enough to release an errata for?  I could
put together an updates disk and make it available on the web if you'd like.

Comment 11 ramon 2001-10-24 09:05:36 EDT
Yes, I think that would be great to release an errata.

Take into account that many new cheap computers come
with monitors that are too new to be in any database.

(By the way, the machine where this problem was detected
is a IBM computer with an IBM monitor. Where should I send
the data of this monitor so that it is included in the monitor
database?).
Comment 12 Brent Fox 2001-10-24 11:17:18 EDT
An updates disk is available at
http://people.redhat.com/bfox/update-for-bug-54955.img

All you need to do is dd that file to a floppy and then boot the Red Hat
installer with 'linux updates'.  Then insert the updates floppy when prompted. 
Please let me know if this works for you.
Comment 13 ramon 2001-10-24 11:35:08 EDT
Thanks, I will test it.

Note You need to log in before you can comment on or make changes to this bug.