Bug 54956 - On 7.2 and 7.1 recent kernel, SiS 735 Motherboard ethernet (SiS 900 variant) doesn't work
On 7.2 and 7.1 recent kernel, SiS 735 Motherboard ethernet (SiS 900 variant) ...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 13:51 EDT by Erich Boleyn
Modified: 2013-07-02 22:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 20:17:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Boleyn 2001-10-23 13:51:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
The driver for the integrated ethernet in a SiS 735 motherboard chipset
(which is a variant of the SiS 900 ethernet chipset) doesn't work on either
the distribution kernel (2.4.7-10) or updated one (2.4.9-7).

This worked fine with the RH 7.1 earlier updated kernel (2.4.3-?? can't
remember).  It obviously won't work on the latest 7.1 update since it's the
same as the RH 7.2 update.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install on motherboard with SiS 735 chipset and integrated ethernet
(only tested on K7S5A motherboard).
2. Boot after installation.
3. Note ethernet module loads, but network doesn't function at all (in my
case, DHCP fails, manual ifconfig and then ping doesn't ever get any packets).

Additional info:
Comment 1 Arjan van de Ven 2001-10-25 06:23:58 EDT
I looked at the differences in the driver, and they were very minimal, except
for one specific PCI ID. Could you attach the output of lspci and "lscpi -n" to
this bug so I can see if your card happens to be this exact id ?
Comment 2 Erich Boleyn 2001-10-25 13:08:26 EDT
[root@heatmiser root]# lspci -n
00:00.0 Class 0600: 1039:0735 (rev 01)
00:01.0 Class 0604: 1039:0001
00:02.0 Class 0601: 1039:0008
00:02.2 Class 0c03: 1039:7001 (rev 07)
00:02.3 Class 0c03: 1039:7001 (rev 07)
00:02.5 Class 0101: 1039:5513 (rev d0)
00:02.7 Class 0401: 1039:7012 (rev a0)
00:03.0 Class 0200: 1039:0900 (rev 90)
00:0f.0 Class 0200: 1148:4300 (rev 12)
01:00.0 Class 0300: 10de:0200 (rev a3)


Relevant lines from "dmesg":

sis900.c: v1.08.00  6/11/2001
PCI: Assigned IRQ 11 for device 00:03.0
eth0: Realtek RTL8201 PHY transceiver found at address 1.
eth0: Using transceiver found at address 1 as default
eth0: SiS 900 PCI Fast Ethernet at 0xd400, IRQ 11, 00:d0:09:f4:bd:55.
eth0: Media Link On 100mbps full-duplex 


As far as I can tell, it seems to think the card is working fine...  I just
tried it again for sanity's sake, still nothing.  Pinging out causes no lights
to flicker on my switch, nor doing a broadcast ping from another machine and
using tcpdump on this machine to see if it gets anything.

I know the hardware still works fine, as the WinME on this box is happy with
it's networking.
Comment 3 Arjan van de Ven 2002-01-18 14:00:02 EST
Ok in the tree I've done the following:
* put back the 2.4.3-12 driver as sis900.o
* put the 2.4.17 driver as sis900_new.o

as it seems either works for 80% of the people but there's the 20% where there's
no overlap ;(

It will be in the next erratum we'll release.
Comment 4 Need Real Name 2002-02-05 12:45:13 EST
I am assuming you are using the "2.4.9-17" kernel, since I don't know that 
there is a "2.4.17" kernel? I also assume that the 2.4.9-19 and 2.4.9-21 have 
the same update 1.08.01 driver for the nic?

Note You need to log in before you can comment on or make changes to this bug.