Bug 54963 - xinetd forgets spawned processes and "instances=" does not work correctly
xinetd forgets spawned processes and "instances=" does not work correctly
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 15:04 EDT by Need Real Name
Modified: 2014-08-31 19:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:30:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example script that triggers xinetd bug (13.89 KB, text/plain)
2001-12-17 05:43 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-23 15:04:59 EDT
This is a copy of a email a wrote earlier to the author of xinetd.
It contains all relevant info:

----------------------------------------------
Hi,

Are you aware of any problem with xinetd that causes it to "forget"
processes it has spawned ?

I run a rather busy FTP-server (vsftpd-0.9.3) on a Red Hat 7.2 machine
via xinetd-2.3.3.  I configured a "instances=200" limit for the ftp
service, but I notice that there are about 300 processes running now and
the number keeps increasing.

I've made a dump via a "kill -USR2" and it shows this (older dump):

======================================================================
Near the top:
-------------
Service = ftp
        State = Active
        Service configuration: ftp
                id = ftp
                socket_type = stream
                Protocol (name,number) = (tcp,6)
                Instances = 200
                Nice = 10
                Groups = 0
                Server = /usr/sbin/vsftpd
                Server argv = vsftpd
                Logging to syslog. Facility = authpriv, level = info
                Log_on_success flags = HOST PID
                Log_on_failure flags = HOST
        running servers = 12
        ^^^^^^^^^^^^^^^^^^^^
        ^^^^^^^^^^^^^^^^^^^^
        retry servers = 0
        attempts = 0
        service fd = 3
        shutdown function = (null)

Near the end:
-------------
active_services = 1
available_services = 1
descriptors_free = 1015
running_servers = 261
^^^^^^^^^^^^^^^^^^^^^
^^^^^^^^^^^^^^^^^^^^^
Logging service = enabled
Shutdown service = enabled
======================================================================

Furthermore sending a "kill -ABRT" (same as SIGIOT mentioned in xinetd
manual but kill on RH 7.2 doesn't recognize -IOT) and the following appears
in /var/log/messages:

      xinetd[671]: service ftp: actual running servers = 301, known running servers = 54
      xinetd[671]: Consistency check detected 1 errors

I notice also quite some of the following messages  in my /var/log/messages:

      xinetd[671]: Service ftp: server exit with 0 running servers

and occasionally:
      xinetd[671]: Deactivating service ftp due to excessive incoming connections.  Restarting in 30 seconds.

Sysinfo:
--------
Athlon 900 MHz, Red Hat Linux 7.2, kernel 2.4.9-7.  Completely standard
RH 7.2 setup (compiled vsftpd myself, but I don't think the problem
is related to the ftp daemon).  vsftpd is the *only* service started
by xinetd.  All vsftpd processes were started by the running xinetd
and it has been running since boot-time.

Please contact me if you need more info !

	greetings,
	Rob van Nieuwkerk
Comment 1 Trond Eivind Glomsrxd 2001-10-24 12:40:15 EDT
Assigning to myself.
Comment 2 Rob Braun 2001-12-03 17:49:14 EST
Can you reproduce this with the latest xinetd?  I'm unable to reproduce it 
here, but my test environment may not be exactly the same.  I believe this was 
a duplicate of the lost SIGCHLD problem.  The packages at 
http://people.redhat.com/teg/xinetd/ or the source at 
http://www.xinetd.org/devel will give a good indication.
Comment 3 Need Real Name 2001-12-16 19:38:19 EST
Yes, I can reproduce it with the latest version.

I built http://people.redhat.com/teg/xinetd/xinetd-2.3.4-0.3.src.rpm

I have a user who has a script that makes many download accesses

to my server that triggers the bug.  I asked him to rerun his

script after my upgrade.  Same problem.



If you want I can ask him to tell what the script exactly does,

so you can reproduce the problem on your system (should be very

easy).



        Greetings,

        Rob van Nieuwkerk

Comment 4 Trond Eivind Glomsrxd 2001-12-16 20:04:41 EST
Yes, please, I'd like the reproducing script (-0.3 is 2001-12-13, BTW)
Comment 5 Need Real Name 2001-12-17 05:43:21 EST
Created attachment 40808 [details]
example script that triggers xinetd bug
Comment 6 Need Real Name 2001-12-17 05:45:00 EST
Hi,
The (type of) script my user uses to trigger the bug is just
a bunch of "ncftpget -b" commands.  These start in the background
so you get many connections in a short time.
See the attachment for an example script.

    greetings,
    Rob van Nieuwkerk
Comment 7 Daniel Senie 2001-12-18 09:22:57 EST
I have seen related issues. I have per_source limits, and see FTP going well 
beyond this (in /var/log/secure, I see 20 or 30 incoming connections, THEN the 
disconnects, as a part of someone's attack on a server). I have per_source set 
to 3.

I'm also going to submit another bug because xinetd starts doing USERID (Ident) 
after resetting a service following an attack.

Looks like lots of bugs still lingering in xinetd.
Comment 8 Bill Nottingham 2006-08-07 16:07:29 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 9 Bill Nottingham 2006-10-18 13:30:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.