Bug 54967 - bad net driver disk image
bad net driver disk image
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-23 15:57 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-16 16:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
module compiled for the -BOOT kernel (10.72 KB, application/octet-stream)
2001-11-09 05:40 EST, Arjan van de Ven
no flags Details

  None (edit)
Description Need Real Name 2001-10-23 15:57:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en]C-CCK-MCD   (WinNT; U)

Description of problem:
When I try to load network drivers off of the 7.2 drvnet.img disk, I get a message that there is a "bogus sector 0" and no VFAT file system 
found on the floppy. I've tried a number of disks and have tried downloading the disk image from ftp.redhat.com and a number of mirrors, 
all to no avail, so I suspect the disk image is broken. I'm trying to do a network install on a machine that has no way to attach a CDROM 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. download drvnet.img and dd it onto a floppy
2. boot off a disk with bootnet.img
3. insert driver disk when picking a network driver (press F2 etc.)

Actual Results:  No additional drivers appear in the driver list. (e.g., I need an SMC9000 series driver and it's not there). Pressing 
to another virtual terminal shows me the error message mentioned above (bogus sector 0, no vfat fs)

Expected Results:  Should load a driver list, no?

Additional info:

This is preventing me from installing redhat7.2, which is irritating.
Comment 1 Jeremy Katz 2001-10-23 16:25:48 EDT
I know I've tested loading a driver off of a driver disk.  Could you verify that
the md5sum for the image you download matches the correct one?

[katzj@mordor images]$ md5sum drvnet.img 
e898eef0af4629ee3dae66ec74506dca  drvnet.img

It should also mount via loopback as an ext2 image.
Comment 2 Need Real Name 2001-10-23 16:45:56 EDT
I checked it - identical.

auvserv,[/nobile/jmorash/redhat7.2/images],4:44pm% md5sum drvnet.img 
e898eef0af4629ee3dae66ec74506dca  drvnet.img

just double checking - the correct command to produce a disk is

dd if=drvnet.img of=/dev/fd0 bs=1440k

Comment 3 Need Real Name 2001-10-23 16:53:35 EDT
Hmm. I tried mounting it via loopback

[jmorash@auvserv images]# mount drvnet.img /mnt/floppy/ -t ext2 -o 
[jmorash@auvserv images]# ls /mnt/floppy/
modinfo  modules.cgz  modules.dep  pcitable  rhdd-6.1

and it works fine. Maybe my floppy drive is just screwed up? I tried several 
different disks (different brands, different boxes).
Comment 4 Need Real Name 2001-10-23 16:57:48 EDT
(sorry to be posting all these comments)
I was just looking at the file 'modinfo' off the driver disk and it doesn't 
list an SMC9000 series driver. Perhaps this is the problem after all - that it 
just doesn't have the driver I was expecting to see? I see smc-ultra and smc-
ultra32 but no smc9194 ... has this been deprecated?
Comment 5 Need Real Name 2001-10-23 17:00:08 EDT
(sorry to be posting all these comments)
I was just looking at the file 'modinfo' off the driver disk and it doesn't 
list an SMC9000 series driver. Perhaps this is the problem after all - that it 
just doesn't have the driver I was expecting to see? I see smc-ultra and smc-
ultra32 but no smc9194 ... has this been deprecated?
Comment 6 Need Real Name 2001-10-25 09:48:46 EDT
Hi... anyone there? I'd really like to be able to install... please?
Comment 7 Brent Fox 2001-10-25 10:20:13 EDT
katzj, any idea what happened to this driver?
Comment 8 Need Real Name 2001-10-27 14:53:58 EDT
Hi again,
Is there any way I could just make my own driver disk with this driver on it? It seems you folks are occupied with other things...
Comment 9 Brent Fox 2001-10-29 16:49:29 EST
For some reason, the smc9194 driver isn't getting compiled.  Even after
installation, the smc9194.o driver can't be found in
/lib/modules/2.4.7-10/kernel/drivers/net/.  It isn't in the kernel-2.4.9-7 RPM

Arjan, any idea what happened to this driver?
Comment 10 Arjan van de Ven 2001-10-29 17:02:00 EST
No idea why it's not compiled
if needed I can make a module to put on the driverdisk...
(no guarantees the driver will actually WORK; it might be disabled for a reason
Comment 11 Need Real Name 2001-11-02 11:35:35 EST
Any further news? If you could make a module to put on the driver disk, I'd be
happy to give it a try.
Comment 12 Brent Fox 2001-11-08 11:49:07 EST
arjanv, can you make a driver disk for him to try?
Comment 13 Arjan van de Ven 2001-11-09 05:40:00 EST
Created attachment 37002 [details]
module compiled for the -BOOT kernel
Comment 14 Arjan van de Ven 2001-11-09 05:50:55 EST
I made an (untested!) new network driver disk for it, see
use this instead of drvnet.img
Comment 15 Need Real Name 2001-11-09 13:51:34 EST
Hrmm. I try and use the module and get "failed to insert smc9194"
In vt3, I get:
* starting to STEP_URL
* trying to mount device /tmp/fd0
* extracting pattern 2.4.7-10*/smc9194.o
* going to insmod smc9194.o (path is /tmp/modules/smc9194)
error -2147483630 reading header: cpio: read failed - Success
* got url (null)

and in vt4:
<4>FAT: bogus logical sector size 0
<4>VFS: Can't find a valid FAT filesystem on dev 02:00

I've tried several different floppies and have tried extracting the module right
off the disk from the modules.cgz on another machine, which appears to work, so
I don't think it's a disk media problem... (?)
Comment 16 Need Real Name 2001-11-16 15:09:35 EST
More info: I'm trying a workaround. I installed RH7.2 onto a hard drive using
another computer. Now I've got the computer with the SMC9000 series eth. booting
off this HD, and I'm trying to install the proper network driver. When i extract
the drivers from the modules.cgz off the disk image arjanv gave me, then run
insmod smc9194.o, I get this error:

smc9194.o: unresolved symbol alloc_skb_R68af3782
smc9194.o: unresolved symbol __kfree_skb_Rf186d2b7
smc9194.o: unresolved symbol skb_over_panic_R29e50abb
smc9194.o: unresolved symbol unregister_netdev_Rab724ad4
smc9194.o: unresolved symbol ether_setup_Ra7efae99
smc9194.o: unresolved symbol softnet_data_R6faef490
smc9194.o: unresolved symbol register_netdev_R682aac73
smc9194.o: unresolved symbol netif_rx_Rdda29343
smc9194.o: unresolved symbol eth_type_trans_R9da8f968

what does this mean?

Comment 17 Arjan van de Ven 2001-11-16 15:14:08 EST
That means the module is for the -BOOT kernel only, not for the runtime one.
Comment 18 Arjan van de Ven 2001-11-16 15:16:36 EST
I've updated the http://people.redhat.com/arjanv/rhl72/smc9194/
directory with a .c a .h and a Makefile
install the kernel-source rpm (you probably already have it) and download these
three files.
Type "make"
This should give you a smc9194.o for the currently running kernel...
Comment 19 Need Real Name 2001-11-16 16:00:54 EST
Hey, whaddaya know, it worked. I can ssh in and everything.
Thanks a lot for your help!
Any idea why this got left off the driver disk, then? (or why the dd img you
gave me didn't work?)
Comment 20 Arjan van de Ven 2001-11-16 16:11:17 EST
I have no idea why the boot floppy didn't work, but then again I couldn't test it.
I have also no idea why the driver was disabled (sounds like I don't know much ;)
but I enabled it for all future kernels...

I'll close this as "fixed in rawhide" as our tree has this fixed, and it'll show
up in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.