Bug 549703 - insert one floppy disk during guest is running, it cannot be recognized by guest os.
insert one floppy disk during guest is running, it cannot be recognized by gu...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Burke
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-12-22 07:27 EST by Miya Chen
Modified: 2013-01-09 17:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 11:06:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miya Chen 2009-12-22 07:27:32 EST
Description of problem:
insert one floppy disk during guest is running, it cannot be recognized by guest os.

Version-Release number of selected component (if applicable):
# uname -r
2.6.18-182.el5
# rpm -q kvm
kvm-83-139.el5


How reproducible:
100%

Steps to Reproduce:
1.boot guest:
/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2 -drive file=win08-64-rc2.qcow2,if=ide,format=qcow2,cache=off -smp 2 -m 2G -vnc :1 -net nic,macaddr=20:20:20:11:00:90,model=e1000,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -monitor stdio
2.In qemu monitor:
(qemu) info block
ide0-hd0: type=hd removable=0 file=win08-64-rc2.qcow2 ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 [not inserted]
floppy0: type=floppy removable=1 locked=0 [not inserted]
sd0: type=floppy removable=1 locked=0 [not inserted]
(qemu) eject floppy0
(qemu) change floppy0 /root/virtio-drivers.vfd 
(qemu) info block
ide0-hd0: type=hd removable=0 file=win08-64-rc2.qcow2 ro=0 drv=qcow2
ide1-cd0: type=cdrom removable=1 locked=0 [not inserted]
floppy0: type=floppy removable=1 locked=0 file=/root/virtio-drivers.vfd ro=0 drv=raw
sd0: type=floppy removable=1 locked=0 [not inserted]

3.check in guest.
  
Actual results:
Inserted floppy disk can not be seen in guest os.

Expected results:


Additional info:
Comment 4 RHEL Product and Program Management 2011-01-11 15:46:32 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-11 17:48:16 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.