Bug 5498 - perl-MD5 package missing in 6.1
perl-MD5 package missing in 6.1
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl-MD5 (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-04 13:47 EDT by Chris Kloiber
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-15 10:04:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 1999-10-04 13:47:41 EDT
There is no perl-MD5 package in 6.1. This prevents me from
accessing the internet (RoadRunner cable modem) until I
obtain and install it.

Chris Kloiber
Comment 1 Cristian Gafton 1999-10-04 14:33:59 EDT
perl-MD5 is now part of the main perl package.
Comment 2 ryan_tucker 1999-10-04 14:48:59 EDT
Are you sure?  :-)

[rtucker@04355 rtucker]$ rpm -qil perl | grep MD5
/usr/lib/perl5/5.00503/man/man3/MD5.3

Seems to be all that's there in relation to MD5... -rt
Comment 3 Chris Kloiber 1999-10-04 16:26:59 EDT
I retreived the perl-MD5-1.7-6.i386.rpm from the Red Hat 6.0
Distribution, and preformed an rpm -qlip on it. Here's the files
listed:

/usr/lib/perl5/5.00503/man/man3/MD5.3
/usr/lib/perl5/site_perl/5.005/i386-linux/MD5.pm
/usr/lib/perl5/site_perl/5.005/i386-linux/auto/MD5
/usr/lib/perl5/site_perl/5.005/i386-linux/auto/MD5/.packlist
/usr/lib/perl5/site_perl/5.005/i386-linux/auto/MD5/MD5.bs
/usr/lib/perl5/site_perl/5.005/i386-linux/auto/MD5/MD5.so
/usr/lib/perl5/site_perl/5.005/i386-linux/auto/MD5/autosplit.ix

I then compared it to my fresh Red Hat 6.1 install. The only file
instaled on the 6.1 system (custom, install everything) was the
manpage MD5.3.

Unless it's been totally hidden using different filenames, (I tried to
locate them) then there is no perl-MD5 on this system.

Chris Kloiber
Comment 4 eczema 1999-10-18 17:28:59 EDT
This is right. Perl MD5 is missing..
Work around: take perl-MD5 in srpms in RH6.0
rpm -ba perl-MD5.spec and use the new rpm...
You must include this new RPM in the errate ASAP

Alain Degreffe
Comment 5 Chris Kloiber 1999-11-29 14:23:59 EST
I found the perl-MD5 rpm on the secure apache CD in the Professional Edition.
Why is it there?

Chris Kloiber
Comment 6 jmartin 1999-12-30 13:44:59 EST
This is important and it's a simple fix. Why isn't it in the errata yet?
An additional problem is that performing an upgrade removes the perl-MD5
package.
I see two solutions, one of which should be posted to the errata
immediately:
1. Remove the MD5 module man page from the perl rpm and fix the updater so
that it doesn't remove perl-MD5 for those of us who want to keep it.
2. Add MD5 as a standard part of the perl rpm.
Comment 7 Jeff Johnson 2000-01-15 10:04:59 EST
The perl-MD6 package is now part of the perl package as of perl-5.00503-7
and later from Raw Hide.
Comment 8 Ian Macdonald 2000-01-15 12:37:59 EST
Solving the problem in Rawhide is NOT a fix for RHL 6.1. Why doesn't Red Hat
just issue an erratum for this? It's simple to fix.

Whichever way you look at it, the official RPM for Perl on RHL 6.1 is still
buggy.

Note You need to log in before you can comment on or make changes to this bug.