Bug 54984 - kdepasswd doesn't work as expected
kdepasswd doesn't work as expected
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdeutils (Show other bugs)
7.3
s390 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 18:55 EDT by Ben Levenson
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-24 04:54:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2001-10-23 18:55:59 EDT
Description of Problem:
can't change root or standard user passwd w/ kdepasswd. 

Version-Release number of selected component (if applicable):
kdeutils-2.2-2

How Reproducible:
100%

Steps to Reproduce:
1. launch kdepasswd (as root)
2. enter original passwd
3. enter identical passwords in <Password> and <Verify> fields:
   Sorry, passwords do not match <OK>
4. just to see what happens, enter original passwd in both fields:
   Conversation with 'passwd' failed. <OK>
   Information: Your password has been changed. <OK>
---
when the same steps are performed as a standard user, the utility doesn't
appear to accept the original passwd:
 Error: Conversion with 'passwd' failed. <OK>
Then it prompts you for the new passwd.... 
 Sorry: Conversion with 'passwd' failed. <OK>
 Information: Your password has been changed. <OK>
But the password is not changed in either instance.
Additionally, the following message is displayed on the terminal that is
used to launch the utility:
   passwd: Only root can specify a username

Additional Information:
what is the purpose of the --user option? The binary executes the same
way with or without it. Is the root user supposed to be able to use
kdepasswd to change standard users' passwords w/ this option? If so, 
this is broken as well:
kdepasswd & kdepasswd --user => both appear to launch the passwd utility
                                for the user that launched them.
kdepasswd veloce & kdepasswd --user veloce => both fail w/ the same error
                                even when executed as root:
                                message: "Unexpected argument 'veloce'.
                                (veloce is a standard user on my system.)
Comment 1 Ben Levenson 2001-10-23 18:58:23 EDT
problem also exists on i386.
Comment 2 Bernhard Rosenkraenzer 2001-10-24 04:54:28 EDT
This is because of a change in passwd - older versions used to allow user bero 
to run "passwd bero", newer versions complain that only root can specify a 
user name, even if the user name is the user's own name. :/

Adapting kdepasswd code...

Comment 3 Bernhard Rosenkraenzer 2001-10-24 05:33:42 EDT
I've fixed this in CVS, and thrown a new package at dist-7.2-scratch (won't 
fix dist-8.0 for now - 8.0 will have KDE 3.x anyway).

It'll automatically be fixed when we release the update to KDE 2.2.2 on 
November 12.


Note You need to log in before you can comment on or make changes to this bug.