Bug 549890 - [abrt] crash in dp_gui::ExtMgrDialog::updateProgress
[abrt] crash in dp_gui::ExtMgrDialog::updateProgress
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
abrt_hash:d404d6df4806b0642a366112cf3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 17:22 EST by mdmpsyd@gmail.com
Modified: 2010-02-16 08:05 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.1.1-19.26.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 08:05:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (79.87 KB, text/plain)
2009-12-22 17:23 EST, mdmpsyd@gmail.com
no flags Details
output of unopkg list --shared && unopkg list (85.99 KB, text/plain)
2009-12-23 20:18 EST, mdmpsyd@gmail.com
no flags Details

  None (edit)
Description mdmpsyd@gmail.com 2009-12-22 17:22:59 EST
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/swriter.bin -writer
component: openoffice.org
executable: /usr/lib/openoffice.org3/program/swriter.bin
kernel: 2.6.31.6-166.fc12.i686.PAE
package: openoffice.org-writer-1:3.1.1-19.14.fc12
rating: 4
reason: Process was terminated by signal 6 (Aborted)
Comment 1 mdmpsyd@gmail.com 2009-12-22 17:23:04 EST
Created attachment 379928 [details]
File: backtrace
Comment 2 Caolan McNamara 2009-12-23 04:34:32 EST
This looks a low memory error thing in openjdk java. What were you doing at the time of the crash ?
Comment 3 mdmpsyd@gmail.com 2009-12-23 05:51:38 EST
IIRC, Writer was trying to create a photogallery. So a low memory error would make sense.
Comment 4 Caolan McNamara 2009-12-23 11:37:03 EST
A photogallery ? Looking again at the stack I see that there seems to be some extensions getting installed as well. So can I get a list of what extensions are installed., i.e. the output of...

unopkg list --shared && unopkg list
Comment 5 mdmpsyd@gmail.com 2009-12-23 20:18:58 EST
Created attachment 380115 [details]
output of unopkg list --shared && unopkg list

I can not seem to find how I was creating a photogallery in writer so unless it was in one of the extensions I deactivated, I was probably using something else (which I assume would be a memory hog).

I was deactivating and updating extensions. Should I have done this in two steps?

The output you asked for is larger than the 65,000 or so max characters allowed so I've attached a text file: open office extensions.txt (at least I hope it got attached)
Comment 6 David Tardon 2009-12-30 07:05:37 EST
dtardon->caolanm: All the java-related stuff is just JVM reacting on the
SIGSEGV. The 'real' stack starts at frame 13:

#13 0x044f5af6 in acquire (this=0xba0)
    at /usr/src/debug/OOO310_m19/solver/310/unxlngi6.pro/inc/osl/mutex.hxx:69

, which is evidently an invalid memory access. My guess is that there was a running update when the ext. manager was closed and the crash happened when the running update tried to access the ext. manager to update progress bar.
Comment 7 David Tardon 2009-12-31 12:55:53 EST
Yup, dp_gui::ProgressCmdEnv::m_pDialog is initialized to 0 in dp_gui::handleInteractionRequest() . Stupid...
Comment 8 David Tardon 2010-01-01 02:32:40 EST
fix checked in, will be in >=3.1.1-19.25
Comment 9 Fedora Update System 2010-02-03 04:16:56 EST
openoffice.org-3.1.1-19.25.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.25.fc12
Comment 10 Fedora Update System 2010-02-04 20:28:22 EST
openoffice.org-3.1.1-19.25.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1460
Comment 11 Fedora Update System 2010-02-13 07:00:50 EST
openoffice.org-3.1.1-19.26.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openoffice.org-3.1.1-19.26.fc12
Comment 12 Fedora Update System 2010-02-16 08:03:18 EST
openoffice.org-3.1.1-19.26.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.