Bug 549925 - <entry> tag causes unpredictable output when building translations with po files
<entry> tag causes unpredictable output when building translations with po files
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-22 18:51 EST by Richard Wilding
Modified: 2010-11-23 23:18 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-31 20:14:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Table entry problems demonstrated in Japanese (39.42 KB, application/x-gzip)
2009-12-22 19:00 EST, Richard Wilding
no flags Details

  None (edit)
Description Richard Wilding 2009-12-22 18:51:45 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091216 Fedora/3.5.6-1.fc11 Firefox/3.5.6

The <entry> tag seems to be causing some unpredictable behaviour when replacing translated strings from po files. Some symptoms are:
- text without <para> tags is not replaced
- text with inline tagging is omitted
- fuzzy translations are being included in the build

These issues are fixed by enclosing text in the table entries in the en-US xml files within <para> tags (i.e. <entry><para>text</para></entry>) and updating po files. However the Docbook spec seems to indicate that <entry>text</entry> is well-formed.

Will attach xml and po files that exhibit this problem. 


Reproducible: Always
Comment 1 Richard Wilding 2009-12-22 19:00:05 EST
Created attachment 379951 [details]
Table entry problems demonstrated in Japanese
Comment 2 Vedran Miletić 2009-12-24 17:28:05 EST
Changing version to 11 per user agent.
Comment 3 Richard Wilding 2010-01-07 21:14:06 EST
This problem doesn't seem to be restricted to table entries. <para>s with nested variable lists and item lists also appear to have the same behaviour. Text in the root of the <para> is not being replaced by its respective translation and inline tagged text is also being omitted.

ie.:

<para>
Text here is problematic.
<variablelist>
...
</variablelist>
</para>
Comment 4 Jeff Fearn 2010-01-18 00:48:50 EST
Modified logic in translation merging code to insert translated text in mix-mode content correctly.

workaround: avoid using mixed mode content.
Comment 5 Fedora Update System 2010-01-28 21:04:57 EST
publican-1.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc12
Comment 6 Fedora Update System 2010-01-28 21:06:17 EST
publican-1.4-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.4-1.fc11
Comment 7 Fedora Update System 2010-01-31 20:13:02 EST
publican-1.4-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-01-31 20:21:26 EST
publican-1.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.