Bug 54993 - Keyboard locks up on Dell Inspiron 5000
Keyboard locks up on Dell Inspiron 5000
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 20:51 EDT by Andy Wang
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 14:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andy Wang 2001-10-23 20:51:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
With my Dell Inspiron 5000 the keyboard periodically locks up.  The system 
is not locked up as I can access it remotely over a network and the mouse 
still works.  It will happen within a few minutes of booting up.  I have 
tried the latest kernel version 2.4.9-7.  This did not happen in RedHat 
7.1.  If I connect an external keyboard to the ps/2 port it has not locked 
up yet.  I don't even have to be using the external keyboard.  It appears 
the keyboard is locked as the LEDs all go dark and caps lock/num 
lock/scroll lock will not reactivate them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RedHat 7.2 on Dell Inspiron 5000 laptop.
2. Boot RedHat Linux 7.2 on Dell Inspiron 5000 laptop.
3. Use RedHat Linux 7.2 for a few minutes and the keyboard will lock up.
	

Actual Results:  The keyboard locks up.

Expected Results:  Nothing.  Everything should work perfectly.

Additional info:

I can provide any other information necessary.  The system is a Dell 
Inspiron 5000 with 384MB RAM, Pentium III 650.  The only extra peripheral 
is a USB logitech optical wheel mouse.
Comment 1 Need Real Name 2001-10-25 09:13:06 EDT
I get the same here, except, even when I use an external keyboard I get the same
problem.
If its of any significance, it seemed to think I had a PS/2 mouse on, until I
plugged the keyboard into the external ps/2 socket, and then it said I removed
it. (This is kudzu)
Comment 2 Andy Wang 2001-10-25 17:55:06 EDT
I have a workaround now.  I originally installed RedHat 7.2 with my Logitech USB
Optical Wheel Mouse attached.  With this configuration, gpm and XFree86 were
both using my USB mouse only.  The touchpad wasn't configured at all.  I
re-installed with the USB mouse detached (actually, I forgot to attach it) and
now everything is good.  I configured the mouse as a second pointer for XFree86
and kept gpm configured to use the touchpad and everything works.  In my case,
this seems to be a specific problem with USB mice and the internal keyboard.  I
have found a few messages using deja where people are having similar problems
with versions of Mandrake.
Comment 3 Pete Zaitcev 2001-10-25 18:16:50 EDT
This sounds like Bug #32533 revisited us again, only
on different Dell model. The workaround applied by model
DMI string, so it is not enabled for Inspirons.
But it may be some other bug as well, so this is FYI.

Processors: Do not mark any of these bugs as dupes, until
there is a resolution for Inspiron specifically.

By the way, in L600 case the "random" lockup was caused
by a user's thumb dangling and touching the touchpad momentarily.
It is hard to track, but it was actually deterministic.
Comment 4 Andy Wang 2001-10-25 20:50:58 EDT
I can't seem to see 32533.  I do occasionally drag on the touchpad, but I also 
have figured out that at times the touchpad acts as if I double tapped it when 
I'm typing, even if my hands are nowhere near the pad.  I've heard this being a 
problem due to the weight of certain keystrokes doing something to the pad 
making it think it was double tapped.  It's entirely possible that this is what 
caused the problem.  Right now with my workaround what ends up happening is 
where my mouse cursor is when this happens gets focus.  If it's an icon on the 
panel then it launches that app.  However, it only happens when I don't have 
the pad configured for use.  Very odd.
Comment 5 Alan Cox 2003-06-07 14:59:58 EDT
Dell funny worked around in later errata kernels. If it still exists please
reopen the bug

Note You need to log in before you can comment on or make changes to this bug.