This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 54994 - When doing upgrade install 7.1 installer incorrectly warns about insuffiecient SWAP
When doing upgrade install 7.1 installer incorrectly warns about insuffiecien...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 20:53 EDT by Steven Roberts
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-23 20:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven Roberts 2001-10-23 20:53:17 EDT
Description of Problem:
When doing an upgrade install If SWAP doesn't hit some magice size (maybe same as physical RAM) the installer gives  a grave warning 
that the upgrade won't work unless you add more SWAP.  machine had 256 Physical and 127 SWAP and so 383 should have been plenty.  
ignored message saying it wouldn't work and it did work.


Version-Release number of selected component (if applicable):


How Reproducible:
Easy

Steps to Reproduce:
1.  Install with 6.2 on a machine with 256MB  physical, 127 SWAP
2.  Do upgrade (used graphical mode) to 7.1

Actual Results:
big nasty warning


Expected Results:
it to figure out >300MB was enough for install and not warn


Additional Information:
Comment 1 Brent Fox 2001-10-23 22:23:14 EDT
Well, our warning messages are guidelines...they are not written in stone.  We
are following the RAM recommendations that the kernel team has specified for us
(swap should == 2 x RAM).  But, we provide a way to ignore the warning and do
the install with less than the recommended amount of RAM.  What else can we do
but make a reasonable recommendation and then allow the user to follow it or
ignore?  Seems reasonable to me.
Comment 2 Steven Roberts 2001-10-23 22:44:20 EDT
The main problem I had with it is it really wasn't phrased as a warning.

I would prefer a sanity check on hey we have enough RAM no warning (6.2 didn't squawk for example), but if you say something like:
"Warning, you may not have enough RAM to continue"

instead of -- can'trecall the exact text but it was soemthing like:
"If you don't create an additional SWAP partition the upgrade will fail".
Comment 3 Brent Fox 2001-10-24 00:32:43 EDT
6.2 was different because the 2.2 kernel wasn't as swap-hungry as 2.4 is.  As
far as the messages for 7.1, I don't think they were *that* ominous.  Here are
the strings I see in the upgrade_swap_gui.py file:

"The 2.4 kernel needs significantly more "
"swap than older kernels, as much as twice "
"as much swap space as RAM on the system.  "
"You currently have %dMB of swap configured, but "
"you may create additional swap space on one of "
"your file systems now.")

And later...:

"It is stongly recommended that you create a swap file.  "                     
      "Failure to do so could cause the installer to abort "
"abnormally.  Are you sure that you wish to continue?"),


So I don't think we tried to suggest that the upgrade would definately fail if
you didn't follow the guidelines.  If we knew that it would always fail, I don't
think we'd give the user the ability to ignore the warning.  
But, it is nontheless a true statement...it *could* fail.  In fact, I can give
you a scenario in which it will fail.  Do an install of, say, 6.0 with 32MB of
swap.  Then upgrade to 7.1 or 7.2.  What will happen is that while the installer
is querying the RPM database on the installed system, which takes lots of RAM,
the kernel will run out of RAM and then run out of swap.  The kernel then goes
looking for processes to kill in order to reclaim some memory.  It usually kills
the anaconda process (which is process 10).  This will cause the abnormal 
process abortion that the warning message refers to.

We thought about how to solve this problem for a while, and this is the decision
that we've made.  It's not perfect, but then, there is no solution that would be
perfect for everyone.

Comment 4 Steven Roberts 2001-10-24 00:53:05 EDT
Okay, guess my memeory remembered it worsethan it is.   Finally geting some spare time to file issues (it has been about 2 months since I 
encoutered it).

I guess the only thing I am thinking would be a better resolution is to have a sanity limit.  I just think getting that on a machine with 512MB physical 
will seem a little odd :)

but I'm not really worried (why I set priority to low) if it doesn't get changed.
Comment 5 Brent Fox 2001-10-24 09:32:02 EDT
I believe the we set the sanity limit at 1 GB of ram.  That is, we don't warn
you to create 2 GB of swap.  At some point the 2x ram equation gets rediculous,
like if you had 4GB of ram.  Maybe we should lower the limit to 512 MB of ram if
that makes more sense.  I guess it depends on the role of the machine.
Comment 6 Steven Roberts 2001-10-24 12:52:26 EDT
okya, yeah in this case it was a laptop, so 256 physical and 127 swap was plenty. but yeah, I woult tend to agree that it is role of machine 
dependent.  Oh well, Most of my RedHat installs are to servers using kickstart so I rarely get to see the installer these days :).  which btw, kickstart 
rocks, and I like the 7.x additions please pass on my gratitude :).

Note You need to log in before you can comment on or make changes to this bug.