Bug 54999 - gcc3-3.0.1-4.src.rpm fails to build
gcc3-3.0.1-4.src.rpm fails to build
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc3 (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-23 21:59 EDT by sean
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 12:07:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-10-23 21:59:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.12 i686)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild gcc3-3.0.1-4.src.rpm
2.
3.
	

Actual Results:  ...
updating cache ../../config.cache
creating ./config.status
creating Makefile
creating config.h
configuring in libF77
running /bin/sh ../../../../libf2c/libF77/configure 
--host=i386-redhat-linux --build=i386-redhat-linux --enable-
multilib
--with-gcc-version-trigger=/usr/src/redhat/BUILD/gcc-3.0.1-20011002/gcc/version.c
--prefix=/usr --mandir
=/usr/share/man --infodir=/usr/share/info --enable-shared
--enable-threads=posix --disable-checking --with-target
-subdir=i386-redhat-linux --cache-file=../../config.cache
--srcdir=../../../../libf2c/libF77
loading cache ../../config.cache
checking for gcc... (cached)
/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/xgcc
-B/usr/src/r
edhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/
-B/usr/i386-redhat-linux/bin/ -B/usr/i386-redhat-linux/
lib/ -isystem /usr/i386-redhat-linux/include
checking whether we are using GNU C... (cached) yes
checking whether
/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/xgcc
-B/usr/src/redhat/BUILD/
gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/ -B/usr/i386-redhat-linux/bin/
-B/usr/i386-redhat-linux/lib/ -isyste
m /usr/i386-redhat-linux/include accepts -g... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking how to run the C preprocessor... (cached)
/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux
/gcc/xgcc
-B/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/
-B/usr/i386-redhat-linux/bin/ -B/
usr/i386-redhat-linux/lib/ -isystem /usr/i386-redhat-linux/include -E
checking for stdio.h... (cached) yes
checking for ANSI C header files... (cached) yes
checking for posix... (cached) yes
checking for GNU library... (cached) yes
checking return type of signal handlers... void
checking for drem in -lm... yes
updating cache ../../config.cache
creating ./config.status
creating Makefile
make[2]: Entering directory
`/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/i386-redhat-linux/lib
f2c'
cd libI77; make
CC='/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/xgcc
-B/usr/src/redhat/BUI
LD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/
-B/usr/i386-redhat-linux/bin/ -B/usr/i386-redhat-linux/lib/ -isy
stem /usr/i386-redhat-linux/include' CFLAGS='-O2 -march=i386 -mcpu=i686'
CPPFLAGS='' AR='ar' RANLIB='ranlib' PICF
LAG='' RUNTESTFLAGS='' prefix='/usr' exec_prefix='/usr' libdir='/usr/lib'
libsubdir='/usr/lib/gcc-lib/i386-redhat
-linux/3.0.2' tooldir='/usr/i386-redhat-linux' all
make[3]: Entering directory
`/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/i386-redhat-linux/lib
f2c/libI77'
/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/gcc/xgcc
-B/usr/src/redhat/BUILD/gcc-3.0.1-2001100
2/obj-i386-redhat-linux/gcc/ -B/usr/i386-redhat-linux/bin/
-B/usr/i386-redhat-linux/lib/ -isystem /usr/i386-redha
t-linux/include -c -I. -I../../../../libf2c/libI77 -I..
-I../../../../libf2c/libI77/..  -DHAVE_CONFIG_H -O2 -marc
h=i386 -mcpu=i686 -o VersionI.o ../../../../libf2c/libI77/Version.c
(cd ../../../../libf2c/libI77 && autoheader)
autoheader: missing template: _POSIX_SOURCE
make[3]: *** [../../../../libf2c/libI77/stamp-h.in] Error 1
make[3]: Leaving directory
`/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/i386-redhat-linux/libf
2c/libI77'
make[2]: *** [i77] Error 2
make[2]: Leaving directory
`/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux/i386-redhat-linux/libf
2c'
make[1]: *** [all-target-libf2c] Error 2
make[1]: Leaving directory
`/usr/src/redhat/BUILD/gcc-3.0.1-20011002/obj-i386-redhat-linux'
make: *** [bootstrap-lean] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.70080 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.70080 (%build)


Additional info:
Comment 1 Fortepianissimo 2001-10-24 02:34:19 EDT
I can confirm this (the same error) - my box is AMD Athlon + RH 7.1. Also it
looks like both gcc-2.96-98.src.rpm and gcc-2.96-99.src.rpm failed to build
because of some errors related to autoconf? It happened only after I upgraded to
the latest rawhide release (Oct 21) - they all compiled with no problem before.
Comment 2 Jakub Jelinek 2001-10-24 02:58:09 EDT
Downgrade autoconf/automake/libtool. Rawhide ATM is very unstable
and e.g. it will take a while until all packages will be prepared
for new autoconf (unfortunately incompatible), new automake, new libtool,
new gcc etc.
Comment 3 Fortepianissimo 2001-10-24 11:37:29 EDT
Yes after downgrading everything compiled (both gcc 2.96 and 3.01).
Comment 4 sean 2001-10-25 23:14:03 EDT
AFAIK, I have the latest automake/autoconf/libtool:
[system@localhost root]$ rpm -q automake
automake-1.5-1
[system@localhost root]$ rpm -q autoconf
autoconf-2.52-3
[system@localhost root]$ rpm -q libtool
libtool-1.4-8

Still no go. The problems seems specific to the _POSIX_SOURCE template for the
fortran compiler.
Comment 5 sean 2001-10-26 19:48:20 EDT
It really is just f77. I changed the spec file to configure with
--enable-languages=c,c++,objc,java.

All worked well.

jay
Comment 6 Bill Nottingham 2002-12-19 12:07:10 EST
Our current packages seem to build ok, closing old bug.

Note You need to log in before you can comment on or make changes to this bug.