Bug 549994 - kwin crashes when enabling plasma-netbook workspace and selinux=enforcing
kwin crashes when enabling plasma-netbook workspace and selinux=enforcing
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 549746
  Show dependency treegraph
 
Reported: 2009-12-23 03:21 EST by Sebastian Vahl
Modified: 2010-02-19 09:27 EST (History)
9 users (show)

See Also:
Fixed In Version: 4.6.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-23 11:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sealert report (94d4513e-7637-4087-9039-4340e3c4b452) (2.87 KB, text/plain)
2009-12-23 03:21 EST, Sebastian Vahl
no flags Details
krash handler report (3.46 KB, text/plain)
2009-12-23 03:26 EST, Sebastian Vahl
no flags Details
krash handler report for qt-4.6.0-3 when switching through windows (5.73 KB, text/plain)
2009-12-23 10:54 EST, Sebastian Vahl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
WebKit Project 35154 None None None Never

  None (edit)
Description Sebastian Vahl 2009-12-23 03:21:32 EST
Created attachment 379988 [details]
sealert report (94d4513e-7637-4087-9039-4340e3c4b452)

Description of problem:
When enabling plasma-desktop workspace kwin is crashing.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.3.85-1.fc13.i686
qt-x11-4.6.0-2.fc13.i686

How reproducible:
ever

Steps to Reproduce:
(0. add a clean user account)
1. enable netbook "form factor" in systemsettings -> deskop -> workspace
  
Actual results:
crash

Expected results:
no crash

Additional info:
I'm using the nouveau driver if that matters.

These messages appear in /var/log/messages when kwin is crashing:

Dec 23 09:09:38 htpc kernel: plasma-netbook[4493]: segfault at bbadbeef ip 0621a5c0 sp bf8f4b20 error 6 in libQtWebKit.so.4.6.0[5fcb000+1090000]  
Dec 23 09:09:38 htpc kernel: Process 4493(plasma-netbook) has RLIMIT_CORE set to 0
Dec 23 09:09:38 htpc kernel: Aborting core
Dec 23 09:09:45 htpc setroubleshoot: SELinux is preventing /usr/bin/plasma-netbook "execmem" access on <Unknown>. For complete SELinux messages. run sealert -l 94d4513e-7637-4087-9039-4340e3c4b452
Dec 23 09:09:48 htpc setroubleshoot: SELinux is preventing /usr/bin/plasma-netbook "execmem" access on <Unknown>. For complete SELinux messages. run sealert -l 94d4513e-7637-4087-9039-4340e3c4b452


The sealert report is attached. plasma-netbook isn't crashing in permissive mode.
Comment 1 Sebastian Vahl 2009-12-23 03:26:07 EST
Created attachment 379989 [details]
krash handler report
Comment 2 Kevin Kofler 2009-12-23 06:53:05 EST
This is the QtWebKit JavaScript yet again, see bug 527079. Somebody disabled the patch to disable the JS JIT and thus fix that bug:
## FIXME: I think this one can be replaced with ./configure -no-javascript-jit
## test first if it's still needed
#patch23 -p1 -b .javascriptcore-disable-jit
Comment 3 Kevin Kofler 2009-12-23 07:34:10 EST
* Wed Dec 23 2009 Kevin Kofler <Kevin@...> - 4.6.0-3
- disable QtWebKit JavaScript JIT again, incompatible with SELinux (#549994)
Comment 4 Kevin Kofler 2009-12-23 09:36:06 EST
qt-4.6.0-3.fc13 has been built: http://koji.fedoraproject.org/koji/buildinfo?buildID=148334
Can you please verify that this resolves your issue?
Comment 5 Sebastian Vahl 2009-12-23 10:54:30 EST
Created attachment 380045 [details]
krash handler report for qt-4.6.0-3 when switching through windows

With -3 plasma-desktop isn't crashing right after enabling it. But if I switch through the open windows (only konsole and systemsettings) it is also crashing. The attached krash handler report is created after such a crash. But this time there is no selinux error.

When I reported this with -2 plasma-netbook crashed but I was able to switch trough the open windows to get the crash report. Now this is only hardly possible because the focus of the active window often gets lost and a half loaded plasma-netbook desktop is shown instead. 
The behaviour is a bit similar to bug #550049.

qt-4.6.0-3.fc13.i686
qt-debuginfo-4.6.0-3.fc13.i686
qt-devel-4.6.0-3.fc13.i686
qt-mysql-4.6.0-3.fc13.i686
qtscriptbindings-0.1.0-10.fc13.i686
qt-sqlite-4.6.0-3.fc13.i686
qt-x11-4.6.0-3.fc13.i686
Comment 6 Kevin Kofler 2009-12-23 11:59:46 EST
That's a completely different issue, let's please track this separately.
Comment 7 Sebastian Vahl 2009-12-23 12:22:12 EST
(In reply to comment #6)
> That's a completely different issue, let's please track this separately.  

Sure. I have only described this because libQtWebKit.so.4 was also mentioned in the crash.
Comment 8 Rex Dieter 2009-12-23 23:25:45 EST
I thought somewhere along the line that upstream had been notified of the selinux/jit problem, but I don't see that documented here or in any other previous bugs (bug #527079 or bug #516057)
Comment 9 Jaroslav Reznik 2010-02-19 09:27:07 EST
Reported upstream, added reference to WebKit's bugzilla.

Note You need to log in before you can comment on or make changes to this bug.