Bug 550010 - unable to install debuginfo packages using debuginfo-install
unable to install debuginfo packages using debuginfo-install
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-23 04:20 EST by Sandro Janke
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 14:43:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of sudo debuginfo-install thunderbird (6.28 KB, text/plain)
2009-12-23 08:17 EST, Sandro Janke
no flags Details
complete output of "sudo debuginfo-install thunderbird" including traceback (6.95 KB, text/plain)
2009-12-23 09:58 EST, Sandro Janke
no flags Details

  None (edit)
Description Sandro Janke 2009-12-23 04:20:09 EST
Description of problem:
debuginfo-install crashes with traceback

Version-Release number of selected component (if applicable):
debuginfo-install - 1.0 (yum - 3.2.25)
yum-utils-1.1.24-2.fc12.noarch

How reproducible:
always

Steps to Reproduce:
1. run "debuginfo-install $package"
  
Actual results:
debuginfo-install crashes after Transaction Summary is displayed.
Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 154, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 48, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 93, in main
    sys.exit(self.doUtilTransaction())
  File "/usr/share/yum-cli/utils.py", line 174, in doUtilTransaction
    return_code = self.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 393, in doTransaction
    if self._promptWanted():
  File "/usr/share/yum-cli/cli.py", line 1036, in _promptWanted
    txmbr.name not in self.extcmds:
AttributeError: 'DebugInfoInstall' object has no attribute 'extcmds'

Expected results:
install debuginfo-packages

Additional info:
Comment 1 seth vidal 2009-12-23 07:54:51 EST
did you really type:

debuginfo-install $package

or was there something else there  b/c I can't replicate this at all.
Comment 2 Sandro Janke 2009-12-23 08:16:47 EST
With $package I meant that it doesn't matter which package I want to install debuginfo for. It happens for all packages I tried so far. In this particular case the command was:

$ sudo debuginfo-install thunderbird

I redirected the output (see attachment).
Comment 3 Sandro Janke 2009-12-23 08:17:43 EST
Created attachment 380024 [details]
output of sudo debuginfo-install thunderbird
Comment 4 James Antill 2009-12-23 09:22:11 EST
I don't have thunderbird installed, but if I do "debuginfo-install evolution" I get:

Transaction Summary
================================================================================
Install      40 Package(s)
Upgrade       0 Package(s)

Total download size: 43 M
Installed size: 225 M
Is this ok [y/N]: 
Exiting on user Command
Complete!

...the last two lines, only after hitting return.
Comment 5 seth vidal 2009-12-23 09:33:55 EST
I'm very confused. The output you attached looks like it succeeded. Where does the failure happen?
Comment 6 Sandro Janke 2009-12-23 09:56:00 EST
Sorry, for all the confusion. The attachment is indeed incomplete. I must have messed up the redirection.

Right after the output in the attachment the reported traceback kicks in. I would expect the question "Is this ok [y/N]:" to be shown waiting for me to confirm the install or abort.

If the command succeeded the output should also show "Complete!" as in comment #4.
Comment 7 Sandro Janke 2009-12-23 09:58:18 EST
Created attachment 380041 [details]
complete output of "sudo debuginfo-install thunderbird" including traceback
Comment 8 seth vidal 2010-01-12 14:43:42 EST
okay, I've figured out where/ why this is happening. Are you able to apply a patch to test this?

If so please apply:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=1af3a46b6ae33b5683e5344a3da025f6fe5403a2


and let me know if it works.

I think it will so in the meantime I'm closing this.
Comment 9 Sandro Janke 2010-01-12 16:07:44 EST
I applied the patch and debuginfo-install is installing the debuginfo packages, happily.

Thank you!

Note You need to log in before you can comment on or make changes to this bug.