Bug 550045 - Apache: Incorrect syntax is not validated for 'Listen' directive.
Apache: Incorrect syntax is not validated for 'Listen' directive.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
1.4
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: SubBug
Depends On:
Blocks: rhq_spearhead jon24-apache
  Show dependency treegraph
 
Reported: 2009-12-23 06:57 EST by Sunil Kondkar
Modified: 2014-05-23 16:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-23 16:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sunil Kondkar 2009-12-23 06:57:30 EST
Description of problem:

If user enters ip with incorrect syntax say 12222.6567.7687.7878.977866.656565.6576.656.755 in Listen directive in httpd resource in imanage UI, it is accepted without any validation.

Version-Release number of selected component (if applicable):

1.4.0-SNAPSHOT
How reproducible:


Steps to Reproduce:

1. Login to imanage UI.
2. Navigate to the apache httpd resource.
3. Navigate to the 'Configuration' tab.
4. Click on 'Change Properties' button.
5. Click on 'Edit' button for 'Listen' directive.
6. Enter any incorrect ip in 'Ip' field. Enter port as 80. Click on OK button.
7. Click on 'Save' button.
  
Actual results:

Incorrect ip is not validated in apache resource.

Expected results:

There should be a validation if user enters ip with incorrect syntax.

Additional info:
Comment 1 wes hayutin 2010-02-16 11:57:53 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 12:02:52 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Lukas Krejci 2013-11-15 08:42:19 EST
Apache plugin is no longer owned by the core RHQ team, so unassigning myself from this.

Note You need to log in before you can comment on or make changes to this bug.