Bug 55007 - Multiple kernel installs
Multiple kernel installs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 05:44 EDT by Need Real Name
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 07:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-24 05:44:22 EDT
Description of Problem:
 I removed the restriction of downloading a new kernel, to update to kernel-2.2.19-7.0.10.
 When I started up2date after updating the kernel, it wanted to update the new kernel again (to the same version). (I have also set it to keep the files. when I did a rm /var/spool/up2date it wanted to download the kernel again.

This may prevent installation of future updates, including security updates, unless it can be fixed.

The same problem as bid 52986.


Version-Release number of selected component (if applicable):

up2date-2.5.4-1

How Reproducible:

every time i run  up2date -u from the command line as root.

Steps to Reproduce:
1. up2date -u

Actual Results:
 If the kernel package is in /var/spool/up2date it attempts to install it, fails on modifying the /etc/lilo.conf , but adds it as being installed. 

Expected Results:
 If the kernel is already installed, it shouldn't be installed again.
 It should not be possible to install the same package twice.

Additional Information:
	
[root@clarity up2date]# rpm -qf /boot/vmlinuz-2.2.19-7.0.10
kernel-2.2.19-7.0.10
kernel-2.2.19-7.0.10

The rpm file was in the directory when i ran up2date -u

Having multiple instances of a file in the RPM database is a form of corruption that may affect future attempts to update the file?
Comment 1 Adrian Likins 2001-10-24 16:07:22 EDT
Taking a look into this currently.
Comment 2 Need Real Name 2001-10-25 07:40:19 EDT
UPDATE

When I rebooted today, lilo didn't manage to boot the kernel.
The computer hang on the 'booting linux' message.
I did a hard reset and selected a previous kernel to enable booting.
The kernel re-installation dying while in the middle of something 
to do with lilois probably related.
Comment 3 Adrian Likins 2002-03-26 18:42:44 EST
This should be fixed with the 2.7.11 version or later of up2date.

If that is not the case, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.