Bug 550119 - sane-v4l not built due to missing BR libv4l-devel
Summary: sane-v4l not built due to missing BR libv4l-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-23 16:34 UTC by Kevin Kofler
Modified: 2010-01-26 01:02 UTC (History)
1 user (show)

Fixed In Version: 1.0.20-11.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-26 01:02:26 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2009-12-23 16:34:03 UTC
Description of problem:
sane-v4l is no longer being built in current sane-backends packages because in current releases of sane-backends, it requires libv4l. This means webcams cannot be used as image acquisition devices anymore. Please add:
BuildRequires: libv4l-devel

Version-Release number of selected component (if applicable):
sane-backends-1.0.20-4.fc11
sane-backends-1.0.20-10.fc12
sane-backends-1.0.20-10.fc13
(Those are the current releases in updates, they're definitely all affected, I haven't checked older packages as they're obsolete anyway.)

How reproducible:
Always.

Steps to Reproduce:
Just try firing up xsane with a webcam plugged in, or even just inspect the package and/or the build log.

Actual results:
sane-v4l backend missing.

Expected results:
sane-v4l backend available.

Additional info:
The build.log says:
checking for LIBV4L... no
[...]
*** v4l backend requires v4l libraries - disabling

libv4l is small, but if the dependency is unwanted in the main package anyway, a subpackage like for the gphoto2 backend would be possible. (But I'm personally in favor of things working out of the box.)

Comment 1 Nils Philippsen 2009-12-29 16:19:20 UTC
(In reply to comment #0)
> libv4l is small, but if the dependency is unwanted in the main package anyway,
> a subpackage like for the gphoto2 backend would be possible. (But I'm
> personally in favor of things working out of the box.)  

I agree that libv4l is not much of an additional burden (it's small and doesn't pull in other requirements), so I'll put in the v4l backend in the main package.

But (and that's referring to your comment in the other bug ;-): I'm not a friend of requiring other packages just because it makes some things working "out of the box" in some situations -- that's what comps is for. In that other case, requiring libsane-hpaio it would pull in cups, dbus, net-snmp libs which is not always desirable (since it would use much more space than, say, libv4l).

Comment 2 Nils Philippsen 2009-12-29 16:26:09 UTC
built sane-backends-1.0.20-11.fc12

Comment 3 Fedora Update System 2009-12-29 16:31:28 UTC
sane-backends-1.0.20-11.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sane-backends-1.0.20-11.fc12

Comment 4 Fedora Update System 2010-01-02 03:37:31 UTC
sane-backends-1.0.20-11.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sane-backends'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0062

Comment 5 Fedora Update System 2010-01-26 01:02:22 UTC
sane-backends-1.0.20-11.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.