Bug 550157 - No guest reboot functionality in 5.5 ?
No guest reboot functionality in 5.5 ?
Status: CLOSED DUPLICATE of bug 495479
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.5
All Linux
medium Severity medium
: alpha
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-23 14:54 EST by Gurhan Ozen
Modified: 2013-11-03 20:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-25 08:42:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-12-23 14:54:36 EST
Description of problem:
# virsh reboot rhel5Latest_x86_64_hvm_guest
error: Failed to reboot domain rhel5Latest_x86_64_hvm_guest
error: this function is not supported by the hypervisor: virDomainReboot

Here is the output with LIBVIRT_DEBUG:
# LIBVIRT_DEBUG=1 virsh reboot rhel5Latest_x86_64_hvm_guest
14:37:55.032: debug : virInitialize:290 : register drivers
14:37:55.032: debug : virRegisterDriver:667 : registering Test as driver 0
14:37:55.032: debug : virRegisterNetworkDriver:567 : registering Test as network driver 0
14:37:55.032: debug : virRegisterStorageDriver:598 : registering Test as storage driver 0
14:37:55.032: debug : virRegisterDeviceMonitor:629 : registering Test as device driver 0
14:37:55.032: debug : virRegisterDriver:667 : registering Xen as driver 1
14:37:55.032: debug : virRegisterDriver:667 : registering remote as driver 2
14:37:55.032: debug : virRegisterNetworkDriver:567 : registering remote as network driver 1
14:37:55.032: debug : virRegisterStorageDriver:598 : registering remote as storage driver 1
14:37:55.032: debug : virRegisterDeviceMonitor:629 : registering remote as device driver 1
14:37:55.033: debug : virConnectOpenAuth:1100 : name=(null), auth=0x31fc29d340, flags=0
14:37:55.033: debug : do_open:922 : no name, allowing driver auto-select
14:37:55.033: debug : do_open:930 : trying driver 0 (Test) ...
14:37:55.033: debug : do_open:936 : driver 0 Test returned DECLINED
14:37:55.033: debug : do_open:930 : trying driver 1 (Xen) ...
14:37:55.033: debug : do_open:936 : driver 1 Xen returned DECLINED
14:37:55.033: debug : do_open:930 : trying driver 2 (remote) ...
14:37:55.033: debug : remoteOpen:1006 : Auto-probe remote URI
14:37:55.033: debug : doRemoteOpen:513 : proceeding with name = 
14:37:55.033: debug : call:6555 : Doing call 66 (nil)
14:37:55.033: debug : call:6625 : We have the buck 66 0x2ad58b277010 0x2ad58b277010
14:37:55.033: debug : processCallRecvLen:6213 : Got length, now need 36 total (32 more)
14:37:55.033: debug : processCalls:6481 : Giving up the buck 66 0x2ad58b277010 (nil)
14:37:55.033: debug : call:6656 : All done with our call 66 (nil) 0x2ad58b277010
14:37:55.033: debug : call:6555 : Doing call 1 (nil)
14:37:55.033: debug : call:6625 : We have the buck 1 0x1f483f50 0x1f483f50
14:37:55.034: debug : processCallRecvLen:6213 : Got length, now need 28 total (24 more)
14:37:55.034: debug : processCalls:6481 : Giving up the buck 1 0x1f483f50 (nil)
14:37:55.034: debug : call:6656 : All done with our call 1 (nil) 0x1f483f50
14:37:55.034: debug : call:6555 : Doing call 110 (nil)
14:37:55.034: debug : call:6625 : We have the buck 110 0x1f483f50 0x1f483f50
14:37:55.034: debug : processCallRecvLen:6213 : Got length, now need 48 total (44 more)
14:37:55.034: debug : processCalls:6481 : Giving up the buck 110 0x1f483f50 (nil)
14:37:55.034: debug : call:6656 : All done with our call 110 (nil) 0x1f483f50
14:37:55.034: debug : doRemoteOpen:805 : Auto-probed URI is qemu:///system
14:37:55.034: debug : doRemoteOpen:824 : Adding Handler for remote events
14:37:55.034: debug : doRemoteOpen:831 : virEventAddHandle failed: No addHandleImpl defined. continuing without events.
14:37:55.034: debug : do_open:936 : driver 2 remote returned SUCCESS
14:37:55.034: debug : do_open:956 : network driver 0 Test returned DECLINED
14:37:55.034: debug : do_open:956 : network driver 1 remote returned SUCCESS
14:37:55.034: debug : do_open:978 : storage driver 0 Test returned DECLINED
14:37:55.034: debug : do_open:978 : storage driver 1 remote returned SUCCESS
14:37:55.034: debug : do_open:999 : node driver 0 Test returned DECLINED
14:37:55.034: debug : do_open:999 : node driver 1 remote returned SUCCESS
14:37:55.034: debug : virDomainLookupByName:1718 : conn=0x1f47a9a0, name=rhel5Latest_x86_64_hvm_guest
14:37:55.034: debug : call:6555 : Doing call 23 (nil)
14:37:55.034: debug : call:6625 : We have the buck 23 0x1f483f50 0x1f483f50
14:37:55.034: debug : processCallRecvLen:6213 : Got length, now need 80 total (76 more)
14:37:55.034: debug : processCalls:6481 : Giving up the buck 23 0x1f483f50 (nil)
14:37:55.034: debug : call:6656 : All done with our call 23 (nil) 0x1f483f50
14:37:55.034: debug : virGetDomain:271 : New hash entry 0x1f480780
14:37:55.034: debug : virDomainReboot:2225 : domain=0x1f480780, flags=0
14:37:55.034: debug : call:6555 : Doing call 27 (nil)
14:37:55.034: debug : call:6625 : We have the buck 27 0x1f483f50 0x1f483f50
14:37:55.035: debug : processCallRecvLen:6213 : Got length, now need 220 total (216 more)
14:37:55.035: debug : processCalls:6481 : Giving up the buck 27 0x1f483f50 (nil)
14:37:55.035: debug : call:6656 : All done with our call 27 (nil) 0x1f483f50
error: Failed to reboot domain rhel5Latest_x86_64_hvm_guest
14:37:55.035: debug : virDomainFree:1806 : domain=0x1f480780
14:37:55.035: debug : virUnrefDomain:345 : unref domain 0x1f480780 rhel5Latest_x86_64_hvm_guest 1
14:37:55.035: debug : virReleaseDomain:303 : release domain 0x1f480780 rhel5Latest_x86_64_hvm_guest
14:37:55.035: debug : virReleaseDomain:315 : unref connection 0x1f47a9a0 2
error: this function is not supported by the hypervisor: virDomainReboot

14:37:55.035: debug : virConnectClose:1118 : conn=0x1f47a9a0
14:37:55.035: debug : call:6555 : Doing call 2 (nil)
14:37:55.035: debug : call:6625 : We have the buck 2 0x1f483f50 0x1f483f50
14:37:55.035: debug : processCallRecvLen:6213 : Got length, now need 28 total (24 more)
14:37:55.035: debug : processCalls:6481 : Giving up the buck 2 0x1f483f50 (nil)
14:37:55.035: debug : call:6656 : All done with our call 2 (nil) 0x1f483f50
14:37:55.035: debug : virUnrefConnect:210 : unref connection 0x1f47a9a0 1
14:37:55.035: debug : virReleaseConnect:171 : release connection 0x1f47a9a0


Version-Release number of selected component (if applicable):
# rpm -q libvirt kernel 
libvirt-0.6.3-25.el5
libvirt-0.6.3-25.el5
kernel-2.6.18-182.el5


How reproducible:
Everytime.

Steps to Reproduce:
1. Install 5.5 nightly tree , install a guest and try to reboot it. 
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Veillard 2009-12-25 08:42:43 EST
dup of 495479, Daniel

*** This bug has been marked as a duplicate of bug 495479 ***

Note You need to log in before you can comment on or make changes to this bug.