Bug 550174 - Xdebug 2.0.5 does not return variable values to the debugger application
Summary: Xdebug 2.0.5 does not return variable values to the debugger application
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: php-pecl-xdebug
Version: 12
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-23 22:05 UTC by Keith Roberts
Modified: 2012-11-12 16:33 UTC (History)
3 users (show)

Fixed In Version: php-pecl-xdebug-2.1.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 580214 (view as bug list)
Environment:
Last Closed: 2010-09-01 05:48:17 UTC


Attachments (Terms of Use)
Screencast of Eclipse demonstrating the missing variable values (3.29 MB, application/octet-stream)
2009-12-24 23:06 UTC, Keith Roberts
no flags Details
Still screenshot of Eclipse on F10 showing variable values correctly (167.19 KB, image/png)
2009-12-24 23:18 UTC, Keith Roberts
no flags Details
Screencast with audio demonstrating possible xdebug problem with variables (13.68 MB, application/octet-stream)
2009-12-28 22:32 UTC, Keith Roberts
no flags Details
This xdebug works OK on F12 with PHP 5.3.1 and Apache 2.2.14 (512.29 KB, application/octet-stream)
2010-01-08 17:26 UTC, Keith Roberts
no flags Details
Source code for compiled xdebug that works (288.65 KB, application/x-gzip)
2010-01-08 17:43 UTC, Keith Roberts
no flags Details
Screencast demonstrating Eclipse and PDT working correctly using Xdebug v2.1.0beta1 (9.08 MB, application/octet-stream)
2010-01-08 18:40 UTC, Keith Roberts
no flags Details
Proposed new srpm (298.00 KB, application/octet-stream)
2010-03-10 13:40 UTC, Stefan Riemens
no flags Details

Description Keith Roberts 2009-12-23 22:05:06 UTC
When debugging PHP applications in Fedora Eclipse, there are no values shown when hovering the mouse pointer over a variable name. All variables in the debug
variables pane are 'uninitialised'.


There seems to be a bug in the current version of xdebug that's causing this.

Please see this bug report for xdebug 2.0.5:

http://bugs.xdebug.org/view.php?id=469

Hope this can get fixed ASAP :)

Comment 1 Keith Roberts 2009-12-24 23:06:36 UTC
Created attachment 380257 [details]
Screencast of Eclipse demonstrating the missing variable values

Comment 2 Keith Roberts 2009-12-24 23:12:22 UTC
Sorry there's no sound on the screencast demo.

Please notice how the variable values do not show in the variables pane, or when I hover the mouse over the variables in the source code editor panel.

I have tried downgrading PHP to PHP 5.3.0 but still get no joy with this on F12.

Funny thing is, on F10, which uses xdebug 2.0.5 and PHP 5.2.9 it all works OK.

Comment 3 Keith Roberts 2009-12-24 23:18:40 UTC
Created attachment 380258 [details]
Still screenshot of Eclipse on F10 showing variable values correctly

Comment 4 Keith Roberts 2009-12-28 22:32:10 UTC
Created attachment 380692 [details]
Screencast with audio demonstrating possible xdebug problem with variables

Here is a new screencast with audio added.

Comment 5 Arif Saleem 2010-01-07 11:28:48 UTC
I'm using Netbeans 6.8 (downloaded from netbeans.org) on F12 x86_64 and have the same problem where PHP debugger sessions using php-pecl-xdebug do not show local variables.
The problem is a known bug in Xdebug 2.0.5, and has been fixed in the 2.1 Beta.
The problem is described on the netbeans forums here :
http://forums.netbeans.org/topic20971.html

I have used a development build of /usr/lib64/php/modules/xdebug.so version 2.1 from the Komodo project ( http://aspn.activestate.com/ASPN/Downloads/Komodo/RemoteDebugging ) and this fixes the problem.

Can php-pecl-xdebug be upgraded to version 2.1 Beta1 to fix this problem?

TIA
Arif Saleem

Comment 6 Keith Roberts 2010-01-08 17:24:03 UTC
Thanks for the input Arif.

I have now downloaded the source code for xdebug-2.1.0beta1 and compiled it on F12 32-bit i686.

I have got it working now!

Comment 7 Keith Roberts 2010-01-08 17:26:53 UTC
Created attachment 382505 [details]
This xdebug works OK on F12 with PHP 5.3.1 and Apache 2.2.14

Comment 8 Keith Roberts 2010-01-08 17:33:42 UTC
I compiled the xdebug-2.1.0beta1 and then renamed /usr/lib/php/modules/xdebug.so to something else. Then overwrote that file with the xdebug-2.1.0beta1 version. So I did not uninstall the php-pecl-xdebug package.

Restarted apache and checked the phpinfo output.

Just for good measure did a complete new installation of Fedora Eclipse.

The enabled the Eclipse Galileo repo, and installed PDT and it's required plugins.

Comment 9 Keith Roberts 2010-01-08 17:43:37 UTC
Created attachment 382509 [details]
Source code for compiled xdebug that works

Here's the source code downloaded from Deriks site that I used. Just in case you want to compile it for another Arch - like 64 bit :)

Comment 10 Keith Roberts 2010-01-08 18:40:48 UTC
Created attachment 382514 [details]
Screencast demonstrating Eclipse and PDT working correctly using  Xdebug v2.1.0beta1

Comment 11 Stefan Riemens 2010-03-10 13:40:18 UTC
Created attachment 399083 [details]
Proposed new srpm

I've made an update for this package. I've disabled the patch, it didn't apply cleanly. I don't know what it was supposed to achieve, or whether it was already sent upstream etc. I've verified that it works for me (f12, x86-64). Builds cleanly in mock.

Comment 12 Keith Roberts 2010-03-10 15:01:54 UTC
Thanks for doing that Stefan. I'm not up to speed on building RPM packages yet, but it's something I want to learn, so to become a Fedora RPM packager / maintainer :)

I have read Maximum RPM, which is a very good guide to using RPM, and creating packages: http://www.rpm.org/max-rpm-snapshot/

Comment 13 Stefan Riemens 2010-03-10 15:15:48 UTC
You can find prebuilt packages for f12 here:
riemens.mine.nu:8080/fedora/php-pecl-xdebug-2.1.0beta3-0.fc12.i686.rpm
riemens.mine.nu:8080/fedora/php-pecl-xdebug-2.1.0beta3-0.fc12.x86_64.rpm

I haven't tested the 32-bit version...

Comment 14 Stefan Riemens 2010-04-06 20:31:05 UTC
Any chance of getting an updated package in fedora? The current xdebug is hardly usable in it's current form...

Thanks, Stefan

Comment 15 Stefan Riemens 2010-07-03 10:53:49 UTC
Ping? Any update on this?

Comment 16 Fedora Admin XMLRPC Client 2010-08-11 17:52:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 17 Fedora Update System 2010-08-11 19:26:10 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc14

Comment 18 Fedora Update System 2010-08-11 19:26:41 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc13

Comment 19 Fedora Update System 2010-08-11 19:27:08 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc12

Comment 20 Fedora Update System 2010-08-12 04:07:26 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc12

Comment 21 Fedora Update System 2010-08-12 04:11:29 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc13

Comment 22 Fedora Update System 2010-08-12 19:59:45 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-xdebug'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.0-1.fc14

Comment 23 Fedora Update System 2010-09-01 05:48:08 UTC
php-pecl-xdebug-2.1.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2010-09-02 20:47:28 UTC
php-pecl-xdebug-2.1.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2010-09-02 20:49:40 UTC
php-pecl-xdebug-2.1.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Keith Roberts 2012-11-12 16:17:41 UTC
Note: These ogv files will not play back on older versions of Linux - like Centos 5.x, which approximates to about Fedora 8. It seems that ogv files need the same or a more recent version of the video decoders to play back fine.

Comment 27 Keith Roberts 2012-11-12 16:33:03 UTC
If you need to, it is possible to convert the ogv files to mp4 videos to work on Centos 5.x using the ffmpeg command:

[root@karsites XdebugReport]# ffmpeg -i xdebug-fixed.ogv xdebug-fixed.mp4

FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
  built on Jan 29 2012 23:56:18 with gcc 4.1.2 20080704 (Red Hat 4.1.2-51)


Note You need to log in before you can comment on or make changes to this bug.