Bug 550177 - Qt 4.6.0 fails to correctly render some bitmap fonts
Qt 4.6.0 fails to correctly render some bitmap fonts
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
http://bugreports.qt.nokia.com/browse...
:
Depends On:
Blocks: qt46
  Show dependency treegraph
 
Reported: 2009-12-23 17:27 EST by Artem S. Tashkinov
Modified: 2010-02-09 13:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-09 13:54:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example (151.50 KB, image/png)
2009-12-23 17:27 EST, Artem S. Tashkinov
no flags Details
terminus appearning ok on f12 x86_64 box with qt-4.6.0-3 (108.14 KB, image/png)
2009-12-23 20:58 EST, Rex Dieter
no flags Details
Bug reproduced in F12 + Qt 4.6.0 (117.00 KB, image/png)
2009-12-31 06:33 EST, Artem S. Tashkinov
no flags Details

  None (edit)
Description Artem S. Tashkinov 2009-12-23 17:27:23 EST
Created attachment 380090 [details]
Example

Description of problem: Qt 4.6.0 doesn't properly render Terminus font in Linux.

Version-Release number of selected component (if applicable): 4.6.0

How reproducible: always, it's a regression.

Steps to Reproduce:
1. Install rawhide, Fedora 13
2. Install terminus font
3. Try to use it in any Qt/KDE application.
  
Actual results: Something terribly wrong is rendered instead of Terminus font.

Expected results: Proper rendering.

Additional info: Qt 4.5.3/Qt 3.5.8 don't have this bug.
Comment 1 Rex Dieter 2009-12-23 20:57:41 EST
I cannot reproduce on my F12 box with qt-4.6.0.  Screenshot forthcoming.
Comment 2 Rex Dieter 2009-12-23 20:58:38 EST
Created attachment 380117 [details]
terminus appearning ok on f12 x86_64 box with qt-4.6.0-3
Comment 3 Artem S. Tashkinov 2009-12-24 03:59:12 EST
(In reply to comment #1)
> I cannot reproduce on my F12 box with qt-4.6.0.  Screenshot forthcoming.  

OK, let's go deeper into details.

1) Are you on Rawhide or Fedora 12?

2) Is your freetype compiled with --with bytecode_interpreter and --with subpixel_rendering ? (because that's how I use it here)

3) I can post my .fonts.conf so that we can investigate that further.
Comment 4 Kevin Kofler 2009-12-24 04:59:48 EST
Yeah, I strongly suspect this is related to freetype.

rdieter: Try installing freetype-freeworld on F12 and see if you can reproduce it with that.
Comment 5 Artem S. Tashkinov 2009-12-24 08:22:50 EST
I cannot reproduce this bug on Rawhide, it only appears on *my* Fedora 12.
Comment 6 Artem S. Tashkinov 2009-12-24 09:15:25 EST
On Fedora 12 this bug has something to do with X server.

1) With NVIDIA proprietary drivers Terminus font is misrendered by Qt 4.6.

2) With Vesa driver Terminus font with size 9 is shown correctly, but with any other size, symbols are rendered as squares.

Also I've found out, that Qt 3.X which is not affected uses libXft to render fonts, while Qt 4.X don't use this library. The strange thing is that Qt 4.5.3 doesn't have this bug, and Qt 4.6.0 has this bug.

P.S. nv drivers doesn't work here so I cannot test it.

I have no idea how to find out the cause of this problem :(
Comment 7 Rex Dieter 2009-12-24 09:40:21 EST
f12 with stock freetype.
Comment 8 Artem S. Tashkinov 2009-12-24 10:01:40 EST
(In reply to comment #7)
> f12 with stock freetype.  

Qt 4.6.0 is not available on F12, how did you install it?
Comment 9 Artem S. Tashkinov 2009-12-31 06:33:19 EST
Created attachment 381076 [details]
Bug reproduced in F12 + Qt 4.6.0

I have reproduced this bug in a VMWare VM in a stock F12:

Steps to reproduce:

1) Install a stock F12, without updating anything.
2) Update Qt 4.6.0 packages to their rawhide versions (qt-4.6.0-3.fc13.i686.rpm, qt-x11-4.6.0-3.fc13.i686.rpm via 'rpm -Uvh --nodeps').
3) Install terminus font.
4) run qtconfig-qt4, try to use Terminus font of different sizes.
Comment 10 Artem S. Tashkinov 2009-12-31 06:37:44 EST
Bug description is obviously erroneous, as this issue affects F12, not F13.
Comment 11 Rex Dieter 2010-01-05 16:29:24 EST
Can anyone else reproduce this?  (I cannot)
Comment 12 Artem S. Tashkinov 2010-01-05 16:48:27 EST
(In reply to comment #11)
> Can anyone else reproduce this?  (I cannot)  

Have you tried to follow the recipe from comment 9? I can even upload a VM image demonstrating this bug.
Comment 13 Rex Dieter 2010-01-11 15:27:48 EST
Yes, terminus looks fine for me.

Can you please try qt-4.6.0-5 ?  It includes a patch related to bitmap fonts (disables Xrender/antialiasing in this case).

See also,
http://bugreports.qt.nokia.com/browse/QTBUG-7255
Comment 14 Artem S. Tashkinov 2010-01-12 02:55:38 EST
I've just downloaded and installed qt-x11-4.6.0-5.fc13.i686.rpm from Koji and nothing has changed for me.
Comment 15 Artem S. Tashkinov 2010-02-09 13:54:45 EST
I cannot reproduce this problem no longer. Closing.

Note You need to log in before you can comment on or make changes to this bug.