Bug 550273 - qemu aborted when run "service network restart" in guest that with i82551 vNIC
qemu aborted when run "service network restart" in guest that with i82551 vNIC
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Amos Kong
Virtualization Bugs
: Triaged, Upstream
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-12-24 05:33 EST by Miya Chen
Modified: 2016-04-26 09:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: kvm-83-232.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 05:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch should fix the problem (6.27 KB, patch)
2011-03-17 02:14 EDT, Michael S. Tsirkin
no flags Details | Diff

  None (edit)
Description Miya Chen 2009-12-24 05:33:27 EST
Test with kvm-83-139.el5, come across that qemu aborted when run "service
network restart" for one time when using i82551 vnic

steps:
1. boot guest with e1000 nic:
/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2
-drive file=rhel5u4-64-virtio.qcow2,if=virtio,boot=on,format=qcow2,cache=off
-smp 2 -m 2G -vnc :2 -net nic,macaddr=20:20:20:11:00:91,model=e1000,vlan=0 -net
tap,script=/etc/qemu-ifup,vlan=0 -monitor stdio 

2. shutdown guest

3. boot guest with i82551 nic:
/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2
-drive file=rhel5u4-64-virtio.qcow2,if=virtio,boot=on,format=qcow2,cache=off
-smp 2 -m 2G -vnc :2 -net nic,macaddr=20:20:20:11:00:91,model=i82551,vlan=0
-net tap,script=/etc/qemu-ifup,vlan=0 -monitor stdio 

4. In guest:
cd /etc/sysconfig/network-scripts/
mv ifcfg-eth0.bak ifcfg-eth0
service network restart

Actual result:
(qemu) qemu-kvm:
/builddir/build/BUILD/kvm-83-maint-snapshot-20090205/qemu/hw/eepro100.c:1573:
nic_receive: Assertion `0' failed.
Aborted

michen->nsprei:
could you please help to check this issue? i cannot reproduce it any more.  

------- Comment #8 From Naphtali Sprei (nsprei@redhat.com) 2009-12-24 05:18:16 EDT (-) [reply] ------- Private

I can reproduce the issue, consistently, using qemu built out of latest git
version of rhel, using guest rhel 5.3 64bit.

I think it's a different issue than this one.
Shouldn't it be a new/different bug ?
Comment 5 RHEL Product and Program Management 2011-01-11 15:46:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2011-01-11 17:48:25 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 7 Eduardo Habkost 2011-01-13 11:59:14 EST
Reassigning to mst.
Comment 8 Miya Chen 2011-01-28 05:09:07 EST
Tried with the same steps in description using kvm-83-224.el5, still cannot reproduce it again.

guest:
rhel5.4-64
rhel6.0-64
Comment 10 Michael S. Tsirkin 2011-03-17 02:14:04 EDT
Created attachment 485925 [details]
this patch should fix the problem
Comment 14 Mike Cao 2011-05-13 05:55:07 EDT
Tried on 
# rpm -q kvm
kvm-83-229.el5

steps:
1.install VM with e1000.
eg:/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2
-drive file=rhel5u4-64-virtio.qcow2,if=virtio,boot=on,format=qcow2,cache=off
-smp 2 -m 2G -vnc :2 -net nic,macaddr=20:20:20:11:00:91,model=e1000,vlan=0 -net
tap,script=/etc/qemu-ifup,vlan=0 -monitor stdio 

2. shutdown guest

3. boot guest with i82551 nic:
/usr/libexec/qemu-kvm -rtc-td-hack -no-hpet -usbdevice tablet -cpu qemu64,+sse2
-drive file=rhel5u4-64-virtio.qcow2,if=virtio,boot=on,format=qcow2,cache=off
-smp 2 -m 2G -vnc :2 -net nic,macaddr=20:20:20:11:00:91,model=i82551,vlan=0
-net tap,script=/etc/qemu-ifup,vlan=0 -monitor stdio 

4. In guest:
for ((i=1;i<=1000;i++))
do
service network restart

Actual result:
guest works fine ,guest does not quit.I can not reproduce this issue.

bcao--->mst
Hi,mst

Could you tell me How I can reproduce it ?

Best Regards,
Mike
Comment 16 Miya Chen 2011-05-16 06:03:12 EDT
Hi, mst
as in description, I only hit this problem once when i reported the bug and then never reproduce it again(nsprei said he can reproduce it consistently but he has gone), so can we verify it by checking if patch was applied and nic sanity testing?
Comment 18 Mike Cao 2011-05-18 04:07:32 EDT
(In reply to comment #17)
> it doesn't really cover a lot :)
> above seems to suggest a 5.3 guest.
> tried that?

Verified on 

I use RHEL5.3 64 bit guest for testing with the steps in comment #14.

Actural Results:

Tried 10000 times restart network in the guest ,qemu does not abort.

Based on above ,this issue has been fixed.
Comment 19 Mike Cao 2011-05-18 04:15:28 EDT
(In reply to comment #18)
> Verified on 
> 
> I use RHEL5.3 64 bit guest for testing with the steps in comment #14.
> 
> Actural Results:
> 
> Tried 10000 times restart network in the guest ,qemu does not abort.
> 
> Based on above ,this issue has been fixed.

Verified on 
# uname -r
2.6.18-260.el5
# rpm -q kvm
kvm-83-232.el5
Comment 20 Mike Cao 2011-05-19 07:13:53 EDT
Reproduced the issue on kernel-2.6.18-190.el5 & kvm-83-161.el5
Verified the issue on kernel-2.6.18-260.el5 & kvm-83-232.el5

steps:
1.start guest with i82551nic.
2.in the guest 
  #ifconfig eth0 allmulti 
2.on the host
  #ping 224.0.0.1 

Actual Resuts:
on kvm-83-161.el5 :qemu-kvm crash due to qemu-kvm: /builddir/build/BUILD/kvm-83-maint-snapshot-20090205/qemu/hw/eepro100.c:1521: nic_receive: Assertion `!(s->configuration[21] & (1 << (3)))' failed.

on kvm-83-232.el5 :qemu-monior prompts "eepro100: feature is missing in this emulation: Multicast All bit" in a loop
Comment 21 Mike Cao 2011-05-19 07:17:38 EDT
Nic Stress test on kvm-83-232.el5:
1.disable allmulti and do some stress of incoming packets
2.in the guest #netserver
3.on the host 
for b in
32 64 128 256 512 1024 1460 2048 4096 8192  9000 16384 32768  65495 65507
do ./netperf -t TCP_STREAM -f m -H <guest ip> -P 0 -l 10 -- -m $b
done
 
 
for b in 
32 64 128 256 512 1024 1460 2048 4096 8192  9000 16384 32768  65495 65507
do ./netperf -t UDP_STREAM -f m -H <guest ip> -P 0 -l 10 -- -m $b
done

Actual Results:

After step3 ,guest network  down ,can not ping .#service network restart still does *not* help


Based on above ,re-assign this issue for developer to look into this.
Comment 22 Michael S. Tsirkin 2011-06-14 11:24:31 EDT
To Comment 21:
So in this case, what you do is network stress and guest network goes down?
service network restart is not involved at all?
Comment 23 Mike Cao 2011-06-15 03:01:11 EDT
(In reply to comment #22)
> To Comment 21:
> So in this case, what you do is network stress and guest network goes down?
> service network restart is not involved at all?

yes.
Comment 26 Amos Kong 2011-08-01 02:01:10 EDT
This model is not supported by us. I've reported a bz in upstream.
https://bugs.launchpad.net/qemu/+bug/808588

So I suggest close this bz to WONTFIX.
Comment 27 Amos Kong 2011-08-01 05:18:12 EDT
Have confirmed with Ronen, close it.

Note You need to log in before you can comment on or make changes to this bug.