Bug 550431 - KMS:R200:kernel command stream rejection
KMS:R200:kernel command stream rejection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-25 01:44 EST by Nicholas Miell
Modified: 2010-12-05 02:15 EST (History)
3 users (show)

See Also:
Fixed In Version: kernel-2.6.35.9-64.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 02:15:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (98.96 KB, text/plain)
2009-12-25 01:44 EST, Nicholas Miell
no flags Details
Xorg log (16.25 KB, text/plain)
2009-12-25 16:12 EST, Nicholas Miell
no flags Details
xorg.conf (1.76 KB, text/plain)
2009-12-25 16:12 EST, Nicholas Miell
no flags Details
Xorg log (44.04 KB, text/plain)
2009-12-25 16:15 EST, Nicholas Miell
no flags Details
dmesg with drm.debug=1 (48.92 KB, text/plain)
2009-12-29 13:20 EST, Nicholas Miell
no flags Details
Xorg log with nomodeset (98.33 KB, text/plain)
2009-12-29 13:27 EST, Nicholas Miell
no flags Details
celestia error spew (243.14 KB, text/plain)
2010-01-11 16:33 EST, Nicholas Miell
no flags Details
glxgears miscoloring #1 (6.43 KB, image/png)
2010-01-24 13:25 EST, Nicholas Miell
no flags Details
glxgears miscoloring #2 (5.84 KB, image/png)
2010-01-24 13:26 EST, Nicholas Miell
no flags Details

  None (edit)
Description Nicholas Miell 2009-12-25 01:44:20 EST
Created attachment 380282 [details]
dmesg

Description of problem:
Attempting to run Google Earth results in a "kernel failed to parse or rejected command stream" error.

Version-Release number of selected component (if applicable):
kernel-2.6.31.6-166.fc12.x86_64
xorg-x11-drv-ati-6.13.0-0.11.20091119git437113124.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run googleearth
  
Actual result:
CS section size missmatch start at (r200_state_init.c,tex_emit_mm,701) 5 vs 9
CS section end at (r200_state_init.c,tex_emit_mm,717)
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.
Google Earth has caught signal 11.
Comment 1 Nicholas Miell 2009-12-25 16:11:11 EST
Still does it with kernel-2.6.31.9-174.fc12.x86_64

This is with
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QH [Radeon 8500] (rev 80)
Comment 2 Nicholas Miell 2009-12-25 16:12:34 EST
Created attachment 380347 [details]
Xorg log
Comment 3 Nicholas Miell 2009-12-25 16:12:58 EST
Created attachment 380348 [details]
xorg.conf
Comment 4 Nicholas Miell 2009-12-25 16:15:56 EST
Created attachment 380349 [details]
Xorg log

attached the wrong log, sorry
Comment 5 Nicholas Miell 2009-12-25 16:35:36 EST
Turns out GL is generally broken

- glxgears renders with random colors, which alternate whenever it writes the framerate to stdout and GNOME Terminal updates

- Nearly every GL xscreensaver either renders wrong, spews endless command stream errors (kernel rejection or possible command buffer overflow warnings), or does both

- crack-attack doesn't draw the the play field

- celestia crashes at startup, after a predicted size overflow warning and a CS size mismatch warning

etc.
Comment 6 Nicholas Miell 2009-12-28 02:30:00 EST
Tried updating to mesa 7.6-0.18 from koji, didn't help.
Comment 7 Nicholas Miell 2009-12-29 00:51:47 EST
Tried with nomodeset. glxgears rendered correctly, Celestia hard locks the machine, Google Earth causes a panic.
Comment 8 François Cami 2009-12-29 10:11:57 EST
Hi Nicholas,

Could you attach /var/log/dmesg after booting with drm.debug=1 as kernel parameter?
Could you also try with nomodeset and attach /var/log/Xorg.0.log?

I can confirm the R200 glxgears brokenness (it happens with my FireGL 8800/R200 128MB).

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Nicholas Miell 2009-12-29 13:20:26 EST
Created attachment 380834 [details]
dmesg with drm.debug=1

Xorg.0.log with nomodeset will be coming shortly
Comment 10 Nicholas Miell 2009-12-29 13:27:17 EST
Created attachment 380836 [details]
Xorg log with nomodeset
Comment 11 François Cami 2009-12-29 15:52:33 EST
Thank you Nicholas.

Can you confirm that launching GL applications with LIBGL_ALWAYS_SOFTWARE=1 results in correct rendering?

All logs aboard, switching to ASSIGNED.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Nicholas Miell 2009-12-29 16:42:52 EST
glxgears and Google Earth render correctly using software, Celestia still gets a SIGFPE at start up, which I'm inclined to believe isn't Mesa's fault. (Mesa isn't involved in the stack trace at all.)
Comment 13 Nicholas Miell 2009-12-29 17:05:34 EST
Huh. Somewhere in all the rebooting, things started rendering correctly again, but with the usual spate of command buffer warnings. I'm also not seeing the glyph cache and/or root pixmap corruption that I saw from time-to-time (and failed to mention in this bug report).

Perhaps the result of the mesa upgrade?
Comment 14 Jérôme Glisse 2010-01-11 07:55:38 EST
Yes likely. Please update everythings and report back if you still see issues or not.
Comment 15 Nicholas Miell 2010-01-11 10:06:20 EST
Upgraded to mesa 7.7-2.fc12 and libdrm 2.4.17-1.fc12 -- no improvement.
Comment 16 Nicholas Miell 2010-01-11 16:33:19 EST
OK, I rebooted under the assumption that testing from a clean slate would be a good idea and discovered the hard way that my old xorg-x11-drv-ati segfaults with the new libdrm. After updating that to xorg-x11-drv-ati-6.13.0-0.20.20091221git4b05c47ac.fc12.x86_64, X works again.

* glxgears still renders with the wrong colors.

* googleearth no longer segfaults, but it does exit with
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

dmesg is:
[drm:r100_cs_track_texture_check] *ERROR* Texture of unit 0 needs 131072 bytes but is 32768
[drm:r100_cs_track_texture_print] *ERROR* pitch                      256
[drm:r100_cs_track_texture_print] *ERROR* use_pitch                  0
[drm:r100_cs_track_texture_print] *ERROR* width                      256
[drm:r100_cs_track_texture_print] *ERROR* width_11                   2048
[drm:r100_cs_track_texture_print] *ERROR* height                     256
[drm:r100_cs_track_texture_print] *ERROR* height_11                  2048
[drm:r100_cs_track_texture_print] *ERROR* num levels                 0
[drm:r100_cs_track_texture_print] *ERROR* depth                      0
[drm:r100_cs_track_texture_print] *ERROR* bpp                        2
[drm:r100_cs_track_texture_print] *ERROR* coordinate type            1
[drm:r100_cs_track_texture_print] *ERROR* width round to power of 2  0
[drm:r100_cs_track_texture_print] *ERROR* height round to power of 2 0
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

* celestia doesn't segfault either, it just exits unexpectedly. errors attached.

dmesg is:
[drm:r100_cs_track_texture_check] *ERROR* No texture bound to unit 1
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

* xscreensavers misrender and spew errors, as per usual
Comment 17 Nicholas Miell 2010-01-11 16:33:48 EST
Created attachment 383101 [details]
celestia error spew
Comment 18 Nicholas Miell 2010-01-24 13:25:31 EST
Created attachment 386464 [details]
glxgears miscoloring #1
Comment 19 Nicholas Miell 2010-01-24 13:26:15 EST
Created attachment 386465 [details]
glxgears miscoloring #2

glxgears flickers between these two color schemes, and never draws the correct colors
Comment 20 Nicholas Miell 2010-01-29 18:56:36 EST
Latest mesa-libGL-7.7-3.fc12.x86_64 fixes the color issues, but celestia and googleearth still blow up (and googleearth's explosion still corrupts the render glyph cache).
Comment 21 Nicholas Miell 2010-09-30 19:56:34 EDT
Tested with the (updated) September 2010 graphics test day CD live image and the kernel is still rejecting command streams with the R200 T0/T1 GPU hang workarounds.
Comment 22 Bug Zapper 2010-11-03 22:36:01 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Nicholas Miell 2010-11-04 00:28:38 EDT
This was finally fixed upstream in 43b93fbffc2c080dba2e84df6fce8d7e6c0a2581.

F14 is still broken, though.
Comment 24 Dave Airlie 2010-12-04 02:44:02 EST
can you check the F14 kernel in koji?

http://kojipkgs.fedoraproject.org/packages/kernel/2.6.35.9/64.fc14/
Comment 25 Nicholas Miell 2010-12-04 13:14:55 EST
2.6.35.9-64.fc14 fixes this problem
Comment 26 Dave Airlie 2010-12-05 02:15:23 EST
seems pushed to stable now.

Note You need to log in before you can comment on or make changes to this bug.