Bug 55052 - XFree4 glint driver draws corrupted pixmaps
XFree4 glint driver draws corrupted pixmaps
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-10-24 18:22 EDT by Greg Bailey
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-06 15:39:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
What netscape looks like with acceleration enabled... (37.08 KB, image/gif)
2001-10-24 18:23 EDT, Greg Bailey
no flags Details
XFree86 4.1.0 configuration file (1.86 KB, text/plain)
2001-11-01 14:29 EST, Greg Bailey
no flags Details
XFree86 4.1.0 log file (6.38 KB, text/plain)
2001-11-01 14:30 EST, Greg Bailey
no flags Details
Xfree86 4.1.0 log file (with XaaNoPixmapCache) (17.04 KB, text/plain)
2001-11-06 11:36 EST, Greg Bailey
no flags Details
Xfree86 4.1.0 configuration file (with XaaNoPixmapCache) (1.89 KB, text/plain)
2001-11-06 11:37 EST, Greg Bailey
no flags Details
Output of "lspci -vn" (1.54 KB, text/plain)
2001-11-06 12:55 EST, Greg Bailey
no flags Details

  None (edit)
Description Greg Bailey 2001-10-24 18:22:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
The hardware acceleration when using the "glint" driver in XFree86 4.1.0
doesn't draw graphics correctly.  When using netscape, for example, large
sections of the page will have corrupted images.  (See attached example

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Install default RH 7.2, with updates as of 10/24/2001
2.  Run "Xconfigurator"--accept default values
3.  Launch a program with graphics (i.e. netscape)

Actual Results:  xterm applications seem normal, but graphics programs seem
to exhibit the corruption.

Expected Results:  I should be able to >read< the web pages... :-(

Additional info:

When running Xconfigurator, it displays the following:

PCI Entry:     Texas Instruments|TVP4020 [Permedia 2]
X Server:      XF86_3DLabs
XFree4 driver: glint       (default)

NOTE:  I can install XF86_3DLabs-3.3.6-42 RPM, and the accelerated mode
works-AS LONG AS I use the option "no_pixmap_cache".  However, I can't find
an equivalent to the "no_pixmap_cache" option under XFree 4.1.0
Comment 1 Greg Bailey 2001-10-24 18:23:33 EDT
Created attachment 34961 [details]
What netscape looks like with acceleration enabled...
Comment 2 Greg Bailey 2001-10-26 17:23:18 EDT
More testing shows that this problem only manifests itself depending on the
resolution of the video:

1024x768:  OK.  Problem does not appear
1280x1024: OK.  Problem does not appear
1600x1200: FAILS.  Screen is corrupted.

Haven't tried other resolutions yet.
My monitor is a Compaq V1100.
Comment 3 Mike A. Harris 2001-10-31 21:01:17 EST
To force the usage of XFree86 4.x, use "Xconfigurator --preferxf4"

Please attach your XFree86 log file, and config file using the link below.
Then we can proceed to troubleshoot this problem, and see what can be done.
Comment 4 Greg Bailey 2001-11-01 14:29:27 EST
Created attachment 36061 [details]
XFree86 4.1.0 configuration file
Comment 5 Greg Bailey 2001-11-01 14:30:49 EST
Created attachment 36062 [details]
XFree86 4.1.0 log file
Comment 6 Alan Hourihane 2001-11-06 09:39:05 EST
Can you try

Option "XaaNoPixmapCache"

in your Device section.
Comment 7 Greg Bailey 2001-11-06 11:34:27 EST
I tried adding option "XaaNoPixmapCache" as requested and unfortunately I get
the same results as before.  I'm attaching both the XFree86 config file and the
log file in case anyone needs to see it...
Comment 8 Greg Bailey 2001-11-06 11:36:03 EST
Created attachment 36641 [details]
Xfree86 4.1.0 log file (with XaaNoPixmapCache)
Comment 9 Greg Bailey 2001-11-06 11:37:08 EST
Created attachment 36642 [details]
Xfree86 4.1.0 configuration file (with XaaNoPixmapCache)
Comment 10 Alan Hourihane 2001-11-06 12:06:06 EST
Can you do an 'lspci -vn' for me.
Comment 11 Alan Hourihane 2001-11-06 12:08:33 EST
Can you also try this

VideoRam 4096

in your Device section. 
You can remove the XaaNoPixmapCache now too.
I suspect the driver could be misdetecting your board as an 8MB one where it 
really only has 4MB.
Comment 12 Greg Bailey 2001-11-06 12:54:27 EST
Adding "VideoRam 4096" seemed to clear the problem up.  No longer seeing any
corruption.  I'm attaching the output of "lspci -vn".
Comment 13 Greg Bailey 2001-11-06 12:55:32 EST
Created attachment 36662 [details]
Output of "lspci -vn"
Comment 14 Alan Hourihane 2001-11-06 13:17:32 EST
O.k. Your board is an ELSA Gloria Synergy.

Has it got a white socket without anything plugged into it ?

If not, your board really has only 4MB and you probably need to try and upgrade 
your VideoBIOS - not for the fainthearted.

If it does have something plugged into it then it could be defective memory.
Comment 15 Greg Bailey 2001-11-06 15:39:15 EST
I have 2 systems that both exhibited this problem.  They're both Compaq AP350
workstations, and each one has a video card with a label that says "Compaq
Gloria Synergy+".  Neither of the cards have anything plugged into the white
sockets, so according to what I can tell, each host has 4MB of video memory.

From my standpoint, I'm not sure if it's worth upgrading the VideoBios, when an
easy workaround exists.  If it really is the fault of the Video BIOS, then is
there the possibility of implementing a workaround in the probing routines?  Or
at the very least, a "gotcha" in the GLINT(4x) manpage?

Thanks again very much for the help!
Comment 16 Mike A. Harris 2002-05-30 02:07:03 EDT
Closing bug as WONTFIX due to it being a hardware bug.  I don't see any
simple configuration workaround that can be made automatically.  If
possible it would be nice if the driver could auto detect this card,
and work around it somehow.

Note You need to log in before you can comment on or make changes to this bug.