Bug 55055 - kernel-smp-2.4.9-6 panics on Dell
kernel-smp-2.4.9-6 panics on Dell
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-10-24 19:43 EDT by Hunter Hillegas
Modified: 2007-04-18 12:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-13 08:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hunter Hillegas 2001-10-24 19:43:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)

Description of problem:
Kernel kernel-smp-2.4.9-6, delivered recently causes a kernel panic 
on a Dell PoweEdge 2550 w/ RAID card.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install kernel
2. Boot system

Actual Results:  Panic

Expected Results:  Normal boot

Additional info:

Switching back to the stock kernel boots fine.
Comment 1 Matt Domsch 2001-10-24 22:24:58 EDT
Another customer john.emerson@yale.edu reported:
	7.1 installs and runs, but the current kernel patch in the mirror 
hoses the machine.  On reboot after the updates there are errors like

	/lib/aacraid.o: unresolved symbol
	ERROR: /bin/insmod exited abnormally
	Kernel panic: No init found.
Comment 2 Arjan van de Ven 2001-10-25 11:10:43 EDT
Question: you did upgrade mkinitrd and the other packages required for
installing the kernel first, right ?
Comment 3 Matt Domsch 2001-10-25 12:01:51 EDT
In John Emerson's case, he did a --force --nodeps on the install, which is 
probably why his broke.

In Hunter's case, he got the new kernel via up2date.
Comment 4 Hunter Hillegas 2001-10-25 16:04:40 EDT
Apparently it is a bug in up2date with the dependency list...

Another user states:

"I think the real issue is that the filesystem rpm in noarch needed
to be installed with other things in i386."

Is it possible that up2date didn't install the correct packages?
Comment 5 Cristian Gafton 2001-10-25 20:37:07 EDT
I'll try to see if I can hunt down a similar machine in our lab to check what is
going on. Without testing this on similar hardware it is hard for me to say
whether up2date needs to be smarter aout anything.
Comment 6 Ed Griffin 2001-10-26 15:41:45 EDT
I have tried to install this on 2 PowerEdge 2550's (Dual PIII 1GHz, 1GB RAM, 
RAID 1).  I installed all patches (kernel last always) from ftp.redhat.com from 
the i386, i686 and noarch directories.  Everytime I boot to the 2.4.9-6 kernel 
smp or uniprocessor the machine kernel panics and dumps a log file 
into /var/log.  I can forward this to anyone who would like to take a look.
Comment 7 Adrian Likins 2001-10-26 18:53:19 EDT
the kernel requires the correct filesystem rpm? or filutils?

[alikins@sludge i386]$ rpm -qp --requires kernel-2.4.9-6.i386.rpm 
rpmlib(VersionedDependencies) <= 3.0.3-1
modutils >= 2.4.6
initscripts >= 5.83
mkinitrd >= 3.2.2
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

That kernel doesnt seem to have any dep on "filesystem". The filesystem
package just provides "filesystem". So, just updating "kernel" will not
have brought in the "filesystem" package as best I can tell.
Comment 8 Adrian Likins 2001-10-26 18:57:04 EDT
One issue that might be related to the comment by  edg@ll.mit.edu on 10-26...

If you installed the i386 and the i686 "kernel" packages, and didnt
run "mkinitrd" manually, you only get one initrd created (the initrd
isnt arch specific). If those modules are not arch independent, that
may be causing the problem.

dunno if that is really the case, but something to look into.
Comment 9 Arjan van de Ven 2001-10-26 18:58:16 EDT
mkinitrd, which has the real dependency on the /initrd directory, depends on
Comment 10 Arjan van de Ven 2001-10-26 18:59:33 EDT
kernel modules are very architecture specific; i386 ones won't work with the
i686 kernel
Comment 11 Adrian Likins 2001-10-26 19:02:28 EDT
>mkinitrd, which has the real dependency on the /initrd directory, depends on

true. And even if nothing had the dep, up2date would find the new filesystem
package as an available update as well.
Comment 12 Ed Griffin 2001-10-29 09:31:37 EST
I only used the kernel's in i686 and I have tried the uni-processor, the smp 
and the enterprise and they all have the same results.  I also ran mkinitrd by 
Comment 13 Arjan van de Ven 2001-10-29 09:35:12 EST
edg@ll.mit.edu: but you DID upgrade the required filesystem package too, did
you? and you do have an /initrd directory in your root filesystem ?
Comment 14 Ed Griffin 2001-10-29 09:51:28 EST
I did install/upgrade to filesystem-2.1.0-2.1 from the noarch directory and yes 
I do have an /initrd directory in root.  Question... my /boot directory 
is /dev/sda2 and my / is /dev/sda3 (Dell utils are /dev/sda1) could that cause 
a problem?
Comment 15 Hunter Hillegas 2001-11-02 18:33:08 EST
So, what is our status now?
Comment 16 Hunter Hillegas 2001-11-03 13:11:15 EST
Is this issue resolved for the recently released kernel 2.4.9-12 that fixes 
the syn-cookie issue?
Comment 17 Matt Domsch 2001-11-12 16:39:28 EST
I'm not sure whose problem this is.  It appears to be a RHN problem because the 
customer simply ran up2date and was left with an unusable system.  If packages 
were upgraded manually (and all of them were updated), I believe it worked fine.
Comment 18 Adrian Likins 2001-11-12 17:20:54 EST
I think this bug report has way too many possibly not related threads
going on. 

hunter@guerrillabroadcasting.com: you updated with up2date correct? and then
got a kernel panic on reboot? Did up2date report any errors?  Can you provide
any more information about the kernel panic? (did it complain about missing
modules, "unable to mount /" etc?)

 Matt_Domsch@dell.com: can the bug report from   john.emerson@yale.edu
 be ignored as part of this report?

 edg@ll.mit.edu: You did manual installs of all the different kernel packages,
including a mkinitrd and filesystem update, and manually running "mkinitrd"
correct? And still saw all of them fail?
Comment 19 Hunter Hillegas 2001-11-12 17:40:03 EST
I ran up2date and there were no errors.

Kernel panics like this at boot:

	/lib/aacraid.o: unresolved symbol
	ERROR: /bin/insmod exited abnormally
	Kernel panic: No init found.
Comment 20 Matt Domsch 2001-11-12 17:58:06 EST
>can the bug report from john.emerson@yale.edu
> be ignored as part of this report?

Yes.  Upgrading RPMs by hand and doing the kernel separately worked fine for 
him.  They seemed related, but apparently are not.
Comment 21 Ed Griffin 2001-11-13 08:56:44 EST
I did everything by hand, including deleting the initrd's created by installing 
the new kernel and making new ones.  I have subsequently tried this on 2 other 
systems with the same results.  (PowerEdge 2400 and another 2550)  Everything 
installs fine and then when I reboot the kernel panics and the machine hangs.

Note You need to log in before you can comment on or make changes to this bug.