Bug 550699 - SIGSEGV in "QApplicationPrivate::isBlockedByModal(QWidget*)" in /usr/bin/smoltGui
SIGSEGV in "QApplicationPrivate::isBlockedByModal(QWidget*)" in /usr/bin/smol...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
abrt_hash:08bbb661b7a0a30699821d7fee0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-26 16:31 EST by jim1sanders
Modified: 2010-02-23 00:32 EST (History)
6 users (show)

See Also:
Fixed In Version: smolt-1.4.2-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 00:32:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.71 KB, text/plain)
2009-12-26 16:31 EST, jim1sanders
no flags Details

  None (edit)
Description jim1sanders 2009-12-26 16:31:14 EST
abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/smoltGui
component: python
executable: /usr/bin/python
kernel: 2.6.31.6-166.fc12.x86_64
package: python-2.6.2-2.fc12
rating: 3
reason: Process was terminated by signal 11
Comment 1 jim1sanders 2009-12-26 16:31:17 EST
Created attachment 380468 [details]
File: backtrace
Comment 2 Dave Malcolm 2010-01-04 13:24:38 EST
Thank you for reporting this bug.

How reproducible is this problem?  If you run the program from a terminal, is an error message printed?

What version of smolt-gui do you have installed?

Looking at the backtrace, it looks like the problem occurred in thread #1 in QApplicationPrivate::isBlockedByModal(QWidget*), though thread #2 also appears to be talking to the X server, whilst cleaning up PyQt; this happens when the application is exiting.

Reassigning component from "python" to "smolt", though it may be a PyQt issue.
Comment 3 Dave Malcolm 2010-01-05 11:23:43 EST
Jim sent me a direct email in which he indicated that this segfault is happening when run as a non-root user, but works when run via sudo; hopefully he won't mind me quoting his email here; I replaced the real UID with "THE_REAL_UID" below in case of privacy concerns:

[jim@localhost ~]$ /usr/bin/smoltGui
Unable to save UUID, continuing...
Your UUID file could not be created: [Errno 13] Permission denied:
'/etc/smolt/hw-uuid'
Segmentation fault (core dumped)
[jim@localhost ~]$ sudo /usr/bin/smoltGui
Error determining public UUID: [Errno 14] HTTP Error 500 :
http://www.smolts.org/client/pub_uuid/THE_REAL_UID
Unable to determine Public UUID!
Comment 4 Mike McGrath 2010-01-05 11:40:23 EST
Ok, i see what is going on here but I'm not quite sure on what to do to fix it.  Basically /etc/smolt/hw-uuid doesn't get created until the first smolt run, which normally happens at firstboot.  If not then it has to be run as root first to generate that file since we don't want normal users creating that file.  I'll think on what to do about this some.
Comment 5 Fedora Update System 2010-02-04 09:57:44 EST
smolt-1.4.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/smolt-1.4.2-1.fc12
Comment 6 Fedora Update System 2010-02-05 19:01:53 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smolt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1529
Comment 7 Fedora Update System 2010-02-23 00:31:33 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.