Bug 550704 - SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.
SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.
Status: CLOSED DUPLICATE of bug 542257
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:b119f51e79e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-26 17:33 EST by fredouille
Modified: 2009-12-28 06:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-28 06:24:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description fredouille 2009-12-26 17:33:43 EST
Résumé:

SELinux is preventing /usr/bin/qemu-system-x86_64 "write" access on sr0.

Description détaillée:

SELinux denied access requested by qemu-system-x86. It is not expected that this
access is required by qemu-system-x86 and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Autoriser l'accès:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Informations complémentaires:

Contexte source               system_u:system_r:svirt_t:s0:c267,c678
Contexte cible                system_u:object_r:virt_content_t:s0
Objets du contexte            sr0 [ blk_file ]
source                        qemu-system-x86
Chemin de la source           /usr/bin/qemu-system-x86_64
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         qemu-system-x86-0.11.0-12.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.32-59.fc12
Selinux activé               True
Type de politique             targeted
Mode strict                   Enforcing
Nom du plugin                 catchall
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.31.5-127.fc12.x86_64
                              #1 SMP Sat Nov 7 21:11:14 EST 2009 x86_64 x86_64
Compteur d'alertes            1
Première alerte              sam. 26 déc. 2009 21:56:49 CET
Dernière alerte              sam. 26 déc. 2009 21:56:49 CET
ID local                      5e5fa06a-b274-4520-9b40-c40d13d6a7ab
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1261861009.169:140): avc:  denied  { write } for  pid=13155 comm="qemu-system-x86" name="sr0" dev=tmpfs ino=3489 scontext=system_u:system_r:svirt_t:s0:c267,c678 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_file

node=(removed) type=SYSCALL msg=audit(1261861009.169:140): arch=c000003e syscall=2 success=no exit=-13 a0=7fff15d3d4b0 a1=1002 a2=1a4 a3=30 items=0 ppid=1 pid=13155 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-system-x86" exe="/usr/bin/qemu-system-x86_64" subj=system_u:system_r:svirt_t:s0:c267,c678 key=(null)



Hash String generated from  selinux-policy-3.6.32-59.fc12,catchall,qemu-system-x86,svirt_t,virt_content_t,blk_file,write
audit2allow suggests:

#============= svirt_t ==============
allow svirt_t virt_content_t:blk_file write;
Comment 1 Miroslav Grepl 2009-12-28 06:24:51 EST

*** This bug has been marked as a duplicate of bug 542257 ***

Note You need to log in before you can comment on or make changes to this bug.