Bug 550711 - ghc-GLUT-debuginfo contains no sources
ghc-GLUT-debuginfo contains no sources
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghc-GLUT (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2009-12-26 18:51 EST by Ville Skyttä
Modified: 2010-01-11 05:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-11 05:21:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2009-12-26 18:51:11 EST
ghc-GLUT-debuginfo 2.1.1.2-3.fc13 contains no sources, which might be an indication of $RPM_OPT_FLAGS (specifically -g) not being honored or binaries being stripped too early.  Is this expected behavior with ghc-* packages?  See bug 496968.

Same thing apparently with recent ghc-OpenGL, ghc-tar, and ghc-zlib Rawhide builds.
Comment 1 Bryan O'Sullivan 2009-12-27 14:21:52 EST
Hmm, none of the ghc-* packages should be emitting debuginfo packages:

# ghc does not emit debug information
%global debug_package %{nil}
Comment 2 Ville Skyttä 2009-12-28 15:11:02 EST
(In reply to comment #1)
> Hmm, none of the ghc-* packages should be emitting debuginfo packages:
> 
> # ghc does not emit debug information
> %global debug_package %{nil}  

Sorry to be blunt, but would you mind actually checking things before closing bugs?  All of the packages mentioned in the initial comment *do* emit debuginfo packages.  They have the line you cited commented out.

http://cvs.fedoraproject.org/viewvc/devel/ghc-GLUT/ghc-GLUT.spec?revision=1.6&view=markup
http://cvs.fedoraproject.org/viewvc/devel/ghc-OpenGL/ghc-OpenGL.spec?revision=1.6&view=markup
http://cvs.fedoraproject.org/viewvc/devel/ghc-tar/ghc-tar.spec?revision=1.4&view=markup
http://cvs.fedoraproject.org/viewvc/devel/ghc-zlib/ghc-zlib.spec?revision=1.18&view=markup
Comment 3 Bryan O'Sullivan 2009-12-28 17:30:31 EST
It's perfectly fine to be blunt, but I did actually check, but I looked at the F-12 branch rather than the devel branch.  It might be a good policy not to make accusations about what someone did or didn't do when you don't actually know. That could easily be misinterpreted as rudeness, which would not be so perfectly fine.

Jens, what's the story with the debuginfo generation being re-enabled?
Comment 4 Ville Skyttä 2009-12-28 18:01:46 EST
This bug is reported against rawhide, the initial comment specifically mentions a NEVR containing f13, there's no way I could tell that you checked F-12, and I think it's quite fair to assume that if rawhide had been actually checked, this bug would have not been closed as NOTABUG along with the text in comment 1.  But nevermind, mistakes do happen, I'll shut up now and let you find out the cause and what to do about it.
Comment 5 Jens Petersen 2010-01-06 19:55:00 EST
That's me sorry.

I reenabled debuginfo in rawhide for a few libraries as an experiment
since it strips the new shared libraries, but if that is stepping on
sanity script's I better do it right I guess.
Comment 6 Jens Petersen 2010-01-06 19:55:53 EST
bos: BTW feel free to reassign bugs relating to my changes to me. :)
Comment 8 Jens Petersen 2010-01-11 05:21:50 EST
Thanks Ville for catching and reporting it.

I reverted my little experiment in the latest builds.

Note You need to log in before you can comment on or make changes to this bug.