Bug 55074 - System hangs when mounting cdrom
System hangs when mounting cdrom
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 01:58 EDT by Thomas M Steenholdt
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 11:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas M Steenholdt 2001-10-25 01:58:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
When trying to mount the CD-ROM immediately after installation, system 
hangs. Doing the same thing, but using my CD-RW drive does not cause this 
problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
2. login as root on eg. tty1
3. toss a cd in the CD-ROM drive
4. mount /mnt/cdrom
	

Actual Results:  for a couple of seconds mount just seemed to struggle 
with spin-up etc. then it all hung completely(CD-ROM LED permanently on)

Expected Results:  mount should return without any problem, letting me 
access the contents of my CD in my CD-ROM drive

Additional info:

CD-ROM is on /dev/hdb, CD-RW is on /dev/hdc
Tried upgrading with all ERRATA as of Oct. 24th 2001(incl. new kernel), 
same problem
Comment 1 Arjan van de Ven 2001-10-25 06:35:13 EDT
Can you try "hdparm -d0 /dev/hdb" and then try to mount it ?
Some (well a LOT) of cdrom drives claim they can do IDE DMA, but just
hang the IDE bus when the operating system actually tries to use DMA.
Comment 2 Thomas M Steenholdt 2001-10-26 02:41:05 EDT
running `hdparm -d0 /dev/hdb' before mounting the cd-rom actually solves the 
problem. However I haven't had this problem before, on RHL71, is there any 
chance it could have been caused by my moving the cdrom device from hdc(master) 
to hdb(slave)... If you don't know the answer right off, don't spend any time 
looking for an answer - I will try it myself.

What's the correct way of making the new non-DMA setting stick?

Comment 3 Arjan van de Ven 2001-10-26 04:07:29 EDT
Making the hdparm stick is easiest done by adding the command to /etc/rc.local

Can you give me the output of

cat /proc/ide/hdb/model 

so that I can see if your cdrom drive is on the "don't do dma on these" list ?
Comment 4 Thomas M Steenholdt 2001-10-26 16:44:40 EDT
Here is the output of /proc/ide/hdb/model:
CRD-8400B

The writer(hdc)'s model is this:
10X4X32

And then i noticet that during boot this is what is shown about the devices:
ide: Assuming 33MHz PCI bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 11
    ide0: BM-DMA at 0xfff0-0xfff7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xfff8-0xffff, BIOS settings: hdc:pio, hdd:pio
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15

Seems to me, that the devices are actually detected correctly, but that info 
is not passed to the driver - or mayby I'm wrong!

Regards!
Comment 5 Thomas M Steenholdt 2001-10-31 01:30:11 EST
Instead of doing a hdparm -d0 /dev/hdb, doing a hdparm -d1 -X34 /dev/hdb also
solves my problem...

It still puzzles me, however... I have never needed anything like this on any of
my previous Linux installations. I should probably mention, that I DID move my
IDE devices around when I was about to install RHL7.2.
Comment 6 Giovanni Corriga 2001-11-07 17:41:40 EST
I have experienced the same problem. My CD-ROM is a CRD-8400B too (on hdc),
while my writer is a Waitec Shuttle (on hdd). I have caused system hangs coth
when mount a cd as root and as a normal user. I have solved the problem with
'hdparm -d1 -X34 /dev/hdc'
I haven't moved my IDE devices before installing RHL7.2.
Comment 7 Need Real Name 2002-01-24 12:30:01 EST
Well, I had the same problem, I solved in the same way, but before adding 
a "hdparm ..." issue, I tried to mount a NON ISO9660 (HFS CDROM) FileSystem 
thinking about a ISO9660-related bug... God! It worked fine!! So what about the 
DMA NonDMA PIO mode problems, if I was able to mount the CD Disk WITHOUT 
changing the hdparm... The funniest thing is during the installation process 
with the same kernel (2.4.7-10BOOT vs 2.4.7-10) the system recognized the CD-
ROM Drive perfectly!!! What a hell?!?!?
Any explanation here??
Comment 8 Jason Jones 2002-02-08 16:36:59 EST
I have a CRD-8400B on /dev/hda on an IBM NetFinity, and am having the same 
problem also.  No problems with previous Linux installs.
Comment 9 Arjan van de Ven 2002-02-11 12:41:16 EST
The BOOT kernel has dma disabled *hard*.

The drive is in the blacklist, but somehow this blacklist is getting ignored ;(
Comment 10 Thomas M Steenholdt 2002-04-15 11:38:35 EDT
This problem has disappeared from me after updating the kernel to 2.4.9-XX. I'm
not sure which one. The 2.4.9-31 has not got this problem at my machine!
Comment 11 Thomas M Steenholdt 2002-08-14 14:44:43 EDT
never saw this problem since - closing it - thanks for you help way back then :-)

Note You need to log in before you can comment on or make changes to this bug.