Bug 550790 - Please remove plexus-archiver pom and depmap from common poms.
Please remove plexus-archiver pom and depmap from common poms.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven2-common-poms (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 542341
  Show dependency treegraph
 
Reported: 2009-12-27 07:08 EST by Lubomir Rintel
Modified: 2010-06-01 17:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 17:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2009-12-27 07:08:26 EST
Description of problem:

plexus-archiver now depends on plexus-io, but maven is unaware of that which breaks its jar plugin: [1]. (running with -x reveals java.lang.ClassNotFoundException: org.codehaus.plexus.components.io.resources.PlexusIoResourceCollection).

[1] http://koji.fedoraproject.org/koji/getfile?taskID=1890757&name=build.log (might disappears since it's a scratch build)

Additional info:

Please add the following hunk to /usr/share/maven2/default_poms/JPP.plexus-archiver.pom:

    <dependency>
      <groupId>org.codehaus.plexus</groupId>
      <artifactId>plexus-io</artifactId>
      <version>1.0</version>
      <scope>compile</scope>
    </dependency>
Comment 1 Alexander Kurtakov 2009-12-28 03:56:34 EST
The problem was that plexus-archiver wasn't installing it's own pom. 
Your problem should be fixed with http://koji.fedoraproject.org/koji/taskinfo?taskID=1893249. 
What is needed now is to actually remove plexus-archiver pom from common poms so such problems don't go unnoticed.
Comment 2 Bug Zapper 2010-03-15 09:42:21 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Guido Grazioli 2010-05-11 20:22:56 EDT
Fixed in maven2-common-poms-1.0-14

Note You need to log in before you can comment on or make changes to this bug.