Bug 55082 - acenic driver on Kernel 2.4.9-6enterprise not loading on Netfinity 5500
acenic driver on Kernel 2.4.9-6enterprise not loading on Netfinity 5500
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 05:52 EDT by TC
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 21:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output (9.96 KB, text/plain)
2001-10-25 05:53 EDT, TC
no flags Details

  None (edit)
Description TC 2001-10-25 05:52:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
Netfinity 5500 RH 7.1 install, upgraded to 2.4.9-6enterprise kernel
3Com 3C985 Gigabit Ethernet NICOn 2.4.3-12enterprise, acenic driver loads
without problems.
On 2.4.9-6enterprise, attempting to ifup the card will cause kernel to loop
complaining that the acenic firmware is not running. System becomes unusable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot using 2.4.9-6enterprise on Netfinity 5500
2.ifup eth1 (acenic is eth1)
3.
	

Actual Results:  Kernel printk messages, complaining that firmware is not
running, and loops infintely trying to bring eth1 up.

Expected Results:  eth1 to be enabled correctly

Additional info:
Comment 1 TC 2001-10-25 05:53:58 EDT
Created attachment 35022 [details]
dmesg output
Comment 2 Arjan van de Ven 2001-10-25 07:01:26 EDT
We've been investigating a similar report yesterday and found the cause late
last night; I'll make a new acenic driver available later today.
Comment 3 Arjan van de Ven 2001-10-25 12:16:51 EDT
I've put the new sourcecode up on
http://people.redhat.com/arjanv/rhl72/acenic

download the files, make sure the kernel-source package is installed and
type :
make
and then cp the resulting acenic.o to it's final place:
cp acenic.o /lib/modules/`uname -r/kernel/drivers/net

Comment 4 TC 2001-10-26 21:22:15 EDT
Applying the patch fixes the Firmware loading problem. System currently running
on  Kernel 2.4.9-6enterprise + acenic patch with uptime of 20+ hours (to date).

Would there be a more automated fix to this short of manually applying the patch?
Comment 5 Arjan van de Ven 2001-11-03 12:57:34 EST
We released a kernel errata yesterday, which has this fix included.
Thanks for reporting the problem!

Note You need to log in before you can comment on or make changes to this bug.