Bug 55085 - dhcp client and token ring
dhcp client and token ring
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 06:25 EDT by Martin Garton
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 17:00:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Garton 2001-10-25 06:25:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.17-21mdk i686)

Description of problem:
The message "dhcpStart: interface tr0 is not Ethernet or 802.2 Token Ring"
appears in /var/log/messages and the dhcp client does not work with the
token ring card. The card is using the "olympic" driver. When using a
static IP, all is fine so it looks like a problem with dhdpcd. This worked
fine with this card using Redhat 7.1 although I cannot be sure dhcpcd was
being used then (maybe pump was the dafault??)
lspci describes the card as "Token ring network controller: IBM 16/4 Token
ring UTP/STP controller (rev 05)"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH7.2 on a machine with an IBM 16/4 Token Ring card
2. Attempt to set up the card to use dhcp
3. Watch it fail and see /var/log/messages for the reason.
	

Actual Results:  The interface tr0 was unavailable because it didn't know
what IP address to use

Expected Results:  If should have retrieved the IP and other info form the
dhcp server.

Additional info:
Comment 1 Bill Nottingham 2001-10-29 14:08:39 EST
pump was the default in 7.1.
Comment 2 Alex Holder 2001-10-30 18:36:41 EST
I had a similar problem using dhcpcd on a token-ring network.  In my case my
network card is an IBM Turbo 16/4 Token-Ring PC Card 2.  Under RedHat 7.1 client
dhcp (ie pump) worked out of the box; after installing Red Hat 7.2 client dhcp
(ie dhcpcd) wouldn't work at all.  

Uninstalling dhcpcd and installing pump (pump is on the 2nd cd) fixes the
problem.  This is most likely the case for many or most token-ring users.  This
issue should probably be listed in the install FAQ.
Comment 3 Kent Yoder 2001-11-20 17:00:36 EST
  Hi,

This is the patch included with the source code for the dhcpcd program in the
RH7.2 source rpm.  I believe the line:

+  &&   ifr.ifr_hwaddr.sa_family != ARPHRD_IEEE802)

should be:

+  &&   ifr.ifr_hwaddr.sa_family != ARPHRD_IEEE802_TR)

  This makes the dhcpcd program recognize the TR card, however, in all my tests,
dhcpcd still did not configure the TR cards.  "pump" from RH7.1 does work,
however, so there is probably a bigger problem with dhcpcd.

dhcpcd-1.3.17-tr.patch from RH7.2-CD3/SRPMS/dhcpcd-1.3.18pl8-13.src.rpm:

--- dhcpcd-1.3.17-pl5/client.c.tr	Wed Jun  2 07:08:58 1999
+++ dhcpcd-1.3.17-pl5/client.c	Wed Jun  2 07:11:44 1999
@@ -678,9 +678,10 @@
       syslog(LOG_ERR,"dhcpStart: ioctl SIOCGIFHWADDR: %m\n");
       exit(1);
     }
-  if ( ifr.ifr_hwaddr.sa_family != ARPHRD_ETHER )
+  if ( ifr.ifr_hwaddr.sa_family != ARPHRD_ETHER
+  &&   ifr.ifr_hwaddr.sa_family != ARPHRD_IEEE802)
     {
-      syslog(LOG_ERR,"dhcpStart: interface %s is not Ethernet\n",ifr.ifr_name);
+      syslog(LOG_ERR,"dhcpStart: interface %s is not Ethernet or 802.2 Token
Ring\n", ifr.ifr_name);
       exit(1);
     }
   if ( setsockopt(dhcpSocket,SOL_SOCKET,SO_BROADCAST,&o,sizeof(o)) == -1 )
Comment 4 Elliot Lee 2002-01-04 14:38:40 EST
I put a modified version of this patch in dhcpcd-1.3.21pl2-1 for rawhide, thanks.

Note You need to log in before you can comment on or make changes to this bug.