This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 550870 - virt-manager clone progress bar not indicative of actual progress
virt-manager clone progress bar not indicative of actual progress
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-27 16:22 EST by John Ruemker
Modified: 2010-05-06 23:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-virtinst-0.500.1-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 23:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of problem (96.61 KB, image/png)
2009-12-27 16:22 EST, John Ruemker
no flags Details

  None (edit)
Description John Ruemker 2009-12-27 16:22:11 EST
Created attachment 380557 [details]
screenshot of problem

Description of problem: The progress bar in virt-manager's clone function is not accurate.  When the clone begins it is at 0%, and then it immediately jumps to 100% and stays there for the remainder of the clone operation.  

This is fairly low-impact since the clone will eventually complete normally, but its confusing as it appears the tool has locked up when it is actually still progressing.  I killed virt-manager a number of times thinking it was just stuck before I realized that it was still cloning.

Version-Release number of selected component (if applicable):

virt-manager-0.8.2-1.fc12.noarch
libvirt-0.7.1-15.fc12.x86_64
kernel-2.6.31.9-174.fc12.x86_64

How reproducible: Always (for me at least)

Steps to Reproduce:
1. Create a domain (in my case RHEL4 and 5 on a logical volume
2. Stop the domain
3. Right click on it and hit 'Clone'
4. Fill in fields and click 'Clone' button
  
Actual results: Progress bar immediately jumps to 100% and stays there for the duration of the operation

Expected results: Progress bar should actually indicate the progress of the operation

Additional info: Screenshot attached
Comment 1 Cole Robinson 2010-02-26 21:19:31 EST
Fixed upstream, this fix is actually in python-virtinst:

http://hg.fedorahosted.org/hg/python-virtinst/rev/cb28868d9213
Comment 2 Fedora Update System 2010-03-21 20:49:52 EDT
python-virtinst-0.500.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/python-virtinst-0.500.1-3.fc12
Comment 3 Fedora Update System 2010-03-23 19:30:29 EDT
python-virtinst-0.500.1-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtinst'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-virtinst-0.500.1-3.fc12
Comment 4 Fedora Update System 2010-05-06 23:50:29 EDT
python-virtinst-0.500.1-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.