This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 550877 - SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacula/log.
SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacula/log.
Status: CLOSED DUPLICATE of bug 494037
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:4aa69ae508e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-27 17:26 EST by rvc.pobox
Modified: 2009-12-29 18:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-29 18:49:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rvc.pobox 2009-12-27 17:26:03 EST
Summary:

SELinux is preventing /usr/bin/perl "getattr" access on /var/spool/bacula/log.

Detailed Description:

SELinux denied access requested by logwatch. It is not expected that this access
is required by logwatch and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:logwatch_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_spool_t:s0
Target Objects                /var/spool/bacula/log [ file ]
Source                        logwatch
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.0-82.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-59.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.9-174.fc12.i686.PAE #1 SMP Mon Dec 21
                              06:04:56 UTC 2009 i686 athlon
Alert Count                   2
First Seen                    Sun 27 Dec 2009 03:30:03 AM EST
Last Seen                     Sun 27 Dec 2009 03:30:03 AM EST
Local ID                      d9076b49-7017-45f2-a50f-b2430200103f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1261902603.596:150): avc:  denied  { getattr } for  pid=14191 comm="logwatch" path="/var/spool/bacula/log" dev=dm-0 ino=5375290 scontext=system_u:system_r:logwatch_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_spool_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1261902603.596:150): arch=40000003 syscall=195 success=no exit=-13 a0=8e0e454 a1=8dea0c0 a2=2b0ff4 a3=8dea008 items=0 ppid=14185 pid=14191 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=17 comm="logwatch" exe="/usr/bin/perl" subj=system_u:system_r:logwatch_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-59.fc12,catchall,logwatch,logwatch_t,var_spool_t,file,getattr
audit2allow suggests:

#============= logwatch_t ==============
allow logwatch_t var_spool_t:file getattr;
Comment 1 rvc.pobox 2009-12-27 17:33:29 EST
I saw where some folks recommended to move the log files to /var/log/bacula:

  "append = "/var/log/bacula/daemon.log" = all, !skipped"

  "append = "/var/log/bacula/standard.log" = all, !skipped"

But even after restarting the services no entries were made to these files.
Comment 2 Daniel Walsh 2009-12-29 18:49:36 EST

*** This bug has been marked as a duplicate of bug 494037 ***

Note You need to log in before you can comment on or make changes to this bug.