Bug 55093 - dhcpcd does reset the IFF_MULTICAST flag
dhcpcd does reset the IFF_MULTICAST flag
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 10:49 EDT by jum
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 10:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jum 2001-10-25 10:49:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.12; Mac_PowerPC)

Description of problem:
dhcpcd does reset the IFF_MULTICAST flag if it was set by the 
ethernet driver to signal it supports multcasting. This causes modern 
software that uses the MULTICAST flag to autoconfigure to skip the 
interface in question. An example is OpenSLP and some AppleTalk 
software.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. load your ethernet driver, I used a 3c59x
2. run ifconfig eth0, the MULTICAST flag is turned on
3. run dhcpcd eth0
4. after having aquired an IP address run ifconfig eth0 again
	

Actual Results:  the MULTICAST flag is gone.

Expected Results:  The MULTCAST flag should not have been 
touched at all by dhcpcd.

Additional info:
Comment 1 Elliot Lee 2002-01-04 14:41:56 EST
Bugzilla is being mean and won't let me mark this a duplicate of #48669

Anyways, this is fixed in rawhide, all should be well in the future.

Note You need to log in before you can comment on or make changes to this bug.