Bug 55095 - [IRIX NFS] tcsh expansion dosn't work reliably
[IRIX NFS] tcsh expansion dosn't work reliably
Status: CLOSED DUPLICATE of bug 73877
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 11:01 EDT by s.maass
Modified: 2007-04-18 12:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description s.maass 2001-10-25 11:01:00 EDT
Description:
  File expansion in tcsh don't work properly in some NFS mounted directories.
  Nothing is happend when pressing <tab> is such a dir.  Doing a is < ls * >
  show nothing as well. With a bash these operation works perfect.

  The problem could not be verified on local (non-mounted) directories.


Versions:
  - Redhat 7.2 with all updates (tcsh-6.10-6, kernel-2.4.9-7, nfs-utils-0.3.1-13.7.2.1)
  - directories are mounted via NFS from an IRIX 6.5 machine

Comment:
  - Perhaps this has somithing in common with the bugs:  30944, 36897 ??
Comment 1 Robert Jones 2001-10-26 15:55:03 EDT
We have verified this bug in our environment.
Comment 2 Thomas J. Baker 2001-11-29 15:36:53 EST
I experience this same bug with both 7.1 and 7.2 and all their associated updates.
Comment 3 Joe Krahn 2001-12-04 11:46:37 EST
This is partly an IRIX NFS problem. Try upgarding IRIX to 6.5.14.
Comment 4 Thomas J. Baker 2001-12-06 08:02:33 EST
We're already running IRIX 6.5.14m.
Comment 5 Thomas J. Baker 2001-12-12 09:45:45 EST
Is this bug being looked at? It doesn't appear that anyone from Red Hat has
acknowledged it. It's fairly major for us as we have many older SGIs serving
disk space to our linux machines.
Comment 6 Michael K. Johnson 2002-01-04 09:31:28 EST
It has been suggested that this is a tcsh bug; that tcsh needs to be
rebuilt with -D_FILE_OFFSET_BITS=64

Based on that suggestion, I am reassigning this bug report to tcsh.
Comment 7 Preston Brown 2002-01-07 15:31:47 EST
can you folks please try:

ftp://people.redhat.com/pbrown/tcsh-6.10-6test.i386.rpm 

and report if it fixes your problems?
Comment 8 Thomas J. Baker 2002-01-08 10:25:32 EST
The new version of tcsh seems to work in the two cases I was having problems.
How soon until this patch is official? Thanks...
Comment 9 Robert Jones 2002-02-26 18:07:00 EST
This appears to work in our environment as well, please merge the changes into
your production tree as soon as you can.  Thanks,  Rob.
Comment 10 Frank Bures 2002-04-23 16:33:24 EDT
The patched tcsh solves the problem between 2.4.9-31smp kernel and IRIX6.5.12f in CLI.
However it does not solve the related problem described in bug 54941.  NFS mounted volumes on IRIX6.5 are still invisible from VMware 3.1 running
over 2.4.9-31smp kernel.  Kernel 2.4.3-12 does not exhibit this problem.
Is there any probability, that this problem, that has been around for quite a while now, will ever be solved?  We have a considerable number of 
machines that must be kept at 2.4.3-12 level solely because of this bug.


Comment 11 Thomas J. Baker 2002-08-05 11:20:25 EDT
What's happening with this bug? The version of tcsh in 7.3 has the same version
number 6.10-6 as the test rpm but doesn't fix the bug. So even though you have a
fix, it hasn't been pushed out yet. There must be other issues?
Comment 12 Need Real Name 2002-08-12 16:16:38 EDT
We had this problem and adding the 32bitclients flag to /etc/exports on the IRIX
box fixed it.
Comment 13 daryl herzmann 2004-01-13 22:18:59 EST
For the archives, I recently ran into this bug(?) after an 
upgrade on the IRIX NFS server to 6.5.22 .  Here is a typical 
error.

% tcsh
% cp v_otg0012180602.dat_control ../../etaplot
cp: writing `../../etaplot/v_otg0012180602.dat_control': Permission denied
% bash
$ cp v_otg0012180602.dat_control ../../etaplot
$ exit

very sparatic behavior with tcsh (6.12-4 rh9) and none with bash while
inside of the NFS mounted directories (-32bitclients flag on)

I rolled by own from tcsh.org and it seems to have fixed the error...   
Comment 14 Miloslav Trmač 2004-08-17 09:12:25 EDT

*** This bug has been marked as a duplicate of 73877 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:48:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.