Bug 55097 - bad: xconfig fails, good: config & menuconfig works
bad: xconfig fails, good: config & menuconfig works
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 11:11 EDT by Mika Länsirinne
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-03 12:45:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mika Länsirinne 2001-10-25 11:11:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.10 i686)

Description of problem:
In kernel-source -package:
There is a typo in drivers/net/Config.in: an additional line 278 which
contains "P" should be removed. "make config" & "make menuconfig" don't
fail, but "make xconfig" fails at the start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /usr/src/linux-2.4
2.make xconfig
3.
	

Additional info:
Comment 1 Mika Länsirinne 2001-10-25 11:19:04 EDT
The additional "P" in the line 278 belongs to the end of line 277, the last
letter in the word "$CONFIG_PPP".

<=> there is just additional line break inside "$CONFIG_PPP".

Comment 2 Mika Länsirinne 2001-10-25 11:22:03 EDT
The additional "P" in the line 278 belongs to the end of line 277, the last
letter in the word "$CONFIG_PPP".

<=> there is just additional line break inside "$CONFIG_PPP".

Comment 3 bammi 2001-10-25 12:42:04 EDT
Similarly there is another bug that trips up make xconfig (but not 
config/menuconfig) in drivers/addon/Config.in, line 7 is missing an " m" at the 
end of the line (the default value for CONFIG_NET_BROADCOM).

++jrb
bammi@cadence.com
Comment 4 Michael Schwendt 2001-10-26 04:55:24 EDT
Duplicate of bug #55025.
Comment 5 Alan Cox 2001-11-03 12:44:13 EST
The PPP one is fixed in my base tree. The Broadcom one is RH specific 
Comment 6 Arjan van de Ven 2001-11-03 12:49:04 EST
fixed in the yesterday released kernel erratum (2.4.9-12 for 7.1 and 2.4.9-13
for 7.2)

Note You need to log in before you can comment on or make changes to this bug.