Bug 55101 - Installer crashes every time I try to update/install RH7.2
Installer crashes every time I try to update/install RH7.2
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 12:07 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-28 09:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-25 12:07:41 EDT
When I try to install RH7.2 the installer crashes in the beggining of the
process of installing the RPMs it self. it install 3 or 4 packages and then
it stops incrementing the progress bar, after that I can switch terminals
with alt-f3 for a few seconds and then it freezes hard, after that only a
reset gets me out.

Once when I tried the text instalation it printed a kernel panic in the
ext2 module, I didn't catch the message. :-/

This problem happen EVERY time I try to install red-hat 7.2 in my home
computer. It is a K6-2 550 Mhz with a ASUS P5AB motherboard and a single
IDE HD from samsung (this I am not 100% sure) and a HP CD recorder.it has
128 Mb of memory. A All-in-wonder pro video board (rage-pro based card with
4mb of memory). A SB-awe 64 (isa version). Two ethernet controlers (one old
ne200, is not found by the installation)
Comment 1 Brent Fox 2001-10-25 15:34:15 EDT
Is there a debug message when the installer crashes that you could attach to the
bug report?  I think that you might have a bad cd. 

Also, the reason that your ne2000 ethernet controller is not found is probably
because it is ISA instead of PCI.  If it is ISA, then it will not be
automatically detected because kudzu can't probe ISA devices like it can for PCI
devices.
Comment 2 Need Real Name 2001-10-25 19:16:15 EDT
I get no error messages at all, I tried to reproduce the time I got the kernel
panic error I stated above but got no luck. :-/

The process locks up when it is installing Glibc-2.2.4-13, usualy at the end,
but sometimes it stops before that. When the progress bar stops the ide leds
stops blinking and stays lit. After that I can switch terminals for a while and
then it halts for good. If I am in a FB virtual terminal I can see it is locked
for good when the text cursor stops blinking. 

Also I tried to play a little with kernel params, no luck I tried the following
options : 

linux ideo=autotune -> this seems to have detected a ALi15x chip, but the
windows device manager tells me that it is a ALiM5229.

linux ide0=dma
linux ide0=serialize
linux idebus=66 

None of those options made any diference.
Comment 3 Brent Fox 2001-10-26 09:51:25 EDT
Hmm...did you verify the md5sums of the ISOs before using them?  The hanging on
package installation makes me think that the cdrom might be corrupted somehow.
Comment 4 Need Real Name 2001-10-26 12:57:38 EDT
I did check the MD5 sum of the ISOs, and I also installed another system with
the same disk without any problem at all. :-/ 

I've seen that there is a kernel update, is there a boot disk for the
instalation with this kernel? I could test to see if the install goes well with
the new kernel.
Comment 5 Brent Fox 2001-10-26 14:50:24 EDT
There is not currently a new boot disk for the installer.  katzj, msf tells me
that you were working on one.  Is this true and do you think it would resolve
the problem in this bug report?  Or do you think there are hardware related
problems with the machine in question here?
Comment 6 Need Real Name 2001-10-26 14:59:47 EDT
I think that this is a kernel related problem. It could be hardware, but since
this same hardware goes througth a redhat 7.1 instalation with no problems, and
it failed to install both the beta and the release versions of redhat 7.2, I
would say that it must be in somethig that is working diferently in the 7.2
release? 

I don't know if the hardware access changed from 7.1 to 7.2, maybe it is a ext3
related bug? 

I am not creating a new boot disks, I lack the expertize to do this. :-/
Comment 7 Need Real Name 2001-10-26 19:01:44 EDT
I MADE IT!!!! I managed to install it. I had to format my installation partition
with the mkreiserfs that is bundled in the CD. WIth reiser FS as the target
partition the installation went nice til the end. :-) :-)
Comment 8 Brent Fox 2001-10-27 10:18:29 EDT
Ok, I'm glad things are working now but I don't understand what the problem was
to begin with.  Do you want me to close this report now or do you want to try
and reproduce the problems you were seeing?
Comment 9 Need Real Name 2001-10-28 09:28:02 EST
Well I had some instability problems with the RH 7.2 after the installation. I
had some lockups and had to reset, just like the instalation. I added ide=nodma
to grub and it become more stable. Checking the system logs I found some
interesting items : 


Oct 26 22:27:25 victor kernel: hda: timeout waiting for DMA
Oct 26 22:27:25 victor kernel: ide_dmaproc: chipset supported ide_dma_timeout
func only: 14
Oct 26 22:27:25 victor kernel: hda: status timeout: status=0xd0 { Busy }
Oct 26 22:27:25 victor kernel: hda: drive not ready for command
Oct 26 22:27:25 victor kernel: ide0: reset: success
It seems that this is related to the problem. Since I had turned off ide dma it
worked just fine. Now I am not shure if this is some faulty hardware (controler
or disk) or if this is normal in some setups. :-/ I have read somewhere that DMA
could be dangerous, is it true? 

In an unrelated problem I noticed that my eth0 was also unreliable sometimes it
simply did not work. The with a littler research I found out that RH7.1 used the
dmfe kernel module, and the RH7.2 used the tulip driver. I swicthed the driver
in the /etc/modules.conf and it worked til now, since I just started it once I
am not 100% shure it worked. Maybe I should open a new bug report for this, what
do you think?
Comment 10 Brent Fox 2001-10-28 10:19:46 EST
The problems you are seeing now are kernel related.  Since the installer seemed
to work ok, I would recommend filing a new bug against the kernel describing the
behavior you are now seeing.
Comment 11 Need Real Name 2001-11-09 16:09:06 EST
This happened to me too. 7.2 hangs in a random spot when installing RPMs, but
it hangs every time.  Sometimes I get through 100 files before it hangs.

I also have an HP CD writer, CD-Writer Plus 7200.
And an FIC  VA503+ mother board with an AMD K-6 400 mhz processor.

I am installing to my second ide drive, hdb:
hda: ST320420A, 19458MB w/2048kB Cache, CHS=2480/255/63
hdb: Maxtor 90845D4, 8063MB w/256kB Cache, CHS=1027/255/63

------------------------------------------------------------------------
I discovered a work around to the problem that makes it go away:

use "ide=nodma" as a boot parameter during the boot process.

This was mentioned in the previous post.
-------------------------------------------------------------------------

My other versions of linux use this:
"hdc=ide-scsi"
and that may work too but I have not tried it yet...

Note You need to log in before you can comment on or make changes to this bug.